Jump to content

Unable to launch Media Browser


Netbug
 Share

Go to solution Solved by ebr,

Recommended Posts

80% of the time when I launch MB Classic, I am getting the error "unable to launch media browser".

It seems to be occurring more and more frequently. If I wait 20-30 minutes, sometimes it will allow me to launch, sometimes not.

It is only replicable when I first start up the computer as I have to wait between 10 to 30 minutes before I can launch MBC.

Windows 8
MB Server Version: 3.0.5083.27698
MB Classic Version: 3.0.100.0 B12-4.1

Problem occurs on launch of MB Classic either from desktop shortcut or from within Media Center.

No error in Event Logs for the time of the errors.

 

MBClassic Log: https://dl.dropboxusercontent.com/u/1233738/MBClassic-14102013c7490222ccc542c4b9bbf7391da1b5cd.log

MB Server Log: https://dl.dropboxusercontent.com/u/1233738/server-63522466581.log

 

Any suggestions?

Link to comment
Share on other sites

Is the server on the same machine and also starting up at the same time?

 

(the mbc log you provided appears to be two months old...)

Link to comment
Share on other sites

Is the server on the same machine and also starting up at the same time?

 

(the mbc log you provided appears to be two months old...)

 

Yes, the server is on the same machine as the client in this case. It is not always starting at the same time. When I boot the machine, the server launches. I have to wait about 15-20 minutes before I can launch MBC without it throwing that error.

 

When the server has been running for some time (anywhere from bootup onwards), I will often attempt to launch MBC and it will throw that error. I will go away for 10 minutes or so, try again, and sometimes it will launch, sometimes it errors again.

 

It's the last MBC log I have. Let me check again for a newer one... for some reason that is the latest entry in that directory, despite MBC being run almost daily. Could I have disabled logging accidentally somehow?

Edited by Netbug
Link to comment
Share on other sites

Yes, you may have disabled logging.  First page of the config area in MBC.

 

I'm pretty sure this is a problem with the current server release.  It is simply un-responsive during its initial library scan.  That has been improved for the upcoming release.

Link to comment
Share on other sites

Strangely enough, it hasn't crashed in the last 3 days. There was a server update, so that possibly corrected something.

 

I've got logging enabled now, so if it happens again, I will post the log.

 

I'll leave this topic unsolved for a few days to see if it crashes again.

Link to comment
Share on other sites

Not strange.  As I said, the previous server was very non-responsive during start up.  Glad it has improved for you.

Link to comment
Share on other sites

My setup has been doing the same thing for the past week. Initially I thought it may have been something my system that had gone wonky. Having uninstalled all MB3 programs, cleaning, then reinstalling, the problem persists. The server has been upgraded to 3.0.5099.2102 but sadly the problem persists.

 

https://www.dropbox.com/s/b0pg14ww2v14vrh/MBClassic-15122013064366886c6c40f78eea4d6a3932de66.log

https://dl.dropboxusercontent.com/u/83193122/server-63522679706.log

 

Sorry, forgot to mention that MBT and the Android client all work as they should with the setup. Just can't figgure out why MBC won't play the game :(

Edited by KnowEyeDear
Link to comment
Share on other sites

  • 1 month later...

I just upgraded from MB2 to MB3 and I'm quite frustrated.  I cannot get MBC to open at all. I get the error message "Unable to launch media browser 3".  Launching through WMC.

 

Server Version 3.0.5135.311685

MBC version 3.0.117.0 B1-23.1

OS is Win7 SP1 64bit

 

I've tried everything. Uninstalled, reinstalled, remapped my libraries using UNC, No plugins installed except chocolate.  I'm a paid supporter because I liked MB2 so much but I can't get MB3 to work at all.

 

Link below is to my server and MBC logs:

https://www.dropbox.com/sh/5177lo59ecwyf5r/91N2vi_L7j

 

please help

 

If I need to revert back to MB2, will my supporter key I purchased work for MB2?  I couldn't find anywhere to purchase a supporter key for MB2.  This is my second attempt at upgrading to MB3.  Tried it a month or so back and had the same problem and just gave up and went back to MB2.  Do I need to do that again?

Link to comment
Share on other sites

I just upgraded from MB2 to MB3 and I'm quite frustrated.  I cannot get MBC to open at all. I get the error message "Unable to launch media browser 3".  Launching through WMC.

 

Server Version 3.0.5135.311685

MBC version 3.0.117.0 B1-23.1

OS is Win7 SP1 64bit

 

I've tried everything. Uninstalled, reinstalled, remapped my libraries using UNC, No plugins installed except chocolate.  I'm a paid supporter because I liked MB2 so much but I can't get MB3 to work at all.

 

Link below is to my server and MBC logs:

https://www.dropbox.com/sh/5177lo59ecwyf5r/91N2vi_L7j

 

please help

 

If I need to revert back to MB2, will my supporter key I purchased work for MB2?  I couldn't find anywhere to purchase a supporter key for MB2.  This is my second attempt at upgrading to MB3.  Tried it a month or so back and had the same problem and just gave up and went back to MB2.  Do I need to do that again?

 

HI, you may want to start a new thread for your issue.

 

I have had a few teething problems getting MB3 to work, but I think the great result is worth the effort.

 

I have come up with a sequence that works well for me for installing the client for when things are not working. Maybe worth following this and see if it helps your case, note the warning below.

 

1) Stop the server service

 

2) Deinstall MBC client from Windows Control Panel > Programs

 

3) Clear the ClickOnce cache from a command window with Admin privilege using: rundll32 %windir%\system32\dfshim.dll CleanOnlineAppCache.

 

Note this will deinstall all apps installed via .Net click once mechanism. I found this was needed to clear out MBC - but if you have other apps beware you will need to reinstall them too.

 

4) Delete the mediabrowser classic folder in c:\programdata

 

5) Delete any mediabrowser folders for all user accounts under the hidden folder appdata\roaming

 

6) Run the MBC installer - it will not connect to the server which is OK

 

7) Restart the server

 

8) Run MBC configuration program and point it at the server / userid required

 

9) Restart MBC

 

10) Reconfigure MBC to your needs

Edited by GhostRider
Link to comment
Share on other sites

  • Solution

Before you go through all of that, look in your Windows\ehome directory for a "chocolate.dll".  If it is there, delete it.

  • Like 1
Link to comment
Share on other sites

Before you go through all of that, look in your Windows\ehome directory for a "chocolate.dll".  If it is there, delete it.

 

THANK YOU THANK YOU THANK YOU!

 

I can't believe I've been beating my head against the wall for something that was as easy to fix as that.  I deleted the chocolate.dll and it's working!  I really appreciate your prompt support.  You have renewed my faith in MB!

Link to comment
Share on other sites

Okay, now look back in that ehome folder and delete any other MB theme dlls that may be in there.  Look for:

 

neo

vanilla

diamond

pearl

jade

lotus

subdued

 

DON'T delete any other dlls from that folder other than those.

Link to comment
Share on other sites

I'd be glad to, but I'm not sure how to mark it solved.  

 

52e448730f6f9_marksolved.png

 

Be sure to do it on my answer, not your post.  Thanks.

Link to comment
Share on other sites

I'm not sure what I'm missing, but the only buttons I see are Send Message, Report, MultiQuote, Quote, and Like This.  Sorry to be high maintenance.  I just didn't want you to think I wasn't grateful for your help.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...