Jump to content


Photo
- - - - -

Loading external players from EMC

MPC-HC ArcSoft TMT5 Virtual Clone Drive Elaborate Bytes VCD mount iso LAV MadVR

  • Please log in to reply
15 replies to this topic

#1 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 04 January 2016 - 05:04 PM

Scenario:

 

Using EMC (Media Browser Classic in WMC).

Loading External Players.

 

Issues:

1. When loading MPC-HC with MadVR from EMC it sometimes starts to play audio only but sometimes plays fine. I either need to right click a mouse (not very reasonable as this is supposed to be all controlled with a remote) to get the file to play or I need to try repeatedly by stopping the playback and starting over from one to three times to get video playback.

 

2. ISO mounting. I have the configurator set to load TMT5 set for playback for ISO only and I have Elaborate Bytes Virtual Clone Drive set as the ISO mounter in the ISO and Extender tab. I have Mikhano's ISO mounter for WMC also installed. The iso's are not mounting nor playing back, unless I mount them prior to loading EMC which is not good as EMC loads when WMC loads when I Select HTPC on my Harmony Remote.

 

Any assistance would be appreciated.. My logs from yesterday and previously when this occurred will not open correctly and I get the following from ServiceStack:

Response Status
Error CodeOutOfMemoryExceptionMessageException of type 'System.OutOfMemoryException' was thrown.Stack Trace[GetLogFile: 1/4/2016 8:54:42 PM]: [REQUEST: {Name:server-63587389501.txt}] System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown. at System.Text.StringBuilder.ToString() at System.IO.StreamReader.<ReadToEndAsyncInternal>d__19.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task) at MediaBrowser.Server.Implementations.HttpServer.HttpResultFactory.<GetStaticResult>d__7.MoveNext()

I will try to grab a log immediately next time this occurs but stopping to do something like that lowers WAF tremendously!

 

Thanks.



#2 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 05 January 2016 - 12:41 PM

Anyone?

 

I still haven't had time to grab a log but it seems to be working pretty well with MPC-HC/LAV/MadVR right now.

 

Opening ArcSoft TMT5 WMC player for ISO playback goes to a screen trying to open a web page with the typical warning that the webpage is not optimized for WMC. When I click "Cancel" it returns to EMC, ready to click "Play" again which, of course, repeats the same action again.

 

Thanks.



#3 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 05 January 2016 - 12:50 PM

Here's the log.. Hope it can be opened. BTW, my testing should be time stamped somewhere between 4:30 and 5:00 if that helps.


Edited by Sammy, 05 January 2016 - 12:51 PM.


#4 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 05 January 2016 - 01:10 PM

Maybe this log will have what you need??



#5 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 01:33 AM

Posted 05 January 2016 - 01:14 PM

The server log won't tell us what is happening on the client side.  We would need to see the EMC log.

 

But, this sounds like a failure outside of our app - as in somewhere in the ISO mounting.

 

I would try setting up the mounting in EMC and using AutoPlay to actually start the player.



#6 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 05 January 2016 - 01:16 PM

Can you direct me to how to do this? I had it working perfectly in MB 2.6.x but haven't been successful in Emby. I'm not sure if Mikhano's ISO automounter is working or not.. Let me remote into my HTPC and I'll post the Emby Classic settings I have.. It'll be a bit. 



#7 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 05 January 2016 - 01:29 PM

568bfd78ed916_Tab2.png568bfd34ca941_Tab1.png



#8 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 01:33 AM

Posted 05 January 2016 - 01:36 PM

I'm sorry but we will probably need someone who has an ISO setup to help out with specific configuration.  There are some around so hopefully, they'll chime in.



#9 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 05 January 2016 - 01:43 PM

I hope so too. I think I'll cross post over at AVS or Green Button.

 

I appreciate the help you have provided to this point. Thanks!



#10 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 05 January 2016 - 06:49 PM

So I played around with using the native video library in WMC and it loaded TMT5 perfectly with the exception of not being able to playback Blu-ray 3D iso over a remote session (which I still need to test on the HTPC to verify that it works). I then changed the player set up such that all but ISO is played back with MPC-HC and deleted the TMT5 WMC player in the Emby Configurator completely. When loading the iso in Emby, it loads the TMT5 WMC player but again I'm not able to play it back over an RDP. I will continue to test that later but forward I go. I'm just a little concerned about the lack of support for TMT5 going forward as ArcSoft apparently no longer sells or supports TMT. Unless they've disabled it in some way that I cannot see over RDP from afar I should be good to go as I wasn't upgrading it anyhow due to the Cinavia "bug" in later versions.



#11 Overseer OFFLINE  

Overseer

    Advanced Member

  • Members
  • 245 posts
  • Local time: 09:33 PM
  • LocationYelm, WA, US

Posted 05 January 2016 - 10:31 PM

May I ask why your ripping to ISO? Are you copying the entire disk or just main movie?

 

I've ripped my 3D movies to MKV using MakeMKV and renaming the extension to MK3D and then have Stereoscopic Player set as the external player in the EMC configurator.  My Vizio TV recognizes the stream and gives me the appropriate query to either switch to 3D mode or 2D mode.

 

Don't know how it would work over RDP but could be worth a test or two.



#12 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 05 January 2016 - 10:47 PM

May I ask why your ripping to ISO? Are you copying the entire disk or just main movie?
 
I've ripped my 3D movies to MKV using MakeMKV and renaming the extension to MK3D and then have Stereoscopic Player set as the external player in the EMC configurator.  My Vizio TV recognizes the stream and gives me the appropriate query to either switch to 3D mode or 2D mode.
 
Don't know how it would work over RDP but could be worth a test or two.


Well. Because I always did it like this before my HTPC failed me. Ha!
A few things.. How to properly rip to mkv for full frame 3D playback? Does stereoscopic player behave with a remote? Does it load from Emby Configorator in EMC?

FYI.. I was merely remoted in from work today trying to get things right. I will test it in my living room tomorrow morning.

#13 Overseer OFFLINE  

Overseer

    Advanced Member

  • Members
  • 245 posts
  • Local time: 09:33 PM
  • LocationYelm, WA, US

Posted 05 January 2016 - 11:24 PM

Download MakeMKV (which is free while in beta) and it will rip the movie for full-frame 3D playback (no conversion; file size will be the same as it is on the disk).

 

Sadly, Stereoscopic Player doesn't work very well with a remote.  It is a barebones player that just happens to play MVC files well.  It isn't free, there is a cost, but you can download a trial (will play the first 5 minutes only) to test things out.  It is set up to run via the configurator.



#14 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 01:33 AM

Posted 05 January 2016 - 11:37 PM

If you can avoid ISOs, do.



#15 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 06 January 2016 - 11:00 AM

Download MakeMKV (which is free while in beta) and it will rip the movie for full-frame 3D playback (no conversion; file size will be the same as it is on the disk).

 

Sadly, Stereoscopic Player doesn't work very well with a remote.  It is a barebones player that just happens to play MVC files well.  It isn't free, there is a cost, but you can download a trial (will play the first 5 minutes only) to test things out.  It is set up to run via the configurator.

I have MakeMKV and just updated it on Sunday. What are the settings to rip 3D Blu-ray?

 

Can I instead use TMT5 to playback 3D MVC / mkv's?



#16 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 3533 posts
  • Local time: 10:33 PM

Posted 06 January 2016 - 11:03 AM

If you can avoid ISOs, do.

 

I am happy to report that I got it working. I set the configurator to play all but iso using MPC-HC/MadVR and deleted using TMT5 to playback iso. When I click on an iso, TMT5 loads (and after clicking cancel on that annoying "Upgrade Available, which it isn't because ArcSoft no longer supports this product) the 3D iso immediately loads! Pretty sweet.

 

Now, if there's a frame packed player for 3D mkv's that works with a remote, I'd like to know about it! 

 

Thanks for all the help, all of you.







Also tagged with one or more of these keywords: MPC-HC, ArcSoft, TMT5, Virtual Clone Drive, Elaborate Bytes, VCD, mount, iso, LAV, MadVR

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users