Jump to content

Media Browser Diamond Plugin


Trev22
 Share

Recommended Posts

Hi all, firstly let me apologise as I doubt this is the correct place to post this, but I have been unable to get help anywhere else....I have had to re-install windows due to a catastrophic failure....I have re-built and am still using Media Browser 2.6.2, but I am not quite ready to use EMBY...I have now lost my original plugin for the Diamond theme because I was unable to save the file programdata/mediabrowser/plugins/configuration settings....The question is have I now lost this for ever, or is there still a chance to do something about it so my MC shows as it used to....Thanks in advance for any help that may be available....

Link to comment
Share on other sites

You are in the right place but I'm afraid I don't have any of those old plug-ins anymore.

 

Perhaps another user will be able to help...or, you could upgrade to Emby :).

Link to comment
Share on other sites

Hi ebr and thanks for the reply.....Gutted you no longer have it, but hopefully someone else can help as you said. I will look at upgrading soon, but I am just not ready at the mo... :)

Link to comment
Share on other sites

  • 1 month later...

I don't know what the final version of diamond was? @@BAS

 

I have version 0.3.6.0 Hope that helps you out

 

https://dl.dropboxusercontent.com/u/1349444/Diamond.dll

 

 

I also have the source 

 

https://dl.dropboxusercontent.com/u/1349444/DiamondTheme.dll%20%26%20source..rar

 

If that is the right one it is your lucky day if not maybe you can dig into the source and make the changes required.

  • Like 2
Link to comment
Share on other sites

  • 4 weeks later...

Nope thats a really old version and not at all the right one.

 

I gave away Diamond theme to another developer who maintained it for a while on Google Code. 

 

I believe Google Code has been shutdown and therefore the code may have been lost forever - unfortunately I cannot remember the name of the repository it was hosted under.

Link to comment
Share on other sites

Also I seem to have been removed as a developer from this site so I can't even view version info... I suppose my lack of activity is to blame.

 

Oh well.

Link to comment
Share on other sites

OMG - He lives!  :)

 

Welcome back.

 

ST - if you wish to start being involved again, I will gladly restore your dev privileges.  The new Emby Theater can be skinned with html and js much, much easier than EMC.  I'm sure the community would love to see you start cranking out skins for it...

  • Like 1
Link to comment
Share on other sites

@@ebr Sure no harm in checking out the Theater development platform as long as it's stable. 

 

I assume by easy you are using npm, ES6, react, gulp etc...

Link to comment
Share on other sites

I don't know if I'd call it "stable" just yet but two guys are working on new skins right now.

 

Check out the Emby Theater forum in the dev area.

Link to comment
Share on other sites

@@ebr Sure no harm in checking out the Theater development platform as long as it's stable. 

 

I assume by easy you are using npm, ES6, react, gulp etc...

 

npm yes but it's not exposed to the UI, which means you're limited to pure web api's. ES6 is not used in the core due to the desire to have a smart tv version and those browsers are always a little behind. But skinners can use whatever they like inside their own skin and decide what devices they want to support. We're not using react, it's almost entirely pure javascript, but I'm fine with making it available for skinners to pull in via amd if they like.

Link to comment
Share on other sites

  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...