Jump to content


Photo
- - - - -

Genre Link Not Working

Genre

  • Please log in to reply
5 replies to this topic

#1 kbeck OFFLINE  

kbeck

    Member

  • Members
  • 16 posts
  • Local time: 11:49 AM

Posted 26 December 2015 - 04:26 PM

Hi all. I changed over to Emby from Media Browser this week. Everything seems to work well. Server, accessing Movies from 2 different computers (both thru Emy for WMC). I have everything organized and am using xml files created by Media Center Master.

 

What I noticed was that if I click on one of the Genres within a movie, I get a blank screen with "No Items". If I click on one the Cast "Persons" that works fine. Kinda stumped because I guess they both look at the XML file but 1 works and 1 doesn't.

 

I will check from within a browser, am not at home right now. Any suggestions?

 

Thanks

 



#2 Riff OFFLINE  

Riff

    Newbie

  • Members
  • 1 posts
  • Local time: 10:49 AM

Posted 16 March 2016 - 09:10 PM

Did you ever get this figured out?  I'm having the same problem.

 

If I access the genres through the web client, they work perfecly.  In WMC, I have the same thing you're getting: No Items.



#3 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47503 posts
  • Local time: 10:49 AM

Posted 17 March 2016 - 08:39 AM

Sorry, I missed this one, I guess since it was while I was gone over Christmas.

 

Luke, something must have changed to affect the url I'm sending.  Can you tell what is  wrong here?

2016-03-17 08:35:12.5518 Info HttpServer: HTTP GET http://192.168.1.120:8096/mediabrowser/Users/5b48ed39-9904-2084-abe1-6d27a0e88e9c/Items?ParentId=2a448e1b3c040b5da8c5f7a94a25041a&sortBy=&fields=Overview,SortName,DisplayMediaType,Path,DisplayPreferencesId,DateCreated,Taglines,Metascore,MediaStreams,ParentId,DateLastMediaAdded,MediaSources,SpecialEpisodeNumbers&Filters=&ImageTypes=&recursive=True&genres=Action&Ids=&studioIds=&ExcludeItemTypes=&IncludeItemTypes=Movie&ExcludeLocationTypes=&personIds=&personTypes=&years=&format=Json. UserAgent: 
2016-03-17 08:35:12.6068 Error DtoUtils: ServiceBase<TRequest>::Service Exception
	*** Error Report ***
	Version: 3.0.5919.23735
	Command line: C:\Users\Eric\AppData\Roaming\MediaBrowser-Server\System\MediaBrowser.ServerApplication.exe
	Operating system: Microsoft Windows NT 6.1.7601 Service Pack 1
	Processor count: 8
	64-Bit OS: True
	64-Bit Process: True
	Program data path: C:\Users\Eric\AppData\Roaming\MediaBrowser-Server
	Application Path: C:\Users\Eric\AppData\Roaming\MediaBrowser-Server\System\MediaBrowser.ServerApplication.exe
	Object reference not set to an instance of an object.
	System.NullReferenceException
	   at MediaBrowser.Api.UserLibrary.ItemsService.<GetItemsToSerialize>d__10.MoveNext()
	--- End of stack trace from previous location where exception was thrown ---
	   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
	   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
	   at MediaBrowser.Api.UserLibrary.ItemsService.<GetItems>d__5.MoveNext()
	--- End of stack trace from previous location where exception was thrown ---
	   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
	   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
	   at MediaBrowser.Api.UserLibrary.ItemsService.<Get>d__0.MoveNext()



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139960 posts
  • Local time: 10:49 AM

Posted 17 March 2016 - 12:09 PM

I don't know, but if you have the genre item prior to making this call, you can do genreids=xxx instead of genres=xxx



#5 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 47503 posts
  • Local time: 10:49 AM

Posted 17 March 2016 - 04:36 PM

So what you are saying is that form of retrieving genres may no longer work?

 

EMC has always just dealt with genres as strings.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139960 posts
  • Local time: 10:49 AM

Posted 17 March 2016 - 04:37 PM

No they both work, i was just pointing that out. As of now I don't know what the actual issue is here.







Also tagged with one or more of these keywords: Genre

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users