Jump to content

Xbox One DLNA Transcoding


LqHnyBear
 Share

Go to solution Solved by LqHnyBear,

Recommended Posts

LqHnyBear

How can I tell why something is transcoding when playing to my Xbox One? I have an mkv file with ac3 audio and for some reason it's being transcoded instead of playing directly. It's never had to transcode mkv with ac3 audio before when playing to the Xbox One. I tried looking in the transcode log but can't make heads or tails of what it's talking about. I'm on server Version 3.0.5781.4

 

 

log.txt

Link to comment
Share on other sites

Does the mkv contain subtitles?

 

Ac3 audio always transcodes to my Xbox one.

 

That device will be then of me....

Edited by chef
Link to comment
Share on other sites

Hmm..

 

That video file should indeed direct play to Xbox.

 

If you look at the media info generated by emby at the bottom of episode page in the web client, does it match what was generated by mkvmerge (or whatever program you used to generate the media info text readout post above)?

 

Under the DLNA options for your Xbox device is ac3 listed in the audio codec area for direct play?

(I realize you mentioned this hasn't happened before, which I believe means you have other ac3 audio codec mkv files which direct play..)

 

Emby transcodes everything to my Xbox one dispite codecs.

Edited by chef
Link to comment
Share on other sites

After reading the git hub link that Luke provided, I would say that your bitrate is to high in that mkv.

 

You could first try and up the bitrate in the transcoding settings or you could re-encode the file with a lower bitrate using ffmpeg.

 

The bitrate is really high in that encoding of the arrow, so my guess is that perhaps the other version of the arrow series you have, might be a 720p version or ones with lower bitrates.

 

Thank you @@Luke

Edited by chef
Link to comment
Share on other sites

Happy2Play

After reading the git hub link that Luke provided, I would say that your bitrate is to high in that mkv.

 

You could first try and up the bitrate in the transcoding settings or you could re-encode the file with a lower bitrate using ffmpeg.

 

The bitrate is really high in that encoding of the arrow, so my guess is that perhaps the other version of the arrow series you have, might be a 720p version or ones with lower bitrates.

 

Thank you @@Luke

Exactly, so is 10Mbps the limit on Xbox One or can it be raised like most other devices?

 

Mediainfo

Overall bit rate                         : 11.1 Mbps

 

From Xbox One Profile - DLNA-Select Profile-Info-Playback Settings

Max streaming bitrate:

10000000

Edited by Happy2Play
Link to comment
Share on other sites

Exactly, so is 10Mbps the limit on Xbox One or can it be raised like most other devices?

 

Mediainfo

Overall bit rate : 11.1 Mbps

 

From Xbox One Profile - DLNA-Select Profile-Info-Playback Settings

Max streaming bitrate:

10000000

I have tried to raise the limit in the past with poor results. Unfortunately, the mkv files I have with high bitrates just play as poorly as if I was transcoding an mkv with DTS audio.

 

Personally, I went through all my media files with an app I made from the API, and collected the ones with high bitrates, then put each through ffmpeg to lower them. All because of the Xbox one...

 

I found that changing the bitrate to anything Up to 10M was best.

 

This was, of coarse, an extreme measure I took.

Edited by chef
Link to comment
Share on other sites

LqHnyBear

I run giggernet throughout my place and have some mkv that are as high as 20Mbps. I know I had a custom profile at one point for the Xbox One and the files streamed without transcoding flawlessly. I must of screwed up the profile somehow or it got corrupted. I'll try changing it again and see what happens. I'll let you know.

Link to comment
Share on other sites

  • Solution
LqHnyBear

Yep, my profiles was fubar. I deleted it and remade it, I then set the "Max streaming bitrate:" to "100000000" and now it plays with no transcoding and the playback is flawless. Thank you for the help everyone.

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...