Jump to content

Images on Home Screen


lja
 Share

Recommended Posts

With the recent server upgrade (5781), In Emby for WMC, Under music, there are: Playlists, Albums etc. listed. However there are no images. Where would I place the images on the server for them to show in Emby for WMC? Thanks.

Link to comment
Share on other sites

Ian-Highlander

Was about to post a similar thread, although slightly different. Having been using Emby for a long time now, my system had been upgraded over and over again and all the images for those sub-views sat nicely in the general folder in the imagesbyname directory. However having just done a completely clean, start over installation after a bit of a "toys out of pram" moment the other night when it all "broke", I'm having a bit of a nightmare with that part of it.

 

Managed to eventually get my custom icons into every main view (user specific caught me out because I set them as me not realising I had to set them on my wifes account seperately which is the main one we use on the living room media pc).

 

Anyway, I digress. All done apart from the sub-view icons the OP is referring to, I've tried all sorts of locations to fit into the new metadata folder structure, I've read thread after thread of info on here and am just getting more and more confused.

 

@@ebr, perhaps you can help/advise where we're supposed to put these icons in the folder structure with this new layout please?

Edited by Ian-Highlander
Link to comment
Share on other sites

I'm afraid the server is moving farther and farther away from the old style of presentation customization used by long-time EMC folks.

 

The first thing to do is attempt to edit images for anything you can directly from the web client home screen.  Anything that cannot be found in the web client in order to customize the image may be a bit hard to deal with going forward.

Link to comment
Share on other sites

I'm afraid the server is moving farther and farther away from the old style of presentation customization used by long-time EMC folks.

 

The first thing to do is attempt to edit images for anything you can directly from the web client home screen.  Anything that cannot be found in the web client in order to customize the image may be a bit hard to deal with going forward.

Does this mean that the images would no longer be available as below:

 

https://dl.dropboxusercontent.com/u/19298307/music.JPG

Link to comment
Share on other sites

Ian-Highlander

@@ebr

 

That's extremely frustrating especially given that the only reason I switched to this type of view (only a couple of months ago) in the first place was because YOU personally advised me to do so because it couldn't handle the quantity of my music collection with just a plain "music" top level view. You advised to switch to the sub views which would split it to various categories and although I hadn't tested it very thoroughly it did appear to be working and a couple of builds ago was working perfectly as far as icons are concerned by adding folders for each one to a general folder in the ibn directory.

 

Are you saying this now can't be done and that your previous "fix" is now only any good to me if I put up with blank images constantly? or is there any other way round this? I realy don't want to have to switch to another media system as I've spent a long time getting this how I want it and it's set up around the house for all members of my household. I've also found the support to be excellent which is more than can be said for some others. Is there a way of making this work at all please?

 

Cheers

 

Ian

Edited by Ian-Highlander
Link to comment
Share on other sites

Ian-Highlander

Looking at the folder structure created. Under Metadata/views there are 195 folders with some kind of umid as the folder name of which only three or four have anything in them and those are the collections/playlists views I've set up and added images to through the web interface.

 

Is it possible some of these empty folders are the sub-views which we can't currently put images on? If so is there a way of identifying which is which and just adding images to the appropriate directory in there?

 

@@ebr @@Luke

Link to comment
Share on other sites

We'll need Luke to chime in as I know the server has been making changes to how images for these types of things are handled.

Link to comment
Share on other sites

I am having a similar issue with Favorites ( which I have renamed New Releases).

I no longer see the assigned image for this virtual folder, everything else remained the same. 

 

563a4ad2b8021_Untitled.jpg

Link to comment
Share on other sites

Same her, "Movies by Genres" and "Favorites" are not showing the images anymore.

 

Also I get no "rated" icons anymore in Emby for WMC.

 

I have there "0", "6", "12", "16" and "18" in the xml files and in the folder "ImagesByName\MediaInfo\All" the "rated_0.png" etc which worked without problems in older versions but now I have no rating at all in the movies and series.

 

How can I get that back?

 

Is not nice to know if the content is child proof or not.

 

In the web interface and the android client the rated is simply displayed as text and working.

 

Ciao,Alfred

 

Link to comment
Share on other sites

Ian-Highlander

We'll need Luke to chime in as I know the server has been making changes to how images for these types of things are handled.

Are we to assume from the silence that Emby for WMC is being deprecated and is no longer any kind of priority? Are other things going to suddenly "stop working" or is there actually any chance of getting this fixed at all please?

 

I'm now building a second "test" system on a virtual machine and all further updates will be being done on that and thoroughly tested before I upgrade my main system again and if there are further issues then I will have to cease upgrading completely which is a damn shame because there is some cool functionality appearing and I don't want to miss out on any new features but I can't have the system breaking further each time I do an "upgrade".

 

Is there any hope at all for us poor Emby for WMC users or are we just being considered a dying breed? I appreciate a huge effort is being put into Emby Theatre now but it's still very much an unknown quantity for most of us. I can't speak for everyone else of course but we also use WMC in general for all our TV including recordings so Emby for WMC is extremely convenient (and everyone in the house is familiar with it).

  • Like 1
Link to comment
Share on other sites

We'll need Luke to chime in as I know the server has been making changes to how images for these types of things are handled.

 

@@Luke

 

Any response?

Link to comment
Share on other sites

I realize that Emby Classic is now somewhat legacy and not getting much attention, but I really do hope this gets fixed at some point.

 

I am old school still running Emby Classic and this and the Hide Empty Folders bugs are driving me nuts.

  • Like 1
Link to comment
Share on other sites

I don't think it's a problem with the emby classic, I think it's the new server version.

 

Until release 3.0.5781.0 I had the following (working!) setup:

 

The metadata of a movie or serie has a rating of age 0. I have pictures for this rating in two folders

 

ibn\general\0\folder.png

ibn\mediainfo\all\rated_0.png

 

Not sure which one was used, I think it was the one from the mediainfo folder.

 

This isn't working anymore, so I added two pictures

 

\ibn\mediainfo\all\rated_de_0.png (for germany)

\ibn\mediainfo\all\rated_ch_0.png (for switzerland)

 

None of this pictures is displayed. The text isn't displayed too and I can't see which rating a movie or series has. There's no rating in the emby WMC client and the emby app.

 

I saw something in the source about a folder "Ratings" and I added this folder with the images in a subfolder named "all". They aren't displayed too.

 

This change of image handling is a big fail. No actual documentation, no notes, just nothing and no answers here in the forums. The new metadata/IBN folder logic is an undocumented disaster. Until the last release Emby was a great software but for now it is just unusable. With a family with children of different ages it's a must to see the ratings - if it's not possible as image anymore then as text.

 

Edit: I forgot to mention that the studio pictures in the film and series details pages also disappeared.

Edited by knoebe
Link to comment
Share on other sites

Ian-Highlander

Any images that in previous versions you could store in the ibn/general folder now don't work. This previously was a way of adding images to folders that didn't have one or weren't manageable through the interface. Now we're simply left with loads of blank folders with no images, ugly doesn't begin to cover it.

Link to comment
Share on other sites

With the recent server upgrade (5781), In Emby for WMC, Under music, there are: Playlists, Albums etc. listed. However there are no images. Where would I place the images on the server for them to show in Emby for WMC? Thanks.

 

Currently a customization process for these images has not been defined yet, but you can remove these categories altogether by opening your user preferences in the web interface and disabling the enhanced view for your music library. this will return it to the same folder-style view you had before.

Link to comment
Share on other sites

There is a fix for ImagesByName\General in today's server release. If you had already had the update prior to 10 minutes ago, then you should download again from the website as i just patched it in there.

Link to comment
Share on other sites

Ian-Highlander

Hi @@Luke

 

Just trying this now, can you confirm which version it is that has this support back in it please. I notice the latest blog says version 3.0.5781.2 is released, but the site has that as a beta download. Is this imagesbyname fix in that or in 3.0.5781.1 ?

 

Many thanks for listening and restoring this functionality.

 

Edit: just tried *.1 from the website and it doesn't appear to be fixed in that, so I'm guessing it's *.2 is there any issues with running the "beta" (if it's not mis-labelled)?

Edited by Ian-Highlander
Link to comment
Share on other sites

Ian-Highlander

Ok I've just updated to 3.0.5781.2 from the website and dropped a Playlists folder with thumb.jpg and folder.jpg images into IBN\General restarted Emby Classic and still not getting an image for Music/Playlists. Has the way this works changed due to the removal/readding please @@Luke or am I doing something daft?

Link to comment
Share on other sites

Did we ever have the ability to customize that? I thought ImagesByName was primarily about media info icons. I would think those are hopefully resolved.

Link to comment
Share on other sites

Ian-Highlander

Thanks @@Luke and if that's all that was fixed then it won't have addressed the issue that is affecting quite a few people judging by the different threads that have been started recently. The mediainfo icons was a small part of the issue of the imagesbyname/general folder being deprecated unfortunately and not the key one (at least not for me and a few others).

 

I may not have explained what I meant very well however, so...

 

In Emby Classic, if I select the "Music" menu/folder/option/whatever name you prefer, I then have several sub menus (Playlists/Albums/Album Artists/Genres/Favorites).

 

Prior to a couple of releases ago, you could customise those images by creating a folder spelled exactly the same within the General folder in the imagesbyname directory and then drop a folder.jpg and thumb.jpg into that directory and that would be used as the image for that menu/folder/whatever.

 

As it is currently they show as blank image holders with no image at all, this happened initially a couple of releases ago. It was all working beautifully up until then.

 

Edited to add some screenshots to illustrate the problem:

 

564a669d94517_2015111623_24_17bedroomRem

 

564a66a9611e2_2015111623_26_13bedroomRem

 

564a6705333c5_2015111623_29_36kurgan_338

Edited by Ian-Highlander
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...