Jump to content


Photo

Wake to record?

record wake win10

  • Please log in to reply
34 replies to this topic

#1 91esprit OFFLINE  

91esprit

    Advanced Member

  • Members
  • 63 posts
  • Local time: 06:32 PM
  • LocationToronto, Ontario, Canada

Posted 05 September 2015 - 11:25 AM

Is my pc supposed to automatically wake up from sleep to do a scheduled TV recording like WMC does?

Mine is not doing that.

 

Server Version 3.0.5724.3

Windows 10



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:32 PM

Posted 05 September 2015 - 01:21 PM

that was just an oversight. we'll fix that for the next release.


  • 91esprit likes this

#3 91esprit OFFLINE  

91esprit

    Advanced Member

  • Members
  • 63 posts
  • Local time: 06:32 PM
  • LocationToronto, Ontario, Canada

Posted 26 October 2015 - 10:41 AM

Did this get fixed?

My install isn't waking up to record.

Do I need to install as a service?

 

 

Version 3.0.5768.6



#4 91esprit OFFLINE  

91esprit

    Advanced Member

  • Members
  • 63 posts
  • Local time: 06:32 PM
  • LocationToronto, Ontario, Canada

Posted 27 October 2015 - 03:57 PM

Can someone please answer?

Did this get fixed?



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:32 PM

Posted 27 October 2015 - 04:08 PM

i missed this one, sorry. we'll try to get to it soon.



#6 Nathanio OFFLINE  

Nathanio

    Advanced Member

  • Members
  • 370 posts
  • Local time: 12:32 AM

Posted 28 October 2015 - 02:41 AM

I was just about to ask the same thing as I missed some recordings overnight. I'll keep my server awake for the time being. 



#7 nsmal24 OFFLINE  

nsmal24

    Advanced Member

  • Members
  • 35 posts
  • Local time: 12:32 AM

Posted 21 January 2016 - 08:10 AM

Luke, have you ever got around to fixing this? I just tested and my Windows server didn't wake for a recording. Could be a bug with my system though. On current dev. Thanks!

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:32 PM

Posted 21 January 2016 - 12:42 PM

It's not implemented yet, sorry. It's on our to do list.



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:32 PM

Posted 21 January 2016 - 01:54 PM

This is available on the dev and beta branches for testing, but supported only on Windows for right now.



#10 nsmal24 OFFLINE  

nsmal24

    Advanced Member

  • Members
  • 35 posts
  • Local time: 12:32 AM

Posted 21 January 2016 - 02:07 PM

Wow, thanks for turning that around. I'll update and give it a try!

#11 nsmal24 OFFLINE  

nsmal24

    Advanced Member

  • Members
  • 35 posts
  • Local time: 12:32 AM

Posted 22 January 2016 - 08:12 AM

Updated, tried one last night and no wake. There was another update this morning, so I updated and tried again. Same, no wake. Running current dev on Windows 7. Server is running as app. Does it need to be running as a service for some reason?

#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:32 PM

Posted 22 January 2016 - 10:28 AM

it's only for new recordings going forward, not existing ones.



#13 nsmal24 OFFLINE  

nsmal24

    Advanced Member

  • Members
  • 35 posts
  • Local time: 12:32 AM

Posted 22 January 2016 - 10:57 AM

it's only for new recordings going forward, not existing ones.


These were new recordings, not previously scheduled. Basically, I waited until 10 minutes before the hour or half hour, opened the guide in emby (chrome), picked a show that was starting in 10 minutes, scheduled the recording (not a series), double-checked that it scheduled, the manually put the server to sleep. Neither time I tried did it wake the computer. I visually checked the computer to make sure that it wasn't waking properly and just failing to record.

Edited by nsmal24, 22 January 2016 - 08:07 PM.


#14 rikiwi OFFLINE  

rikiwi

    Advanced Member

  • Members
  • 438 posts
  • Local time: 11:32 AM
  • LocationNew Zealand

Posted 22 January 2016 - 07:27 PM

Just thought i'd add my 2 cents worth.

I have done exactly as nsmal24 has done 3 or 4 times, and every time the PC has woken up and recorded the program perfectly.

I'm running Windows 10, and my power setting is - Balanced, and goes to sleep after 30 minutes.

Emby version - 3.0.5844.0

‚ÄčI'm using NPVR as my back end between my 3 tuners and Emby.

 

I'm not sure if that helps but any information shared may be of assistance.

 

PS. I just noticed that my recordings are missing about a minute from the start as I have my pre-padding set to 0. I will change it to 1 minute and do more testing and report back.


Edited by rikiwi, 22 January 2016 - 07:44 PM.


#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:32 PM

Posted 22 January 2016 - 09:31 PM

This only applies to the built-in live tv service. If you're using an alternative back-end like nextpvr, it takes over responsibility of managing your recordings.



#16 nsmal24 OFFLINE  

nsmal24

    Advanced Member

  • Members
  • 35 posts
  • Local time: 12:32 AM

Posted 22 January 2016 - 11:08 PM

This only applies to the built-in live tv service. If you're using an alternative back-end like nextpvr, it takes over responsibility of managing your recordings.

 

I am using the built-in live tv service.  I have switched a couple of times back and forth from built-in and ServerWMC.  WMC has always been able to wake the machine to record.  I'm trying some things (updating drivers, bios, etc.).  I may just upgrade to 10, but that's a project for another day.



#17 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 07:32 PM

Posted 23 January 2016 - 10:48 AM

What level of "sleep" does your machine go to when you tell it to sleep?



#18 nsmal24 OFFLINE  

nsmal24

    Advanced Member

  • Members
  • 35 posts
  • Local time: 12:32 AM

Posted 23 January 2016 - 11:34 AM

What level of "sleep" does your machine go to when you tell it to sleep?

 

S3.  Hibernate is disabled (powercfg /h off).  I just updated the server to Win 10 Pro this morning.  I will report back as to if it makes a difference.  For anyone else having problems or trying to troubleshoot, CPU is i7 4790S, Mobo Asrock Z79 Killer, Onboard graphics, Avago/LSI 9361-8i RAID controller.


Edited by nsmal24, 24 January 2016 - 11:09 AM.


#19 nsmal24 OFFLINE  

nsmal24

    Advanced Member

  • Members
  • 35 posts
  • Local time: 12:32 AM

Posted 23 January 2016 - 12:49 PM

powercfg /waketimers reveals   "Timer set by [PROCESS] \Device\HarddiskVolume5\Users\smalley\AppData\Roaming\MediaBrowser-Server\System\MediaBrowser.ServerApplication.exe expires at 7:53:00 PM on 2/4/2016" which tells me that it can indeed set a wake time (in this case, waking the computer 5 minutes (plus 2 min buffer) before Big Bang Theory starts). I canceled a series and rescheduled it but that did not add wake timer for the newly scheduled episodes and neither does manually scheduling a single recording from the web client guide.



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156920 posts
  • Local time: 07:32 PM

Posted 23 January 2016 - 02:11 PM

Ok, I think the answer might be that it requires elevation, and if that's true that pretty much kills this feature because nobody's going to want to do that.

 

In order to test, you can find the server executable and run it as admin. Then create a new recording.


  • nsmal24 likes this





Also tagged with one or more of these keywords: record, wake, win10

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users