Jump to content

Subtitles on Samsung SmartTV UE40F6510


Recommended Posts

Hello,

 

I will open a discussion that I think will be useful for many Samsung SmatTV users!

I am not capable to see subtitles with the latest beta Emby 3713.3 on Windows 10 system for a .srt file. When I send the video to "My Devices" (laptop) and I choose the .srt file from beginning (and only at the beginning of movie) the subtitle is visible. In the middle of the movie don't work.

When I send to [TV]Samsung LED40 the caption don't work everything I do. I have changed the subtitle with Remote Button, the movie re-start but all the time without caption. I want to see the subtitles in Romanian language and the extensions of the subtitle files are in .srt. All my movies are in .mp4 extension.

Do you have a solution to solve this issue or I must wait a new version of Emby? With the previous stable version, I can do nothing. The subtitles are not visible everything you choose or change on "My Devices" or TV.

 

Thank you for help!

Link to post
Share on other sites
FrostByte

I'm assuming you are NOT usig the Samsung app then if you're using the "Send To" command.  Where are you using the "Send To" command from when sending it to you TV, from your Emby server?

Link to post
Share on other sites

I use 3.0.5713.3 Server. First you select from "Cast" the player (when you start movie, this will be send at to default selected earlier). Here are all the connected devices: My device, [TV]Samsung LED40 (for my network).

Link to post
Share on other sites
FrostByte

Gosh, thanks.  I just did a fresh install of my computer and I haven't used the webclient to send a movie in a long time.  I forgot you had to select a device first now when using the webclient.  Okay, I think I'm seeing the same as you.  I can get a movie to "play to" my Samsung TV using the webclient now and using the remote I can see the subtitle I want (there is only one) but it isn't showing on my TV.  In my playback settings I have Eng subtitles preferred and "always play subtitles" chosen.  My subtitles are in format title.eng.forced.srt   In the remote it says the subtitle is forced, but it isn't displaying like you said.

Link to post
Share on other sites

Sorry for the inadvertance that I have made in the title of this post! I talk about a Samsung SmartTV UE40F6510!!!

Title edited.

Link to post
Share on other sites

My subtitles are in format title.eng.forced.srt

Is that how you get forced subtitles to work? You have to have forced in the name of the subtitle file?

Link to post
Share on other sites
FrostByte

Srt subtitles no longer work for me in the Emby Samsung app since chess reenginered it so I have been using DLNA for all my movies with subtitles lately.  However, that seems to no longer work either.  I can't get the webclient or Win app to send a movie with subtitles playing anymore.  My other option is to reencode them all with subtitles burned in the video and that is taking forever :)

  • Like 1
Link to post
Share on other sites

Yes, this is a solution for 2D movies but if you have 3D movie? How do you reencode, it is possible? It is a 3D SmartTV! What software and how?

Link to post
Share on other sites
FrostByte

I have the 3D extended version of the Hobbit movies and was able to burn in the Elvish subtitles using DVDFab.  I usually use Handbrake for 2D, but HB won't do 3D mkv files.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...