Jump to content


Photo

Theme: blue neon night


  • Please log in to reply
1534 replies to this topic

#21 kaelin OFFLINE  

kaelin

    Member

  • Members
  • 29 posts
  • Local time: 08:35 AM

Posted 24 October 2015 - 09:02 PM

Just got my Roku 4 today.Quickly hooked it up tonight and having trouble with theme blue neon. The first time I fired it up, I was able to go to preferences. Changed it to the 40Mbps and changed remember user to "No". It then kicked be out to the Roku home screen. Now it seems to kick me back out to the Roku home screen after a few seconds every time. The normal Emby app seemed to be OK. I'll do some more testing with it after the OSU game.



#22 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 24 October 2015 - 09:21 PM

After you change the remember user to "no" this wont have an affect until the current user logs out. If you leave the app and come back it will still be that user. If you choose "sign out" it will move you back to the "choose user" screen. At this point quit the app. Now whenever started it will ask for a user. You dont have to sign out, everytime you log in. Just that once after you change the setting. This is how it works in the normal app and this app.

As far as it randomly exiting, this might be caused by the server scanning media. When the server is scanning, the server may not reply fast enough. The app will receive a timeout. The app requires metadata from the server to complete its task to finish loading the "detail screen". The normal app crashes into the brightscript debugger when this occurs, you get stuck at retrieving, and the app stops responding. You can only press the home button to get out, which takes you back to the roku homescreen. When this occurs in the blue neon app I have it crash back to the roku homescreen directly. This might be what you are witnessing, maybe..? Other times, you just see the 4 options at the bottom: search, preferences, change server and sign out. Nothing else, no movies, no tv, etc shows up after logging in. This is also caused by the server scanning and what percentage you are and such. It is predictable and reproduceable behavior. So this isnt a bug in the app, hopefully. :)

It works best and most responsive when there are no tasks running in server dashboards "scheduled tasks" page

But yes, report back on h265/hevc/vp9 direct playback. This would be the main benefit of the roku4 at the moment besides it just being faster.

Sent from my Nexus 7 using Tapatalk

Edited by speechles, 24 October 2015 - 10:02 PM.

  • shann1674 likes this

#23 kaelin OFFLINE  

kaelin

    Member

  • Members
  • 29 posts
  • Local time: 08:35 AM

Posted 24 October 2015 - 10:07 PM

I did a little more testing. It would bring up the "choose user" screen every time but when I selected my user, it would enter the app and crash if I scrolled down. I tried logging in with the kids users and everything was working fine. Logged back into my user and crashed again. I turned off the channels on my account. The trailers plugin is the only channel I had. Now I can log in with my user and everything is working. Turned the trailers plugin back on and it crashes again. So there must be something going on with that. I'll just leave the trailers plugin turned off for now since I don't really use it anyway.

 

Besides the speed increase, I got the Roku4 for the netflix and amazon 4k content. Not really crazy about the built-in apps on the TV. Plus I wanted to put the Roku3 in the kids room. I'll try to get some h265 content and test it tomorrow.

 

Thanks for the great work on this. The theme looks great and will work well until we get the scene graph app. I'm a Java developer by day and wish I had more time to dive into brightscript.



#24 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 27 October 2015 - 08:37 PM

edd84fbd220c5d23c33c649c8735c062.jpg

New version, changes below:
* When transcoding use 5.1 AC3 when 5.1 DTS/AC3 track is chosen, for everything else use 2.0 AAC
* MKV container with MPEG4 video stream will transcode XVID/DIVX CodecTag
* Any container with MPEG4 video stream will transcode DX50 CodecTag
* Make the missing/upcoming auto-detect as accurate as possible

This makes automatic detection of the direct-play/transcoding engine almost perfect. There is really no need for options regarding directplay, directstream(remux), or transcoding. That is, if you do things right. In a perfect world, the software should intelligently decide what is best, and now it is much closer to that goal. Thanks to everyone who reports issues with playback and follows through with logs and other added information requests.

Roku users, if you have the app already, you need just do a system update to make sure it's the latest. Everyone else, links in first post of the thread. ;)

@EduardoSantos This should correct the problem you had with "mkv with mpeg4 in divx/xvid = no video" verus "avi with mpeg4 in divx/xvid = video". Yes, it has everything to do with the container as you suspected. Nice work gumshoe. *wink* (nod to carmen sandiego). If you could check the problem videos again with the updated app you can confirm this as solved. Thanks.

Edited by speechles, 28 October 2015 - 06:39 AM.


#25 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 29 October 2015 - 01:28 AM

One of my televisions with surround sound only supports dolby. Any DTS tracks played have no audio. This is no good. The software should automatically detect this. Now it can with firmware above 6.1.


This is the text for this option when using a firmware under 6.1, see below.
000e90c5ae1fbbdc584610313132c6d7.jpg
The above is only shown on legacy devices still on a firmware version under 6.1. They will see that message above indicating they need to let the system know.

281c06caf0fff47aae436412fdf2de04.jpg
On firmware 6.1 and higher you will see this message instead. Indicating it can auto-detect DTS or AC3 to prefer. You can always make it convert if you wanted to, the option is there.

New version:
* DTS to AC3 option in preferences
* Give firmware 6.1+ full auto-detection of DTS/AC3
* Add direct play support for Dobly Digital+ (AC3 7.1)
* TrueHD to AC3 if surround sound detected (DD 5.1/DD+ 7.1)
* When transcoding MPEG4 stream use MPEG4->MPEG4 rather than MPEG4->H264
* When transcoding MP2/3 stream use MP2/3->MP2/3 rather than MP2/3->AAC
* Options to control MPEG4 and MP2/3 transcoding
* Transcode MKV with MPEG4 and codecTag of MP4V same as XVID/DIVX
* roku4 direct-play for apple lossless audio codec (ALAC)
* Direct play/stream support for LPCM audio

e5bfc3b8e5af5d1ee80a880374f260b0.jpg

This is merely a container swap for AVI with MPEG4(divx/xvid) and AC3 or MP3. Barely impacts the cpu at all. Sweet.

0dd42812f60d1e088a4187fe3813c7fe.jpg

Tested a ton of videos. What works, what can transcode, what cant. All sorts of time wasted all in an effort to make this comprehensive and allow the best detection possible to minimize cpu usage. There are now options for MPEG4 and MP2/3 that can be set to NO which will allow those codecs to direct stream in your videos. If you love your cpu, look at these options and enable them to try out. If you have any issues with videos (you may as people encode videos in odd ways at times) please report them. This is why these settings now exist is to help solve issues. To give you more power and control to energize your media. This is emby after all. Haw.

You are in effect beta testers. Thanks for your help making this software better. Lets go team roku! Winning!

For the most part, setting the MPEG4 option to NO and playing direct-stream usually looks the same as converting to H264. It uses less CPU for sure. The MP2/3 option saves a little CPU copying MP2/3 audio. AVI containers with MPEG4 video and MP3 audio will benefit from this the most.

Still need testers with a roku4 to check direct-play of h265 hevc up to 60fps and vp9 up to 30fps with 1080p, 4k, and other various resolutions. Hevc can be 8 or 10 bit. Vp9 is 8 bit. Thanks again.

Update your roku, or get from the links in the first post of this thread to sideload nowtv/roku. May the force be with you. Always.

Edited by speechles, 31 October 2015 - 02:59 AM.


#26 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 01 November 2015 - 05:13 AM

296dadb525fcf9070802f45e227cfbdf.jpg

be79c5da864bd687dea6499372f79dbf.jpg

New version:
* flac will direct play as pcm 2.0/5.1 audio in mkv container
* flac will direct stream as pcm 2.0/5.1 audio if video transcodes

* When transcoding show audio channels original->transcoded in OSD

Another missing puzzle piece falls into place. The robustness of the detection for max direct play/stream just gets better. Thanks to @pclausen for spotting this issue.

@pclausen chage the MPEG4 and MP2/3 settings in preferences to NO to maximize direct streaming.

Everyone with the app, update time again. Those without see links in first post of this thread.


Edited by speechles, 01 November 2015 - 07:24 PM.


#27 pclausen OFFLINE  

pclausen

    Advanced Member

  • Members
  • 373 posts
  • Local time: 08:35 AM

Posted 01 November 2015 - 08:15 PM

I'll be sure to check that out!

 

Also, I have some BRD rips that are in excess of 30 Mbps and I have noticed that when playing those titles back on a Roku 3, it will transcode.  Would there be an issue with upping the bitrate to one of the rates where your app states it is for Roku 4 only?



#28 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 01 November 2015 - 09:00 PM

You can always try. If the roku cant keep up the stream will stall, and the roku may reboot. But, if you are on ethernet likely you can just fine. On wifi is where issues arise.

Sent from my Nexus 7 using Tapatalk

#29 BobbyDing OFFLINE  

BobbyDing

    Advanced Member

  • Members
  • 144 posts
  • Local time: 08:35 AM

Posted 01 November 2015 - 10:00 PM

Hi,

I am having the issue that kaelin has above. Once connected, moving down just one click causes the channel to crash. I don't have the Trailers plugin installed. This just started this today. Unfortunately both this channel and the server were upgraded this morning, so either might be suspect. Any Ideas??

 

Thanks,

 

Bobby


Edited by BobbyDing, 01 November 2015 - 10:49 PM.


#30 kaelin OFFLINE  

kaelin

    Member

  • Members
  • 29 posts
  • Local time: 08:35 AM

Posted 01 November 2015 - 10:15 PM

I had to go back to the regular app. It worked for awhile until the next release and the same thing started happening again with live tv. If I only have my library items visible it works fine but if I turn on live tv or any channels. It will kick me back to the Roku home screen. I need the live tv section so I had to go back to the regular emby channel.



#31 BobbyDing OFFLINE  

BobbyDing

    Advanced Member

  • Members
  • 144 posts
  • Local time: 08:35 AM

Posted 01 November 2015 - 10:40 PM

Yeah, I don't have this issue on the regular EMBY channel either. It was working fine for me up till today. I tried re installing both server and Neon channel on the Roku. No change. I disabled my firewall and it started working for a bit (thought I had found the problem) then it failed again with the firewall down. There are no updates or scans running on the server. I created a new user and logged on, but it dumped back to the Roku screen without loading. I wonder what's causing it?


Edited by BobbyDing, 01 November 2015 - 11:45 PM.


#32 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 02 November 2015 - 01:50 AM

f8add56ea2fffd12a5b8f58ba5e35672.jpg

@BobbyDing

For some reason channels (trailers,tunein,etc) werent showing for me. Deleted and recreated all *.db for my system and now I can see the problem. Scrolling down to where a channel loads its content crashes the channel silently. It just hangs. This had to do with me assuming runtimeticks always exists when it doesnt. Oops, my bad. :(

@kaelin

The problem with livetv was likely how I detect virtual episodes. I wasnt checking if values were valid before using them. Added the missing invalid checks. This should now work with livetv. Since I lack livetv capability can anyone confirm this solves the issue?

112cc2d68913bab3d279a7fd9bdef489.jpg

Made the channel screen more resemble the normal views. This mimics the folder view but for channel content along with filters/sorting/etc via * context options menu.

New version:
* Correctly process movies/episodes lacking runtimeticks (fixes channels crashing)
* Correctly handle invalid locationtype (should fix livetv)
* Channel screen additions with * menu

Update those rokus and nowtvs. Sorry for earlier version. New users get app from links in first post.

Edited by speechles, 02 November 2015 - 07:15 AM.

  • Happy2Play likes this

#33 kaelin OFFLINE  

kaelin

    Member

  • Members
  • 29 posts
  • Local time: 08:35 AM

Posted 02 November 2015 - 02:17 PM

Thanks @speechles

 

I did a quick test this morning and it no longer crashes on the main screen with live tv or other channels. I can play trailers fine now too.

I am not able to play any live tv channels or watch any tv recordings though. It will either freeze or crash back out to Roku home.

 

I'll do some more testing tonight. I am still looking for some h265 content. I'll try to convert some video this evening and test it.



#34 BobbyDing OFFLINE  

BobbyDing

    Advanced Member

  • Members
  • 144 posts
  • Local time: 08:35 AM

Posted 02 November 2015 - 03:11 PM

Thank You @speechles,

Same here. Quick test yielded good results. I'll also test more later tonight.

 

Bobby



#35 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 02 November 2015 - 05:11 PM

@kaelin

Would it be possible for you to enable developer mode on your roku? Once done, you can sideload the zipfile from the link in the first post. When an app is sideloaded you gain access to telnet port 8085. After the app is loaded telnet to your roku on port 8085 and it should start measage reporting. Since I lack livetv I cant do this myself or I would. When the app crashes it will report in the message reports exactly where and why this happened. Without this information I cant properly debug the issue. So help would be most awesome and appreciated. Thanks.

@CBers

Ive seen your posts in the nowtv thread. You for sure know how to sideload, and also have livetv. Can I ask you a favor? Lol.. Ya know, sideload and test this app with livetv/recordings and give me back the debug info on why its crashing for these? Pretty please with sugar on top? Thanks ;)

Edited by speechles, 02 November 2015 - 05:16 PM.


#36 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15395 posts
  • Local time: 01:35 PM
  • LocationKent, England.

Posted 02 November 2015 - 05:39 PM

@CBers

Ive seen your posts in the nowtv thread. You for sure know how to sideload, and also have livetv. Can I ask you a favor? Lol.. Ya know, sideload and test this app with livetv/recordings and give me back the debug info on why its crashing for these? Pretty please with sugar on top? Thanks ;)


Would be more than happy to test, but I don't have Live TV.

Sorry :)

#37 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 02 November 2015 - 05:44 PM

Would be more than happy to test, but I don't have Live TV.

Sorry :)

Oh snap. Dashing my hopes. Haw. Always assumed you had sideloaded nowtv with livetv from threads Ive read. This might be why to assume is to... Apologies :)

Its all good though. I know some kind soul will step forward to sideload this, test against their livetv, and post the error logs they found. Any takers? Cmon don't be shy. Heh

Sent from my Nexus 7 using Tapatalk

#38 kaelin OFFLINE  

kaelin

    Member

  • Members
  • 29 posts
  • Local time: 08:35 AM

Posted 02 November 2015 - 07:06 PM

I will try to make time for this later tonight after the kids go to bed. I haven't put the Roku 4 in developer mode so this will give me an excuse to do that. Been awhile since I have side loaded anything but remember it being pretty easy. I'll let you know.



#39 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15395 posts
  • Local time: 01:35 PM
  • LocationKent, England.

Posted 02 November 2015 - 07:09 PM

Oh snap. Dashing my hopes. Haw. Always assumed you had sideloaded nowtv with livetv from threads Ive read. This might be why to assume is to... Apologies :)

Its all good though. I know some kind soul will step forward to sideload this, test against their livetv, and post the error logs they found. Any takers? Cmon don't be shy. Heh


Sorry I couldn't help.

Would have been more than happy to sideload, but not having Live TV, doesn't help you.

Shout if I can be if assistance in the future, as my Now TV box is sitting gathering dust :)

#40 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5011 posts
  • Local time: 05:35 AM

Posted 02 November 2015 - 09:33 PM

Okay, lets try this again. The problem with live/recorded tv wasnt with browsing the titles? It was regarding playback of them, right? I Experienced the same issue with newly added media that wasnt scanned yet. It wouldnt crash the app, it was simply refusing to play on the videoplayer, and would fall back to the details screen. I have corrected that issue. You will also hear what sounds like Mario picking up a coin in Super Mario World right as you enter the homescreen. This means you have the latest version if you hear that. If not, update the app and see if livetv suddenly works.

New version:
* Videoplayer bug fixes
* Audible "coin pickup" sound on entering homescreen

@kaelin

*crosses fingers*
Live tv/recorded tv is fully browseable and playable now?

Edited by speechles, 02 November 2015 - 09:33 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users