Jump to content

File not found


Pirlo1966
 Share

Go to solution Solved by Pirlo1966,

Recommended Posts

Pirlo1966

Hi

 

I replaced paths on Emby server: volume1/Media/Film/Movies by \\NAS1815\Media\Film\Movies

 

Whenever I try to play a movie form Emby Theater with MPC-HC as an external player, MPC-HC opens but indicates it cannot find a file?? What am I missing? Should I do something extra besides replacing paths?

 

Playing the same media directly for MPC-HC works well.

 

The ET-log when launching  a movie:

2015-08-08 23:27:14.4124 Info - App: C:\Program Files (x86)\MPC-HC\mpc-hc.exe "\\\NAS1815\Media\Film\Movies\3 10 to Yuma (2007)\3 10 to Yuma (2007).mkv" /play /close /fullscreen
2015-08-08 23:27:14.4244 Debug - ApiClient: ReportPlaybackStart: Item 15948721cd70ceadb367a80c00452f49
2015-08-08 23:27:14.4244 Debug - ScreensaverManager: Calling SetThreadExecutionState to prevent system idle
2015-08-08 23:27:14.4244 Debug - ApiClient: POST http://192.168.1.100:8096/mediabrowser/Sessions/Playing?format=json
2015-08-08 23:27:14.5125 Info - ApiClient: Received web socket message: PlaybackStart
2015-08-08 23:27:14.5255 Debug - ApiClient: Received 204 status code after 102,0964 ms from POST: http://192.168.1.100:8096/mediabrowser/Sessions/Playing?format=json
2015-08-08 23:27:15.0390 Info - ApiClient: Received web socket message: UserDataChanged
2015-08-08 23:27:21.8207 Debug - ScreensaverManager: Calling SetThreadExecutionState to allow system idle
2015-08-08 23:27:21.8207 Debug - ApiClient: POST http://192.168.1.100:8096/mediabrowser/Sessions/Playing/Stopped?format=json
2015-08-08 23:27:21.8337 Info - ApiClient: Received web socket message: PlaybackStopped
2015-08-08 23:27:21.8337 Debug - ApiClient: Received 204 status code after 15,0137 ms from POST: http://192.168.1.100:8096/mediabrowser/Sessions/Playing/Stopped?format=json
2015-08-08 23:27:22.3792 Info - ApiClient: Received web socket message: UserDataChanged

Link to comment
Share on other sites

Pirlo1966

Thanks for pointing that out but it's not the answer: file still cannot be found by mpc-hc 

Link to comment
Share on other sites

d00zah

Apologies. I use MPC-BE w/ content stored on NAS without issue. & looking at the library config, the original path was correct from Emby's perspective.. Does your NAS spin-down drives when idle? Perhaps it's not waking quickly enough to MPC-HC's initial request?

 

Do you get  the same result playing the file via web client?

Edited by d00zah
Link to comment
Share on other sites

  • Solution
Pirlo1966

d00zah, no worries. thanks for hrelping.  And you helped! 

 

I looked closer at the log and saw 3 slashes /// ... So I replaced paths as follows:

 

 volume1/Media/Film/Movies by \NAS1815\Media\Film\Movies instead of \\NAS1815\Media\Film\Movies.

 

And now all is okay! The example path replacement on the server dashboard is somehow misleading because it gives as an example \\my server\....

Link to comment
Share on other sites

d00zah

Glad you found it. I was doing some testing & was going to suggest issuing the command (based on log snippet):

 

'C:\Program Files (x86)\MPC-HC\mpc-hc.exe" "\\\NAS1815\Media\Film\Movies\3 10 to Yuma (2007)\3 10 to Yuma (2007).mkv"

 

from the command prompt to remove Emby from the equation. If that worked...

 

Curious... you're using path substitution? When adding libraries, I just browse to the NAS path I want to add (no substitution) & I've never had an issue. Seems like an unnecessary layer of complexity. YMMV. Enjoy!

Link to comment
Share on other sites

Pirlo1966

Path substitution because I cannot browse to (or manually ad) the NAS path when adding libraries. No idea why.

Link to comment
Share on other sites

d00zah

Hmmm. Just noticed thread in the Synology section... must not have all the kinks worked out yet. My understanding is that path substitution applied to Windows drive-letter path issues. In light of the server being hosted on a linux OS, my original path suggestion stands. & should eliminate the need for path substitution.

 

Wish my NAS had the horsepower (& support)  to offload the server function. A project for another day...

Edited by d00zah
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...