Jump to content

Cannot add a media library from UNC shares that point to a NAS


alfman
 Share

Go to solution Solved by FrostByte,

Recommended Posts

alfman

I'm configuring Emby (Version 3.0.5641.4) and cannot add a media library from UNC shares that point to a NAS.

 

On my Windows 8.1 NUC, I have UNC shares that point to folders on a Synology NAS.  I have the UNC shares set up according to the Emby How to Make UNC Folder Shares article.

 

In the Add media folder dialog, I can navigate to my UNC shares (see screenshot).  However, when I select a particular UNC share (e.g., NAS_MUSIC) and click OK, I'm incorrectly taken to the main Emby logon screen.

 

I tested adding a test media library from a folder local to my NUC and that worked successfully. 

 

For comparison, I use these same UNC shares for media libraries on my Plex server successfully (Plex running on the same NUC as the Emby server).  So I believe they are configured correctly.

 

5588bf6064afa_Capture.png

 

 

Clicking on NAS_MUSIC takes me back to the logon screen:

 

5588c1457f0f9_Capture2.png

 

Link to comment
Share on other sites

AdrianW

It looks as though you have mapped NAS_UNC_Shares to your D: drive. You shouldn't be mapping any drives.

 

When entering the path you should navigate to \\servername\sharename and add that.

  • Like 1
Link to comment
Share on other sites

  • Solution
FrostByte

I'm not running as a service.  Would that make difference?

No, you don't have to run as a service.  If running as a service though you have to start the service with an account that is also configured on the NAS with rights to your media folders. 

 

AdrianW is probably on the right.

  • Like 1
Link to comment
Share on other sites

alfman

No, you don't have to run as a service.  If running as a service though you have to start the service with an account that is also configured on the NAS with rights to your media folders. 

 

AdrianW is probably on the right.

 

Running it as a service (with an account with the correct privileges to my NAS shares) worked!

 

Thanks.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...