Jump to content

Few issues in the Android client


Recommended Posts

For the record, these have been reproduced with android client 2.3.13.

 

I think it's time to start up a new thread about these issues. Changing languages in the played stream is proving to be challenging.

 

Issues so far:

  1. Chaging or turning off subtitles doesn't work in Android client (or the chromecast receiver, but we already covered that elsewhere)
  2. Changing audio language doesn't work with chromecast (but luckily works with Android client itself)
  3. Volume buttons don't appear to have any effect on the android player

Also, it would be nice if:

  1. The built in player defaulted to landscape mode, since most media is in landscape format
  2. The pause control was available in the collapsed notification area card (currently it has no controls in the collapsed card)

So yeah, thats a few things for now.

  • Like 2
Link to post
Share on other sites

Maybe it has something to do with the subtitle formats or the like. I've shared a video of this happening as well as the metadata seen by Emby here:

https://goo.gl/photos/vuzJJTaArQUPNWZa7

 

The video sadly doesn't show touch events, but first I try to change the subtitle to Off, then to another language. Neither of that works. Finally I try changing the audio language, which works on Android, but not on ChromeCast.

Link to post
Share on other sites

I have some pretty major issues with the Android Client 2.3.13 as well. WOrked well for about an hour. Then i used the client to stream some music (as opposed to video) and since that point on the client has failed to stream video. I have restarted server (Service and entire machine) I have even reset my android device to factory and re installed the app but no luck. Currently all videos load and begin to play but with audio only... :(

 

Client Device:  Minix NEO-X8-H

Client Software: Emby for Android v2.3.13

Server Device: Windows (Win 8.1x64)

Server Software: 3.0.5621.4

 

Update: After a few hours of hair tearing, my wife found a solution. She clicked on the "full screen/ stretch button" and and the video immediately displayed. Now all videos display and clicking the full screen button makes no difference, just that fist time....?

Edited by bert386
Link to post
Share on other sites

I too am experiencing these same problems listed in the original post. The app does not register any selection of subtitles. No matter what I try to select, the "off" option remains checked. I use emby almost exclusively to cast to my chromecast (because it's connected to my tv). I have been experiencing major problems with basic functionality of the app when I'm connected to the chromecast. It boils down to two things:

 

1) Not allowing me to pause, resume, stop, or seek during playback. 

2) select a subtitle or audio stream. 

 

without these functions, it makes for a very frustrating experience using the app. 

 

I'm using v2.3.13

Link to post
Share on other sites

I too am experiencing these same problems listed in the original post. The app does not register any selection of subtitles. No matter what I try to select, the "off" option remains checked. I use emby almost exclusively to cast to my chromecast (because it's connected to my tv). I have been experiencing major problems with basic functionality of the app when I'm connected to the chromecast. It boils down to two things:

 

1) Not allowing me to pause, resume, stop, or seek during playback. 

2) select a subtitle or audio stream. 

 

without these functions, it makes for a very frustrating experience using the app. 

 

I'm using v2.3.13

 

It's fixed for the next update.

Link to post
Share on other sites

Jumping in with more issues :D

 

In the order of annoyance.

  • If you pause an episode on the ChromeCast and allow Android Mobile to disconnect and then reconnect, there is no way to resume playback. The Mobile app assumes that there is nothing playing. The only way to resume playback is to go to main screen and restart playback from a resume point.
  • Android Notification area controls appear to be a bit of a hit and miss with ChromeCast. Sometimes the playback state doesn't reflect the ChromeCast and usually the controls fail to work. I think I've had success with the controls sometime in the past, but recently I've just given up trying.
  • Reconnect to ChromeCast is annoyingly slow. Most apps manage to reconnect almost instantly, but Emby takes a number of seconds to reconnect.
  • There is no way to check the Client version from within the app. The server lists a completely different version for the client, so the only way to check the client version is from android settings.
I think that's all for now.

 

Oh, and the client version is 2.3.19

Edited by ressu
Link to post
Share on other sites

I agree with ressu, new posts should be started with new individual issues.

 

I for one search as much as I can before I post a question/issue, and having to go through this entire single post is a pain

 

I suggest we shut down this single post asking users to start new posts.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...