Jump to content

default to external subtitle


Recommended Posts

DancingMan

Is it possible to set my external subtitles to be the default?  I see that I can set subtitles to always be on, and I can set a particular language as the default.  Most of my mp4 movies have graphic subtitles in them (dvdsub), and for lots of them I also have external subtitle files (srt, sub).  If I have an internal english subtitle and an external english subtitle file, it seems like Emby uses the internal as the default (the attachment is from the bottom of Emby's WebUI for one of my movies).

 

Is there any way to set a system wide default to say "if there are external & internal subtitles for the default language, use the external subtitle"?

 

 

post-41320-0-88512300-1433260771_thumb.jpg

Link to post
Share on other sites
Luke

it will favor the external subtitles but since the internal ones are marked as default they are taking priority. you can also mark the external ones as default by adding .default to the file name. so movie.eng.default.srt

  • Like 1
Link to post
Share on other sites
FrostByte

Another way is to use a tool like mkvmerge and mark the internal one as default = no.  Luke's method is quicker though

Edited by FrostByte
Link to post
Share on other sites
DancingMan

That set the language to default for the external subtitle (see attachment).  Should it be movie.default.eng.srt?

post-41320-0-34385800-1433265386_thumb.jpg

Link to post
Share on other sites
DancingMan

After more investigation, it seems like I made my mp4s and included the graphic subtitles in them (dvdsub) and did not set them as a default.  The programs I used (VidCoder, Handbrake, & ffmpeg) seem to have taken it upon themselves to mark my subtitle stream as default and add a second (text) subtitle that lists the current chapter.  I can't seem to get rid of the second stream - whether I try to completely transcode the file or just use ffmpeg to copy the video stream, audio stream, and only my graphic subtitle stream (without setting it as default); that second subtitle stream reappears and my subtitles are set to default.

 

Any ideas?  If there's some way in emby to tell it to ignore the default subtitle setting in the mp4, that would be fine (but unfortunately Luke says there isn't).  The next best option would be some sort of batch method - for example, I have a script that will go through a list of files and run ffmpeg on each one to copy streams to another container; I would just need to know what switch to include to make sure the second subtitle stream isn't made and my subtitle stream isn't set to default.

post-41320-0-70562700-1433426898_thumb.jpg

Link to post
Share on other sites
  • 4 years later...
atomicmoon

it will favor the external subtitles but since the internal ones are marked as default they are taking priority. you can also mark the external ones as default by adding .default to the file name. so movie.eng.default.srt

Being as this is an old thread, is this still true? I'm finally starting to get the grasp of direct play/transcoding, and internal subtitles are becoming a pain in my back. I would LOVE to easily strip them, but my library is pretty large. I want to find a way to force external subs by default, and if this method still rings true, I can use a bulk rename tool to hopefully batch this process to allow less transcoding.

 

Thanks as always!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...