Jump to content

Testing onedrive plugin


richardap1
 Share

Recommended Posts

richardap1

I have test uploading two videos. First one was fine. Second generated an error

 

2015-05-31 19:56:34.6916 Error - App: Error transferring sync job file
*** Error Report ***
Version: 3.0.5621.4
Command line: C:\Users\Media\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe
Operating system: Microsoft Windows NT 6.2.9200.0
Processor count: 8
64-Bit OS: True
64-Bit Process: False
Program data path: C:\Users\Media\AppData\Roaming\MediaBrowser-Server
Application Path: C:\Users\Media\AppData\Roaming\MediaBrowser-Server\system\MediaBrowser.ServerApplication.exe
Arithmetic operation resulted in an overflow.
System.OverflowException
  at OneDrive.OneDriveServerSyncProvider.<FillBuffer>d__2a.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at OneDrive.OneDriveServerSyncProvider.<UploadFile>d__22.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at OneDrive.OneDriveServerSyncProvider.<SendFile>d__1.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.Server.Implementations.Sync.MediaSync.<SendFile>d__52.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
  at MediaBrowser.Server.Implementations.Sync.MediaSync.<GetItem>d__2d.MoveNext()
 
 
Thanks
Rich
 
Link to comment
Share on other sites

hamstercat

What size if the file you're trying to sync? I'll try to reproduce with a file as big as the one that triggered this error.

Link to comment
Share on other sites

richardap1

Hi. It was 4.37GB. I did a sync on high quality and the default general profile.

Thanks

Link to comment
Share on other sites

hamstercat

I've uploaded a new version, I'm still testing but I think it may do the trick. Tell me how it goes!

Link to comment
Share on other sites

kakata

Hi

 

Im getting a 400 error adding a account.

 

Here's the log:

2015-06-03 22:09:10.9316 Info - App: HttpClientManager POST: https://login.live.com/oauth20_token.srf2015-06-03 22:09:11.0341 Error - App: Error getting response from https://login.live.com/oauth20_token.srf	*** Error Report ***	Version: 3.0.5621.4	Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server	Operating system: Unix 3.16.0.4	Processor count: 1	64-Bit OS: True	64-Bit Process: True	Program data path: /var/lib/emby-server	Mono: 4.0.1 (tarball Tue May 26 04:37:11 UTC 2015)	Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe	The remote server returned an error: (400) Bad Request.	System.Net.WebException	  at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000] in <filename unknown>:0 	  at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000] in <filename unknown>:0 	2015-06-03 22:09:11.0341 Error - DtoUtils: ServiceBase<TRequest>::Service Exception	*** Error Report ***	Version: 3.0.5621.4	Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server	Operating system: Unix 3.16.0.4	Processor count: 1	64-Bit OS: True	64-Bit Process: True	Program data path: /var/lib/emby-server	Mono: 4.0.1 (tarball Tue May 26 04:37:11 UTC 2015)	Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe	The remote server returned an error: (400) Bad Request.	System.Net.WebException	  at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000] in <filename unknown>:0 	  at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000] in <filename unknown>:0 	2015-06-03 22:09:11.0348 Error - HttpServer: Error processing request for /OneDrive/SyncTarget	*** Error Report ***	Version: 3.0.5621.4	Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server	Operating system: Unix 3.16.0.4	Processor count: 1	64-Bit OS: True	64-Bit Process: True	Program data path: /var/lib/emby-server	Mono: 4.0.1 (tarball Tue May 26 04:37:11 UTC 2015)	Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe	The remote server returned an error: (400) Bad Request.	ServiceStack.HttpError	No Stack Trace Available
Link to comment
Share on other sites

hamstercat

I'm guessing it has to do with the Client ID or Client Secret either missing or invalid, but I'll add more logging and try to return a nicer message in those cases to see if it really is the problem.

Link to comment
Share on other sites

hamstercat

I think I figured it out. You probably entered a client id and secret, but didn't hit save. Then the call to grant access fails because of that. Can you validate?

 

I'll change the config page so this isn't possible anymore.

  • Like 1
Link to comment
Share on other sites

kakata

I redo everything (reinstalled plugin, change client ID secret). In all cases saving before adding account, and no joy (same error).  Should I make a video?

Link to comment
Share on other sites

  • 4 months later...
Monkeylurv

hi. I can't seem to add any accounts. with OneDrive I get this error:

We're unable to complete your request

Microsoft account is experiencing technical problems. Please try again later.

 

with Google I get:

401. That’s an error.

Error: invalid_client

The OAuth client was not found.

Request Details

That’s all we know.

 

with DropBox:

Error (400)

It seems the app you were using submitted a bad request. If you would like to report this error to the app's developer, include the information below.

 

More details for developers

Invalid client_id: "my ID account"

 

I am using my login email accounts and associated passwords, saving them before trying to add the sync

Advice?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...