Jump to content

Emby Server Error: Guid should contain 32 digits with 4 dashes


kakata
 Share

Go to solution Solved by Xtropy,

Recommended Posts

kakata

Hi 

 

Since new ppa (Version 3.0.5621.3) and the recently updated ubuntu install method (for Version 3.0.5621.4), emby server on Ubuntu 14.04 server presents a Guid should contain 32 digits with 4 dashes error if:

 

try to add a setting to a current or new user

try to add a new plugin

 

 

Here's the error presented when adding an option to a current user:

 

015-05-30 10:28:11.7699 Error - DtoUtils: ServiceBase<TRequest>::Service Exception
*** Error Report ***
Version: 3.0.5621.4
Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby
Operating system: Unix 3.13.0.52
Processor count: 1
64-Bit OS: True
64-Bit Process: True
Program data path: /var/lib/emby
Mono: 4.0.1 (tarball Tue May 26 04:28:10 UTC 2015)
Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
System.FormatException
 at System.Guid+GuidResult.SetFailure (ParseFailureKind failure, System.String failureMessageID, System.Object failureMessageFormatArgument, System.String failureArgumentName, System.Exception innerException) [0x00000] in <filename unknown>:0
 at System.Guid+GuidResult.SetFailure (ParseFailureKind failure, System.String failureMessageID) [0x00000] in <filename unknown>:0
 at System.Guid.TryParseGuidWithNoStyle (System.String guidString, System.GuidResult& result) [0x00000] in <filename unknown>:0
 at System.Guid.TryParseGuid (System.String g, GuidStyles flags, System.GuidResult& result) [0x00000] in <filename unknown>:0
 at System.Guid..ctor (System.String g) [0x00000] in <filename unknown>:0
 at MediaBrowser.Server.Implementations.Library.UserManager.GetUserById (System.String id) [0x00000] in <filename unknown>:0
 at MediaBrowser.Api.UserService+<PostAsync>c__async4.MoveNext () [0x00000] in <filename unknown>:0
 
2015-05-30 10:28:11.7702 Error - HttpServer: Error processing request for /emby/Users/f67e8bfc164e48b8940c911ff981f511
*** Error Report ***
Version: 3.0.5621.4
Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby
Operating system: Unix 3.13.0.52
Processor count: 1
64-Bit OS: True
64-Bit Process: True
Program data path: /var/lib/emby
Mono: 4.0.1 (tarball Tue May 26 04:28:10 UTC 2015)
Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
ServiceStack.HttpError
No Stack Trace Available
Link to comment
Share on other sites

kakata

Ok,

 

After reinstalling and no success on the above (and other errors), I proceeded and changed to DEBIAN 8 distribution and all functions are normal.

 

Please if anyone have a successfull Ubuntu 14.04 LTS install and operation, please send kernel version used.

 

Thanks,

Link to comment
Share on other sites

hurricanehrndz

Ok,

 

After reinstalling and no success on the above (and other errors), I proceeded and changed to DEBIAN 8 distribution and all functions are normal.

 

Please if anyone have a successfull Ubuntu 14.04 LTS install and operation, please send kernel version used.

 

Thanks,

 

That is very strange. I use 14.04 wither kernel  3.8.0-39-generic. What other errors are you seeing other than guid. I'm setting up a new vm to see if I can reproduce your error.

Edited by hurricanehernandez
Link to comment
Share on other sites

hurricanehrndz

Just tried with a fresh install of ubuntu minimal 14.04. I followed my own instructions and I received no error about Guid. Using kernel  4.0.0-040000-generic

Link to comment
Share on other sites

JoeyMuyo

Just want to chime in if I can. I am getting this GUID error on all my plugins since the changes. Including a new installation of a plugin, trakt, that I never had before.

 

No amount of reinstalling emby seems to resolve the problem.

 

The error I get for trakt in the logs are:

2015-06-01 22:15:26.1754 Error - DtoUtils: ServiceBase<TRequest>::Service Exception
	*** Error Report ***
	Version: 3.0.5621.4
	Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby
	Operating system: Unix 3.16.0.38
	Processor count: 4
	64-Bit OS: True
	64-Bit Process: True
	Program data path: /var/lib/emby
	Mono: 4.0.1 (tarball Tue May 26 04:32:21 UTC 2015)
	Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
	Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
	System.FormatException
	at System.Guid/GuidResult.SetFailure (System.Guid/ParseFailureKind,string,object,string,System.Exception) <0x000de>
	at System.Guid/GuidResult.SetFailure (System.Guid/ParseFailureKind,string) <0x0001e>
	at System.Guid.TryParseGuidWithNoStyle (string,System.Guid/GuidResult&) <0x0005a>
	at System.Guid.TryParseGuid (string,System.Guid/GuidStyles,System.Guid/GuidResult&) <0x00247>
	at System.Guid..ctor (string) <0x000e0>
	at MediaBrowser.Api.PluginService.Post (MediaBrowser.Api.UpdatePluginConfiguration) <0x0006c>
	at (wrapper dynamic-method) object.lambda_method (System.Runtime.CompilerServices.Closure,object,object) <0x00074>
	at ServiceStack.Host.ServiceExec`1/<>c__DisplayClass6<MediaBrowser.Api.PluginService>.<CreateExecFn>b__5 (object,object) <0x0002d>
	at ServiceStack.Host.ServiceRunner`1<MediaBrowser.Api.UpdatePluginConfiguration>.Execute (ServiceStack.Web.IRequest,object,MediaBrowser.Api.UpdatePluginConfiguration) <0x00424>
	
	
2015-06-01 22:15:26.1754 Error - HttpServer: Error processing request for /emby/Plugins/8abc6789-fde2-4705-8592-4028806fa343/Configuration
	*** Error Report ***
	Version: 3.0.5621.4
	Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby
	Operating system: Unix 3.16.0.38
	Processor count: 4
	64-Bit OS: True
	64-Bit Process: True
	Program data path: /var/lib/emby
	Mono: 4.0.1 (tarball Tue May 26 04:32:21 UTC 2015)
	Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
	Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
	ServiceStack.HttpError
	No Stack Trace Available

And for Auto Box Set, which was already install I get:

2015-06-01 22:18:31.8208 Error - DtoUtils: ServiceBase<TRequest>::Service Exception
	*** Error Report ***
	Version: 3.0.5621.4
	Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby
	Operating system: Unix 3.16.0.38
	Processor count: 4
	64-Bit OS: True
	64-Bit Process: True
	Program data path: /var/lib/emby
	Mono: 4.0.1 (tarball Tue May 26 04:32:21 UTC 2015)
	Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
	Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
	System.FormatException
	at System.Guid/GuidResult.SetFailure (System.Guid/ParseFailureKind,string,object,string,System.Exception) <0x000de>
	at System.Guid/GuidResult.SetFailure (System.Guid/ParseFailureKind,string) <0x0001e>
	at System.Guid.TryParseGuidWithNoStyle (string,System.Guid/GuidResult&) <0x0005a>
	at System.Guid.TryParseGuid (string,System.Guid/GuidStyles,System.Guid/GuidResult&) <0x00247>
	at System.Guid..ctor (string) <0x000e0>
	at MediaBrowser.Api.PluginService.Post (MediaBrowser.Api.UpdatePluginConfiguration) <0x0006c>
	at (wrapper dynamic-method) object.lambda_method (System.Runtime.CompilerServices.Closure,object,object) <0x00074>
	at ServiceStack.Host.ServiceExec`1/<>c__DisplayClass6<MediaBrowser.Api.PluginService>.<CreateExecFn>b__5 (object,object) <0x0002d>
	at ServiceStack.Host.ServiceRunner`1<MediaBrowser.Api.UpdatePluginConfiguration>.Execute (ServiceStack.Web.IRequest,object,MediaBrowser.Api.UpdatePluginConfiguration) <0x00424>
	
	
2015-06-01 22:18:31.8208 Error - HttpServer: Error processing request for /emby/Plugins/899c12c7-5b40-4c4e-9afd-afd74a685eb1/Configuration
	*** Error Report ***
	Version: 3.0.5621.4
	Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby
	Operating system: Unix 3.16.0.38
	Processor count: 4
	64-Bit OS: True
	64-Bit Process: True
	Program data path: /var/lib/emby
	Mono: 4.0.1 (tarball Tue May 26 04:32:21 UTC 2015)
	Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
	Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
	ServiceStack.HttpError
	No Stack Trace Available
Link to comment
Share on other sites

freebs

I brought this to there attention last week, I still see no fix ..?

 

Any updates to this ?

 

 

Thanks.

Link to comment
Share on other sites

kakata

Same here, running smooth but after new ppa all got broken. Even after complete reinstall no joy.

 

My guess is a mono error on the kernel version run in digital ocean vm.

 

Please post kernel version.

Link to comment
Share on other sites

freebs

Here is my kernel version... 

 

root@HTPC:~# uname -a

 

Linux HTPC 3.13.0-53-generic #89-Ubuntu SMP Wed May 20 10:34:39 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Link to comment
Share on other sites

hurricanehrndz

@kakata

 

What is the kernel version you are using? I haven't tried plugins. I tried only adding users and editing them. 

Link to comment
Share on other sites

kakata

@hurracainehernandez:

 

Used 3.13.0-52-generic (also 3.13.0-53-generic) which are the most recent available in Digital Ocean (unsuccessfully).

 

And yes, I got errors creating users, enabling plugins, loading users avatar image, disabling dna service.

 

I love Ubuntu and the challenge, but like I said before, all is now working on Debian 8. Nerveless I'm looking forward on the new mono idea!

Link to comment
Share on other sites

JoeyMuyo

I am on Ubuntu 14.10 with kernel version 3.16.0-38-generic.

 

Haven't tried creating users or editing them yet but I am guessing that might also be a problem.

Link to comment
Share on other sites

hurricanehrndz

@@JoeyMuyo,

 

Have you tried updating to kernel 4.04? mono has been updated in our repos.

Edited by hurricanehernandez
Link to comment
Share on other sites

JoeyMuyo

@@JoeyMuyo,

 

Have you tried updating to kernel 4.04? mono has been updated in our repos.

I have not. I have just recently updated the mono from the repo.

 

What would be the knock of effect of upgrading to 4.04. Or would upgrading to 15.04 help?

Link to comment
Share on other sites

geaves

Luke pointed me here as I posted a problem with Auto Box Sets, however I have just added a user and got the same gui error, but there is more in the log. Having read this thread I have updated kernel to 4.04.

 

server log.txt

Link to comment
Share on other sites

hurricanehrndz

Luke pointed me here as I posted a problem with Auto Box Sets, however I have just added a user and got the same gui error, but there is more in the log. Having read this thread I have updated kernel to 4.04.

 

attachicon.gifserver log.txt

Can you guys please tell me if you have done anything with the emby sqlite files.

Edited by hurricanehernandez
Link to comment
Share on other sites

hurricanehrndz

@@Luke, so this seems to be an sqlite issue: 

http://wp.qmatteoq.com/using-sqlite-in-your-windows-8-metro-style-applications/

 

And emby experience this problem back in 2013 as well:

http://emby.media/community/index.php?/topic/1951-guid-should-contain-32-digits-and-4-dashes-error/

 

I have two different instances of trusty both not exhibiting this issue, so I am at a loss at what it could be.

Link to comment
Share on other sites

Xtropy

I did a complete wipe of Emby and installed from scratch and get this error constantly. I am running Ubuntu 14.04.2 LTS, Trusty Tahr"

 

There are a number of other posts with this issue on various areas of the forums. This issue began after the PPA changes recently.

 

 
Link to comment
Share on other sites

hurricanehrndz

@@Xtropy are you using database backup at all? Because the guid issue from what I can tell could be the result of a corrupt database. I have tried to reproduce the error, but I can't on either of my trusty machines. 

Link to comment
Share on other sites

hurricanehrndz

 

I did a complete wipe of Emby and installed from scratch and get this error constantly. I am running Ubuntu 14.04.2 LTS, Trusty Tahr"

 

There are a number of other posts with this issue on various areas of the forums. This issue began after the PPA changes recently.

 

 

 

Can you please post your logs, the more logs we get the better. Please post as much information as possible, host os, cpu, vm anything and everything.

Edited by hurricanehernandez
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...