Jump to content

New Installation Failure (?)


datahedron
 Share

Recommended Posts

Hello,

After a recent rebuild of my HTPC, I reinstalled and patched the OS to Windows 8.1 w/WMC. All available OS patches were installed as of 4/25/15. When I reinstalled the Emby-WMC app (Version 3.0.262), it installed (apparently) with success, but even after a system reboot, the app will only bring up a blank, blue WMC window. Screenshot attached.

 

I have included the install log, as well as the initial launch log. I have been unable to actually view the Emby interface inside of Media Center. The Emby Server application is running on a separate, network-accessible computer, and the Emby (Android) application is able to connect to it with no configuration needed (launch, and it's there).

 

I included today's launch log as well; taken when I launched the Emby app to grab a screenshot. It's identical to the initial log.

 

Network is configured for LAN-only (I'm not using Connect, or any cloud service access methods), and I haven't installed any antivirus on the HTPC as of yet (I will once I get this hiccup resolved, but no sense adding to the issue until then).

 

Any suggestions would be appreciated. The log files seem to indicate that the application believes it's showing the initial welcome screen ("Hey, here's some new features, and welcome to Emby!"), but as you can see from the screenshot, I'm not seeing what it thinks I'm seeing.. :P

mbc-install.log

MBClassic-25420154f4bdd61239149178ff4e180d53c8094.log

MBClassic-Msi.log

post-3727-0-91409300-1430332515_thumb.png

MBClassic-29420152cd1a39a51534e32be564f6b1b98586a.log

Link to comment
Share on other sites

No. This was a complete clean install. No previous files were carried over. I even downloaded the current Emby-WMC installer fresh.

Link to comment
Share on other sites

datahedron

Thanks for the prompt reply, but it turns out it was something related to the loss of external configurator control. To wit: Previous versions of Emby for WMC allowed us to define a specific server name or IP via the Configurator tool (without launching WMC).

 

Since that was removed, I discovered that my installation of Emby was detecting my Ceton cablecard module as the primary network interface. Seeing no server at this network interface, it would hang, (previously, it was actually launching the "Connect" code page).

 

Disconnecting my Ceton, allowed Emby to launch correctly. Once there, I was able to go to the config screen, advanced tab, and force the current server as the default connection port (disabling the auto-locate function).

 

Suggestion: Can Emby for WMC be set to scan ALL NICs/Network Interfaces at initial startup? It seems to be selecting just the 192.x.x.x port (which is my cablecard), and ignoring the actual, live NIC (which is set to a different IP block).

Link to comment
Share on other sites

Beartlaoi

Suggestion: Can Emby for WMC be set to scan ALL NICs/Network Interfaces at initial startup? It seems to be selecting just the 192.x.x.x port (which is my cablecard), and ignoring the actual, live NIC (which is set to a different IP block).

 

I second that.

I just spent the morning, frustrated, trying to get a fresh install to work, just to find out that the tuner NICs were preventing this from finding the server.

Please, either don't concern yourself with dealing with a specific NIC, or try all of them.

  • Like 1
Link to comment
Share on other sites

It does exaclty that, but is it possible the NIC is not ready yet at the time Emby for WMC is started?

Link to comment
Share on other sites

Hi all

 

Had the exact same situation crop up tonight, installed Emby WMC on a machine that only has one network card, is part of the same workgroup, no firewall running on Client & Server, all using fixed IP's and can see the rest of the network with no issues. Two other clients running off the server fine.

 

Blank blue screen every time I tried to start it.

 

Once I edited the MBCommonXml.config file and changed the following it worked fine:

 

  <FindServerAutomatically>False</FindServerAutomatically>
  <ServerAddress>10.0.0.3</ServerAddress>
  <ServerPort>8096</ServerPort>

 

So somethings not quite right with it auto discovering the server properly.

 

I just checked my Network Connections, I do have 2 x VMware adapters in there as well as a VPN connection (disconnected) and it's associated TAP-Windows adapter (also disconnected).

 

So maybe that is a factor ?

Link to comment
Share on other sites

Yes, a VM produces a virtual network adapter which can fool our server.

 

The reaction on the part of MBC to not finding the server needs to be better, though...

Link to comment
Share on other sites

Even if the the WMC client can't find the server, it needs to time out and then ask for a manual address. I left it alone for an hour to see if it was going to timeout.... it didn't   :)

 

Fortunately I'm savvy enough to dive into the config files, a lot of users aren't going to be.

 

Cheers

  • Like 1
Link to comment
Share on other sites

datahedron

It does exaclty that, but is it possible the NIC is not ready yet at the time Emby for WMC is started?

In most failure cases (for my scenario, at least), the system was online, fully functional, and all internet and media capability had been operating normally for a signifigant (greater than 60 minutes) time. I'm using Emby for WMC, so I launch WMC, watch tv, then switch over to Emby if I want to watch a stored movie or show. Even though I was able to watch Netflix (via WMC plug-in), and all TV channels were coming in clean, the Emby (WMC) app would hang. Logs indicate it was searching the 192.x.x.x subnet for an Emby Server.

Since my Ceton media unit assigns itself a 192.x.x.x address for ethernet emulation (Ceton InfiniTV4 USB edition), it was the first one picked up by the Emby app. With no server response at that address, the app hangs, and DOES NOT search any other interfaces or subnets. My LAN does not use the 192.x.x.x subnet (for various network management purposes), and would never be seen.

NOTE: On other devices that did not have a mediacard device attached, the Emby app worked fine. It does see the internal LAN subnet, if no other device is present or emulating. My workstations have no problem auto-detecting the Emby Server, nor do my laptops. It's just the HTPC that runs my Ceton device, that has this problem. From everything I can determine, the Emby app only grabs the first subnet (with preferential treatment to the 192.x.x.x group), and if it doesn't detect the server, assumes none is present.

Link to comment
Share on other sites

Luke was looking at it from the perspective of the server not the client.  On the MBC side, you are probably correct.  We don't do anything fancy to try different adapters.  We just ask Windows to send a request over the network.

Link to comment
Share on other sites

I cannot reproduce the blank blue screen scenario you had.

 

I manually configured my server to connect to a non-existent address and it timed out and recovered as it should - finding the server via automatic detection.

 

I then brought down the server so that there was none available, and it brought me to the Connect PIN screen as it should.

 

I couldn't create a scenario that would make the app just give up like you had.

Link to comment
Share on other sites

  • 5 weeks later...

I just found this thread because I have VMware adapters which I presume are preventing automatic discovery from working. Is there a workaround for this? I tried editing my config file directly to provide the server details but that didn't help. If I manually enter the server details from within WMC it works fine (other than the fact that it ignores the last character of the server name so I have to enter my server name plus a random character).

Link to comment
Share on other sites

In regards to manually connecting, as ebr mentioned - it's not a problem when the address is configured manually. It's the initial automatic network identification. As I mentioned above, when other devices are connected to the unit running WMC and Emby, the automatic network/server scan fails.

 

This issue, as mentioned when I started the thread, happened because there are two separate ip subnets on my HTPC - one is my internal LAN, and the other is my Ceton cablecard adapter. Since the Ceton device emulates a 192.x.x.x IP device, the automatic scan (when Emby is freshly installed), picks up the Ceton's IP, and fails out - in essence, it behaves as if I'm not connected to/it cannot find an active LAN with an operational Emby Server present. Since my Emby Server runs on a separate IP block (not 192.x.x.x), and since Emby for WMC ONLY auto-scans for 192.x.x.x addresses by default, I either get a frozen blue (WMC background) screen, or the Emby Connect "PIN" screen.

 

By removing ALL ADAPTERS, and ONLY connecting the LAN, I was able to coax Emby for WMC into looking at the only remaining IP block, at which point it immediately identified the Emby Server on my network, connected happily, and launched itself. I then had to configure the Server address to default to the IP block it had found, and to NOT search for other blocks. After that, I was able to shut off WMC, reconnect my Ceton, and re-launch WMC and Emby correctly.

Link to comment
Share on other sites

It isn't looking for the specific 192 IP range, it is just communicating with the first adapter.  I believe if you can re-define the priority of the adapters so that the true network is the first one, it will also work.

Link to comment
Share on other sites

I just found this thread because I have VMware adapters which I presume are preventing automatic discovery from working. Is there a workaround for this? I tried editing my config file directly to provide the server details but that didn't help. If I manually enter the server details from within WMC it works fine (other than the fact that it ignores the last character of the server name so I have to enter my server name plus a random character).

 

It isn't ignoring the last character.  The field is designed for "triple tap" input - entering letters with a remote control number pad much like texting in 2002.  So, the last letter entered doesn't "take" until a couple seconds after it is entered.

Link to comment
Share on other sites

It isn't looking for the specific 192 IP range, it is just communicating with the first adapter.  I believe if you can re-define the priority of the adapters so that the true network is the first one, it will also work.

 

I understand that, but this polling technique still presents a problem. If it's only choosing the first adapter it finds, it completely ignores the other available connections (be they vm adapters, or physical LAN). In my case, the IP block for my physical LAN is numerically below the 192 block (think 1,2,3....LAN... 191,192....). This suggests that the automatic adapter identification is somehow prioritizing the 192 block - perhaps because that's the "standard" for most folks that don't play with their network much?

 

Since Emby's behavior in the event no server is found, is to offer up the "Emby Connect" PIN screen, wouldn't it be possible to provide a manual server location at that point? Something in the realm of:

 

"Hey, since I don't see a server, here's the options you have - use Emby Connect, OR just tell me where I should be looking in the event you do have a server, and I can't find it for some reason.."

 

While the end-user can re-define LAN priorities, (or in my case, simply unplug everything until the physical LAN is the only one available), or can edit the cfg file to force an IP address for the server location, it seems like having the server configuration located INSIDE the program is problematic (it has to launch successfully, before you can tell it how to find the server - if it can't find the server, it can't launch successfully..). If Emby can't find the server, there is no longer an external way (MB Configurator), to tell it where it is, via the GUI.

Link to comment
Share on other sites

 

Since Emby's behavior in the event no server is found, is to offer up the "Emby Connect" PIN screen, wouldn't it be possible to provide a manual server location at that point? 

 

You mean something like the Manual entry button on that screen...?

Link to comment
Share on other sites

You mean something like the Manual entry button on that screen...?

 

Is there a manual entry option at this point? This thread was opened in April, so I haven't seen the Emby Connect screen in a while. It would seem, however, that a number of recent comments from other users suggest there's still some sort of issue with adapter polling.

Link to comment
Share on other sites

If my problem is the network order, then it isn't my vmware adapters because they're prioritized lower than my physical adapter. Instead it's another virtual adapter I have which I specifically wanted to be ordered before my physical adapter, so reordering isn't really an ideal solution for me.

 

Why is it that once I manually enter the server information, future sessions won't try to reuse that information? That seems like the real solution to me. I should only have to manually enter the server information once. Worst case scenario, I ought to be able to coax it into using the right adapter and/or directly specify the server information in the config file but even that doesn't appear to be possible.

 

And yes, datahedron, there is a manual entry option now.

Link to comment
Share on other sites

It isn't ignoring the last character.  The field is designed for "triple tap" input - entering letters with a remote control number pad much like texting in 2002.  So, the last letter entered doesn't "take" until a couple seconds after it is entered.

 

If you click the login button, it ought to be smart enough to realize you're done typing, whether you're using triple tap or not. I guess that also explains why my hidden user always fails to login the first time I try, and then once I retry a second time without changing the credentials, it succeeds. While my use case might be an edge case, that experience could certainly be improved. At least I understand it now though.

Link to comment
Share on other sites

If you click the login button, it ought to be smart enough to realize you're done typing, whether you're using triple tap or not. I guess that also explains why my hidden user always fails to login the first time I try, and then once I retry a second time without changing the credentials, it succeeds. While my use case might be an edge case, that experience could certainly be improved. At least I understand it now though.

 

Talk to Microsoft ;).  This is a feature of WMC.

Link to comment
Share on other sites

If my problem is the network order, then it isn't my vmware adapters because they're prioritized lower than my physical adapter. Instead it's another virtual adapter I have which I specifically wanted to be ordered before my physical adapter, so reordering isn't really an ideal solution for me.

 

Why is it that once I manually enter the server information, future sessions won't try to reuse that information? That seems like the real solution to me. I should only have to manually enter the server information once. Worst case scenario, I ought to be able to coax it into using the right adapter and/or directly specify the server information in the config file but even that doesn't appear to be possible.

 

And yes, datahedron, there is a manual entry option now.

 

Once you are successfully connected, either go to the advanced config page and set the option to connect to the current server, or change the log in behavior on the first config page to log in the current user (which implies connecting to this server).

Link to comment
Share on other sites

Once you are successfully connected, either go to the advanced config page and set the option to connect to the current server, or change the log in behavior on the first config page to log in the current user (which implies connecting to this server).

 

I went there and "current server" was preselected so all I had to do was click "continue". Thanks for that. But why should I even have to do that? If I've entered the server name once, it should automatically keep trying to use that information until the unlikely event that a new server is chosen.

 

Talk to Microsoft ;).  This is a feature of WMC.

 

Ah, got it. Well boo on them. :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...