Jump to content


Photo

Recordings do not show up in MBT


  • Please log in to reply
23 replies to this topic

#1 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 29 April 2015 - 04:35 AM

using beta release of MBS Version 3.0.5597.0 and latest dev version of MBT, plus the dvblink plugin.

 

All is good in the webserver but in MBT none of the recordings from live tv show up in MBT. I've posted this in the dvblink plugin section and got zero response so hopefully i might get some attention here.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146119 posts
  • Local time: 03:54 PM

Posted 29 April 2015 - 08:42 AM

I am not sure. Tests fine here with server wmc.



#3 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 07 May 2015 - 04:47 AM

ok, what else can else can i tell you to help? i have recordings showing up in the web client but nothing in MBT. its the only thing stopping me from transitioning to MBT from WMC but i've been stuck on this final step for a couple of months now...



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146119 posts
  • Local time: 03:54 PM

Posted 07 May 2015 - 08:09 AM

try installing the latest version of MBT from the website.  Then see http://emby.media/co...port-a-problem/



#5 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 11 May 2015 - 05:24 PM

reinstalled MBT and then did the following:

 

started emby server, waited for guide refresh to finish

went to the live tv setup page, all good

went to the live tv main page, takes about 90 seconds to fill all the data and images in the suggestions field

similarly, guide page takes about 90s to open full but is all complete when it does

channels takes 10s to open, no channel icons on server yet

tried to open recordings tab, nothing happened, refreshed, still nowt, navigated around a bit more and went back and it opened fine, almost immediately

scheduled didn't open first time but did second time round.

 

then opened mbt, now on 3.0.5591.19855

 

opened channels, couldnt get anything to stream this time

opened recordings, nothing showed up, went back to channels still no change

 

went back to the web client and the first channel started first time

 

went back to mbt and still can't get anything to play.

 

server and mbt logs attached [attachment=7967:theater-63566978938.txt] https://www.dropbox....972932.txt?dl=0



#6 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 12 May 2015 - 12:50 PM

@Luke hi?

#7 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 15 May 2015 - 06:02 PM

anyone? any further information i can provide? seems to be a problem with the dvblink plugin?



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146119 posts
  • Local time: 03:54 PM

Posted 15 May 2015 - 07:52 PM

i cannot reproduce, sorry. maybe check your parental control settings.



#9 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 15 May 2015 - 08:06 PM

i have absolutely no parental settings set for this user so i'm not sure its that. live tv recordings are available in other apps (currently testing the fire tv beta, using nexus player and roku) and mbt worked fine with serverwmc. its just dvblink and mbt that doesnt work, which unfortunately is the one i want. is it possible that mbt is just timing out waiting for the server?



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146119 posts
  • Local time: 03:54 PM

Posted 15 May 2015 - 08:11 PM

yes, but i don't see anything like that in the mbt log and also if there was a timeout you'd get an on screen error message



#11 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 16 May 2015 - 07:18 AM

ok, so i'm fairly certain now that its a problem between the server and the dvblink plugin. apart from the process of elimination, if we are saying everything looks good in the mbt logs, i've just had the server completely grind to a halt just trying to access the recordings tab in the web client. i can't access the web client at all and can't even restart it from the tray app on the server itself.

 

does this log reveal anything? this is from my production setup rather than the test setup i was using above https://www.dropbox....331200.txt?dl=0



#12 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 16 May 2015 - 08:13 AM

and i can actually remote play live tv recordings from mbs to mbt, but it still takes a while to navigate. 



#13 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 17 May 2015 - 08:44 AM

can you help me try and diagnose this please?

 

when i open the recordings tab in the web client, what is happening? is mbs querying the backend tv solution or does it build up some sort of cache?

 

i notice that even accessing the dvblink web client recordings page isn't exactly speedy. i wonder whether having the recording directory on a network location has anything to do with this? things to try...



#14 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 19 May 2015 - 09:22 AM

another complete lock up in the server just from navigating around live tv. the server hasn't logged anything for the last 2 hours [attachment=8120:server-63567590400.txt]



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146119 posts
  • Local time: 03:54 PM

Posted 19 May 2015 - 09:29 AM

try removing all plugins. you've got about 30 of them installed, which is fine, but removing them is good way to narrow down situations like that.



#16 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 19 May 2015 - 06:25 PM

ok, ive stripped one server back to just the dvblink plugin. i restart the server and wait for the guide to refresh. browse to live tv and it takes roughly a minute to bring up the suggestions. the on now suggestions have no art despite me knowing that dvblink is providing them. they are showing on the on next suggestions. guide screen takes roughly the same time to come up. channels takes 2 seconds. since i've moved the recording directory to a local drive in dvblink recordings come up within a couple of seconds, timers took about 90 seconds to come up and series did not come up first time but came up after about a minute when i refreshed the page.

 

if i continue to navigate around then at some point the page will not load properly, most often this is the recordings page but also the channels page. eventually the recordings page doesnt come up at all.

 

nothing happening in mbt recordings either

 

logs 

https://www.dropbox....672079.txt?dl=0

https://www.dropbox....674094.txt?dl=0



#17 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 26 May 2015 - 03:12 PM

so, any progress?



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146119 posts
  • Local time: 03:54 PM

Posted 26 May 2015 - 03:15 PM

it looks like it is just taking a long time to query your tv back end. i cannot answer why. my only guess is that perhaps it was not designed to be queried repeatedly as we are doing. we don't really cache the recording info for too long because they can be changed from places outside of Emby. I would report this to the builder of your live tv plugin. It does not seem to reproduce with EmbyTV, ServerWMC, or NextPVR.



#19 Spaceboy ONLINE  

Spaceboy

    Advanced Member

  • Members
  • 4171 posts
  • Local time: 08:54 PM

Posted 26 May 2015 - 07:03 PM

Ok, something to investigate. It's not the case that dvblink isn't designed for this, there are several other users using it with emby and it works perfectly adequately in kodi, just that well, it's kodi

#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146119 posts
  • Local time: 03:54 PM

Posted 26 May 2015 - 07:30 PM

because it works well in kodi or any other app doesn't mean anything. the way our live tv is designed could possibly be too stressful for dvblink. in any case, i don't have the answer right now, so your first line of defense should be discussion with the plugin developer about why the calls to dvblink are taking so long.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users