Jump to content

Mark watched in Kodi but server stays unwatched


riffy
 Share

Recommended Posts

riffy

Every time I mark something watched in Kodi, it's not marking it watched on the server now. As soon as I restart Kodi, it does a full sync & everything I've marked watched is back to being marked unwatched.

 

Also, I watched like 2 mins of a show & it marks it watched in Kodi not resumable but watched. On the server, it shows as resumable. I'm on .33 & isengaurd alpha 2.

 

 

kodi.log

  • Like 1
Link to comment
Share on other sites

riffy

I went back to the old addon & it does the same thing. Marked in Kodi as watched, server stays unwatched. Difference being that it still shows the folder in the old addon as if there is something unwatched in it. When you go into that folder tho, it shows it watched. 

 

Server issue? Server version 3.0.5597.1

Link to comment
Share on other sites

Angelblue05

Odd riffy. Reviewing the section of the code that controls the watched status is on the Trello board already. For now, we are mostly focused on getting everyone's initial sync to complete properly. :)

Link to comment
Share on other sites

Angelblue05

@@riffy

 

Are you manually marking as watched or this happens when you finish watching content? In your log, it says you played only 69% when the mark watched happens at 90% so I can't say, unless you have a more another log showing the problem? :)

Link to comment
Share on other sites

riffy

@@riffy

 

Are you manually marking as watched or this happens when you finish watching content? In your log, it says you played only 69% when the mark watched happens at 90% so I can't say, unless you have a more another log showing the problem? :)

That log was me watching only part of a show that was marked unwatched. I stopped it cuz I realized I'd seen it but Kodi marked it completely watched at the 69% or what ever. I then makred it unwatched just to see what happens in the log. Log also shows 5-6 shows I toggled watched before, it does a resync on start & marks them unwatched  again & I marked them watched again, but as soon as Kodi restarts I'm back to them unwatched. From what I remember. I ended up marking them watched in the web interface.

 

Just thought I'd add that I noticed that while messing around. Maybe it is just the new addon. If I hit the hotkey "w" to toggle something watched, it doesn't mark it on the server with the old addon. If I use the contextual menu, it marks it on the server instantly. The new addon tho... neither marks it on the server. Don't know what the difference is with the fast "w" key vs the "c" then scroll down to marked watched. I've always used the hotkey "w" before.

 

I can reproduce this over & over too. If you want a log on debug or something.

Edited by riffy
  • Like 1
Link to comment
Share on other sites

Angelblue05

"w" with the MB addon is not compatible since it doesn't use Kodi native database. Ok well what you are describing sounds like what I've been experiencing as well. For me, I can only reproduce the experience on already watched items. With recently added, it doesn't happen. How about you?

Link to comment
Share on other sites

riffy

"w" with the MB addon is not compatible since it doesn't use Kodi native database. Ok well what you are describing sounds like what I've been experiencing as well. For me, I can only reproduce the experience on already watched items. With recently added, it doesn't happen. How about you?

Any item. Old or recently added, whole seasons, basically anything I try to flag watched, doesn't get marked on the server. If I watch enough to get a resume point, Kodi marks it watched, but.. if I show watched & hit play on such an item, it asks if I want to resume. On the server it shows unwatched with a resume point. Doing the reverse also DOES change the server... marking something unwatched on Koki.

 

booooo to the "w" hotkey :-p

Edited by riffy
Link to comment
Share on other sites

xnappo

With the old addon, you must use the context menu instead of the hotkey.

 

With the new addon, 'w' should work - and it is a bug if it does not.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...