Jump to content

To Many Open Files


grimsage
 Share

Recommended Posts

I seem to be getting the following error quite often, I am running on a mac mini without anything really running.  this has only happened with the two most recent versions of Emby

2015-04-17 18:31:11.7373 Error - Main: UnhandledException
	*** Error Report ***
	Version: 3.0.5582.4
	Command line: /Applications/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
	Operating system: Unix 14.3.0.0
	Processor count: 2
	64-Bit OS: False
	64-Bit Process: False
	Program data path: /Users/user/.config/mediabrowser-server
	Mono: 3.12.1 ((detached/0849ec7)
	Application Path: /Applications/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
	Too many open files
	System.Net.Sockets.SocketException
	  at System.Net.Sockets.Socket..ctor (AddressFamily addressFamily, SocketType socketType, ProtocolType protocolType) [0x00000] in <filename unknown>:0
	  at System.Net.Sockets.UdpClient.InitSocket (System.Net.EndPoint localEP) [0x00000] in <filename unknown>:0
	  at System.Net.Sockets.UdpClient..ctor (AddressFamily family) [0x00000] in <filename unknown>:0
	  at System.Net.Sockets.UdpClient..ctor () [0x00000] in <filename unknown>:0
	  at Mono.Nat.Pmp.PmpNatDevice.CreatePortMapAsync (System.Object obj) [0x00000] in <filename unknown>:0
Link to comment
Share on other sites

 

I seem to be getting the following error quite often, I am running on a mac mini without anything really running.  this has only happened with the two most recent versions of Emby

2015-04-17 18:31:11.7373 Error - Main: UnhandledException
	*** Error Report ***
	Version: 3.0.5582.4
	Command line: /Applications/MediaBrowser.Server.Mac.app/Contents/MacOS/MediaBrowser.Server.Mac
	Operating system: Unix 14.3.0.0
	Processor count: 2
	64-Bit OS: False
	64-Bit Process: False
	Program data path: /Users/user/.config/mediabrowser-server
	Mono: 3.12.1 ((detached/0849ec7)
	Application Path: /Applications/MediaBrowser.Server.Mac.app/Contents/MonoBundle/MediaBrowser.Server.Mac.exe
	Too many open files
	System.Net.Sockets.SocketException
	  at System.Net.Sockets.Socket..ctor (AddressFamily addressFamily, SocketType socketType, ProtocolType protocolType) [0x00000] in <filename unknown>:0
	  at System.Net.Sockets.UdpClient.InitSocket (System.Net.EndPoint localEP) [0x00000] in <filename unknown>:0
	  at System.Net.Sockets.UdpClient..ctor (AddressFamily family) [0x00000] in <filename unknown>:0
	  at System.Net.Sockets.UdpClient..ctor () [0x00000] in <filename unknown>:0
	  at Mono.Nat.Pmp.PmpNatDevice.CreatePortMapAsync (System.Object obj) [0x00000] in <filename unknown>:0

same here.

Link to comment
Share on other sites

  • 2 weeks later...

I'm experiencing "too many files open as well" this happens when scanning for metadata in large directories +3000 items:

 

 

 

Snapshot of GetDashboardResource generated by ServiceStack on 5/7/2015 4:20:10 PM
Response Status
 
Error Code IOException Message Too many open files Stack Trace [GetDashboardResource: 5/7/2015 4:20:10 PM]: [REQUEST: {ResourceName:dashboard.html}] System.IO.IOException: Too many open files at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000] in <filename unknown>:0 at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share) [0x00000] in <filename unknown>:0 at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare) at MediaBrowser.Common.Implementations.IO.CommonFileSystem.GetFileStream (System.String path, FileMode mode, FileAccess access, FileShare share, Boolean isAsync) [0x00000] in <filename unknown>:0 at MediaBrowser.WebDashboard.Api.PackageCreator.GetRawResourceStream (System.String path) [0x00000] in <filename unknown>:0 at MediaBrowser.WebDashboard.Api.PackageCreator+<GetResource>d__0.MoveNext () [0x00000] in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x00000] in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00000] in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00000] in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00000] in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[system.IO.Stream].GetResult () [0x00000] in <filename unknown>:0 at MediaBrowser.Server.Implementations.HttpServer.HttpResultFactory+<GetStaticResult>d__7.MoveNext () [0x00000] in <filename unknown>:0 Errors
I searched on the web to find a cause or better yet a fix and got this (I'm on linux):

 

 

Too many open files

This error can occur on some Linux systems when using the embedded Derby database. Derby opens several file handles and may run over the maximum limit set by the system.

The solution is to increase the limit. The exact procedure varies from one Linux distribution to the next. The procedure below works on Ubuntu. For other systems, see Too many open files.

To set a system wide limit for open files on Ubuntu Linux:

  1. Find the current maximum number of open files per user in a single session: 
    ulimit -n 
    By default the number is 1024 which is too small.
  2. Edit the limits.conf file: 
    sudo gedit /etc/security/limits.conf
  3. Add the following lines to the file: 
    * soft nofile 10000 
    * hard nofile 50000 
    This sets for all users a soft limit of 10000 open files and a hard limit of 50000. These are just example numbers. Set them according to your system needs. Note that the wildcard option applies only to regular users, not to superuser. If you run Magnolia CMS as superuser replace the asterisk with root.
  4. Save the file.
  5. Edit the configuration file for session-related modules: 
    sudo gedit /etc/pam.d/common-session
  6. Add the following line to the file: 
    session required pam_limits.so
  7. Save the file.
  8. Restart Ubuntu.
  9. Verify the new maximum number of open files: 
    ulimit -n 
    The command should now return 10000.

 

 

As I understood the danger with too many open files is that your system might become unresponsive due to processing locking & clocking things up. So I will give it a try and see what happens.

Link to comment
Share on other sites

I don't, so I checked out 'ulimit' and all its respective flags/settings and changed it as above (btw rather than rebooting you can use 'sysctl -p' to make changes effective). This seems to have fixed the problem for me, at least the scan and metadata recognition didn't fail and ran until it was complete.

Edited by jody
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...