Jump to content
icthusman1

Box Sets causes movies to show in child's account

Recommended Posts

icthusman1

I just installed the Auto Box Sets plugin (great work EBR!) and it seems nice except for one thing. I had manually tagged some movies to remove them from my child's account. They are now showing again and I believe it is due to them being added to a collection.

 

For example. I have my son's account set to only show things PG and below. I then manually tagged things with "notkids" to remove other unwanted items. After installing Auto Box Sets, I now have some of those movies back. So now the Poltergeist movie (rated PG when it came out) is showing in his movie section. The tag is still on the movie, so I can only assume it is showing due to this plugin. Is this something that can be fixed? Or do I just need to go and tag the collections as well?

Share this post


Link to post
Share on other sites
Luke

Where are the movies shown?

Share this post


Link to post
Share on other sites
icthusman1

Where are the movies shown?

552748250eb0e_Collectionview.png

5527483862007_Movieview.png

So, there you can see Poltergeist showing in both the Collection view as well as just the standard Movie view. Again, if I tag the collection with my "notkids" tag, it pulls the movie and the collection out. If I only have the movie tagged, having it in the collection causes the tag to be ignored.

 

I realize that this may not actually be an issue with the plug-in, but might actually be a server issue. Please move my thread elsewhere if need be.

 

Thanks Luke!

Share this post


Link to post
Share on other sites
Luke

as a test if you remove the movie from the collection, what happens then?

Share this post


Link to post
Share on other sites
wolf359

I have the same issue with my cillections but as said the movies are not showing so cannot be played. Perhaps some code could be added to remove empty folders from collections ?

Share this post


Link to post
Share on other sites
icthusman1

as a test if you remove the movie from the collection, what happens then?

It respects the tag and does not show. It is the fact that it is in the collection that causes the problem.

 

I have the same issue with my cillections but as said the movies are not showing so cannot be played. Perhaps some code could be added to remove empty folders from collections ?

I don't know what you are talking about here. I was able to play the movie from my son's account in the web player. It is not just an empty collection that is showing, it is the collection with a movie (or multiple movies depending on the collection). Another example, the Harry Potter movies. I tagged them out but their collection added them back in for some reason. Which seems weird, weren't those PG-13??

Share this post


Link to post
Share on other sites
ebr

Pretty sure this is an issue with the actual collections as opposed to the plug-in. Luke, please ping me if you find otherwise.

  • Like 2

Share this post


Link to post
Share on other sites
Luke

I have tried to reproduce this but I cannot. Here is how I tested, please advise if I should try anything differently

 

- created a tv library with two movies - one tvpg, another R

- then created a collection (boxset) and added both movies to it

- then created a user with max parental rating PG

 

At this point everything worked as expected without even having to bother with tags. I logged in as the user, opened the collection and did not see the R movie. For the sake of completeness I went ahead and tested it the tags way - removed the parental rating from the user, which caused the R movie to show up. Then added nokids tags to both the user profile and the movie. Again it worked as expected.

Share this post


Link to post
Share on other sites
Erik

Here is my configuration:

My user has access to the following libraries:

- TV Shows

- Kids TV Shows

- Movies

- Kids Movies

 

My kids user only has access to the following libra it's:

- Kids TV Shows

- Kids Movies

 

Now, when I go into my kids user account, then movies, then collections, I can see all the collections, "Alien Anthology" for example. However, once I enter that collection there are no movies present.

 

So the system is shiwing he movies correctly, but incorrectly still displaying the top level collections folder even if the movies are not available in their associated library.

 

I believe it's because the collections are handled outside of the individual movies folder libraries and therefore are outside of the filtering done by user.

 

Thanks,

Erik

Share this post


Link to post
Share on other sites
ebr

You don't have to use tags.  You can just give the collections a rating.

 

This is not a parental control issue.  This is the same old issue of all collections showing for all users because they are defined globally.

Share this post


Link to post
Share on other sites
icthusman1

I have tried to reproduce this but I cannot. Here is how I tested, please advise if I should try anything differently

 

- created a tv library with two movies - one tvpg, another R

- then created a collection (boxset) and added both movies to it

- then created a user with max parental rating PG

 

At this point everything worked as expected without even having to bother with tags. I logged in as the user, opened the collection and did not see the R movie. For the sake of completeness I went ahead and tested it the tags way - removed the parental rating from the user, which caused the R movie to show up. Then added nokids tags to both the user profile and the movie. Again it worked as expected.

So Luke, the issue is that there are movies rated PG that I want removed. So again, Poltergeist. When that came out in the early 80's there was no PG-13 rating. So the movie got a PG rating. Now, there is no way I am letting my 5 year old son watch that movie. So I used a custom tag to remove it from his view. After I installed the Auto Box Sets plugin, the collection started showing in his account with Poltergeist in it. The second and third movies in the series were PG-13 and do NOT show. There is no indication that I even own more than one of the movies.

 

So, the collection is overriding the custom parental tag so that the PG movie I removed with a tag now shows again and is playable.

 

 

You don't have to use tags.  You can just give the collections a rating.

 

This is not a parental control issue.  This is the same old issue of all collections showing for all users because they are defined globally.

I think this might be the answer here. To give the collection a rating. However, there is definitely something broken in the server implementation of collections that they don't honor custom tags on the movies inside the collection.

Share this post


Link to post
Share on other sites
Luke

i tested it with tags though and found no issue

Share this post


Link to post
Share on other sites
icthusman1

Yes, but I have the parental rating turned on and am not talking about an R rated movie. This is a PG movie that is allowed under parental ratings. That's why I had to use tags to remove the PG movie.

Share this post


Link to post
Share on other sites
Luke

these are just semantics but i tested basically the same issue. note that i'm running the server at primarily default metadata settings so perhaps there's a wrinkle there we're not seeing.

Share this post


Link to post
Share on other sites
icthusman1

First off, thank you Luke for all the effort you are putting in here. I do appreciate it.

 

I'm afraid though that I don't understand why you think your test was the same as what I am doing. The collection is not causing an R rated movie to show. It is causing a PG rated movie to show. His account allowed PG movies. The collection bypasses the custom tag on the movie which results in the system falling back to movie rating and deciding it can be there since it is only rated PG. The parental controls are working just fine.

 

So again, the problem is that the collection bypasses the custom tag causing the system to fall back to rating and deciding that since the movie is PG it should be included. The key here being that collections break the custom tag system.

Share this post


Link to post
Share on other sites
Luke

Understood. I just did a test of that and that also worked as expected, so now I am back to my earlier theory of it being metadata related.

Share this post


Link to post
Share on other sites
Luke

just to confirm, these collections were created with the web interface or the auto-boxset plugin? Or are they old style with [boxset]?

 

in the server dashboard under metadata, have you changed any settings away from defaults, and if so, which ones?

Share this post


Link to post
Share on other sites
icthusman1

just to confirm, these collections were created with the web interface or the auto-boxset plugin? Or are they old style with [boxset]?

 

in the server dashboard under metadata, have you changed any settings away from defaults, and if so, which ones?

I never used boxsets until I installed the plugin 2 days ago.

 

I don't believe I have changed any. I have poked at the settings but pretty much left them normal. I did change subtitle settings, added my account and whatnot.

Share this post


Link to post
Share on other sites
ebr

When you say you used a "Parental tag" do you mean you actually added a "tag" and then used the block tags feature or did you use the "Custom Rating" field which is actually designed for the exact situation you have here (a rating from the MPAA doesn't agree with how you want it treated)?

Share this post


Link to post
Share on other sites
icthusman1

Yes to the tag part. So you are saying I shouldn't be using those?

 

I like the custom tag feature because it allows me to set tags for different levels. Then when I decide stuff with a certain tag is Ok, I can just remove that tag from the account restrictions.

 

I guess the custom rating is sort of similar. Although probably not as granular as you can get with the tags.

Share this post


Link to post
Share on other sites
Luke

no, you certainly can use them. rating, custom rating, tags, library access, those are all just different forms of content control at your disposal

Share this post


Link to post
Share on other sites
ebr

You can use either one or both but the custom rating field was created for the exact scenario you suggested (the MPAA rating of a movie doesn't agree with your opinion) so that would just be the simplest way for that one item.

Share this post


Link to post
Share on other sites
icthusman1

You can use either one or both but the custom rating field was created for the exact scenario you suggested (the MPAA rating of a movie doesn't agree with your opinion) so that would just be the simplest way for that one item.

Yeah, but I am removing more than just this one item. I have used this only as an example. There are a lot of other PG movies that I don't think are appropriate yet for my (almost) 5 year old. So the custom tags are nice since I can use tags for different age levels and then just remove tags from the user account as he gets older. This also leaves the tags in place for my youngest son. So I still think the tag route is the better one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...