Jump to content

Weird Bug


breezytm
 Share

Recommended Posts

breezytm

I noticed this weird bug last night. I don't know when it started. I looked through some of my older scanned contents and the problem appears there as well. 

 

post-3483-0-22848600-1428333158_thumb.png

post-3483-0-09301900-1428333161_thumb.png

Link to comment
Share on other sites

breezytm

I am using it. 

 

I am going around fixing these manually. Should I just leave them in case the addon is what causing the problem?

Edited by breezytm
Link to comment
Share on other sites

olerocker

Hi guys, I am having the same issue.

I reported it in the windows server thread but it appears to have something to do with the kodi plugin.

 

I am using the old plugin. It appears that the plugin somehow corrupts the metadata on the server after you watch an episode.

 

This has been happening since the server upgraded a couple of days ago if I remember correctly.

 

I have 2 kodi clients and the problem appears on both of them.

 

The strange thing is that it doesn't appear on all files, just on a few shows.

Edited by olerocker
Link to comment
Share on other sites

xnappo

If you know how to recreate this, what we really need is a SERVER log to see what is happening.  Seems like somehow when we send a 'watched' update it is causing something wacky to happen.  It is weird because I don't really get how we can be changing the database as we consider it read only other than 'played'.

Link to comment
Share on other sites

is the addon or perhaps kodi updating the metadata to include the watched flag in the nfo? perhaps something is going on there that needs to be looked at.

Link to comment
Share on other sites

xnappo

If we were talking about just the new addon, I might think Kodi was messing the the NFO file.  But I can't see how the old one would do that.

 

Is there any way to tell Emby not to look at nfo files at all?

Link to comment
Share on other sites

If we were talking about just the new addon, I might think Kodi was messing the the NFO file.  But I can't see how the old one would do that.

 

Is there any way to tell Emby not to look at nfo files at all?

 

if you use old style xml then you can prioritize that over nfo, but if all you have is nfo then no, there is no ignore setting. There's nothing wrong with that, but isn't it beside the point? what if the user wants nfo metadata?

Link to comment
Share on other sites

xnappo

It might, but you need to tell us what it means.  What did you do exactly the triggered that?

 

Luke - one thing we are doing in the old addon is manually sending a post to marked watched.  This is not really needed anymore since the server does it as well, but I don't see how it could corrupt anything.

 

The new addon used to do this too - but we have removed it.

Link to comment
Share on other sites

xnappo

if you use old style xml then you can prioritize that over nfo, but if all you have is nfo then no, there is no ignore setting. There's nothing wrong with that, but isn't it beside the point? what if the user wants nfo metadata?

Just for testing.

Link to comment
Share on other sites

well to trace this down i would watch the media folder for nfo changes. then if there's a change, find out who is making the change. that should solve the mystery.

Link to comment
Share on other sites

xnappo

Yeah - do you guys have NFO files?  I don't use them - and I think I have seen the problem anyway but not positive.

Link to comment
Share on other sites

olerocker

It might, but you need to tell us what it means.  What did you do exactly the triggered that?.

If you referring to me, all I did is watch an episode. After it was over I pushed stop and the media browser plugin started syncing with the server all of a sudden a season unknown folder appeared with the episode I just watched in it.

Link to comment
Share on other sites

breezytm

I don't really maintain nfo files but some of my movies have them but not tv shows. 

 

I created this post http://emby.media/community/index.php?/topic/20028-emby-for-kodi-multiple-episodes-with-00/ before I understood the issues were related. Having multiple episodes in Kodi with 00 was from the start. Right after Emby finished syncing. I went on the web client to see if it was pulling the wrong data from the server and noticed the changes. 

Link to comment
Share on other sites

olerocker

This issue wasn't present with older versions of the server, I don't know for sure from what version this started happening.

 

Is there a way that I could fix the metadata or redownload it without losing the watched status of the media?

Edited by olerocker
Link to comment
Share on other sites

well he said he doesn't use nfo files but that doesn't mean kodi or something else didn't save one.

 

if that's not it then i really don't know. someone will have to reproduce and monitor who's touching what.

Link to comment
Share on other sites

xnappo

Okay @@Luke - so no NFO files involved.  Any way you can possibly see a POST request for marking watched could cause the metadata on the server to corrupt?

Edited by xnappo
Link to comment
Share on other sites

breezytm

I also noticed another bug which I would create another thread for. When Kodi is running with Emby I constantly get the "loading" box popping up at random time but frequent. Looking at the logs it appears as if Emby is always doing something in the background. It would be nice to make changes base on the server events. Update Kodi library after the server finished running the "scan media library" task only. Add a manual update button for those who want to manually update their library at random time. Update the watched state when the video finished playing or stop only. Do a pull and push. My FTV can't keep up with all that transaction. Kodi constantly freezing. I can't have both Kodi and Emby for WMC running at the same time. One of them would crash. I know it's not my clients because before introducing the new Emby client for Kodi MBC been running fine for the last year and half. 

Edited by breezytm
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...