Jump to content

Emby crashing - Ubuntu server


daniellog

Recommended Posts

jacob.alberty

For the debian guys if you pull the sid linux-image-amd64 .deb file and dpkg -i it then reboot with it it seems to fix at least the bug-18026.cs bug, assuming that is whats causing it to crash for us that should be a fix. I just installed it and am running that bug-18026 test now emby  only been up about 8 minutes so dont know for sure how stable emby itself is, i'll report back later.

 

A few caveats though. First off make sure you install just the .deb, dont try to use apt to pull it from sid, things can get nasty.

For some reason all of my docker images got wiped when i did this, they're still sort of there as in they take up space but docker images and docker ps show nothing.

I used the following command to reinitalize my docker setup

systemctl stop docker && mv /var/lib/docker /var/lib/docker.old && mkdir /var/lib/docker && systemctl start docker

This will leave all of the old content sin /var/lib/docker.old while giving me a new freshly configured docker setup.

reinitalizing all of my old containers from there and everythings back up and running.

 

Edit: emby has been running for 24 hours on my debian server now with the new kernel with no crashes or other issues that appear related the kernel version i installed is 4.0.0-1-amd64 and is available at https://packages.debian.org/sid/linux-image-amd64 You want the 4.0+64 version for amd64. This fix is debian only and is only a temporary fix please revert back to the stock kernel iffenwhen debian pushes a fix to the stable kernel

Also the docker issues i had may be unrelated to the kernel but i'm leaving them in my post just in case someone else runs into it when upgrading.

Edited by jacob.alberty
Link to post
Share on other sites
ryantiger658

I have read through all of the posts on this thread, and just to confirm we are waiting for an update to the Debian/Ubuntu Kernel? I don't want to go through a ton of trouble if there will be an update soon. But it would be nice to have my server up and running again. :) 

 

I am having the same crashes on Ubuntu Trusty 3.13.0-53. Oddly enough I am not running on a VM, but am experiencing all of the same problems that users on this post are.

Is there any way we can pin a summary of the problem, and the resolution on the forum, or the beginning of this thread so that the affected users can know that it is a known issue waiting on resolution?

  • Like 1
Link to post
Share on other sites
daniellog

I have read through all of the posts on this thread, and just to confirm we are waiting for an update to the Debian/Ubuntu Kernel? I don't want to go through a ton of trouble if there will be an update soon. But it would be nice to have my server up and running again. :)

 

My same thoughts, I'd rather keep the kernel in line with ubuntu updates, will this be released soon? 

Link to post
Share on other sites
daniellog

Was having issues with sonarr, just thought to hell with it and installed v4 kernel on ubuntu server 14.04 lts:

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-headers-4.0.4-040004_4.0.4-040004.201505171336_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-headers-4.0.4-040004-generic_4.0.4-040004.201505171336_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-image-4.0.4-040004-generic_4.0.4-040004.201505171336_amd64.deb
dpkg -i linux-*.deb

Seems to be a hell of a lot more stable now, I'll reinstall emby.

Link to post
Share on other sites
daniellog
root@viper:~# apt-get install mediabrowser 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 mediabrowser : Depends: mono-devel (>= 1.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hmmm, maybe not  <_<

Link to post
Share on other sites
hurricanehrndz
root@viper:~# apt-get install mediabrowser 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 mediabrowser : Depends: mono-devel (>= 1.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Hmmm, maybe not  <_<

 

There is no more mediabrowser package. Please use the new ppa, as the old ones got deleted.

Link to post
Share on other sites
Taloth Saldono
FYI I pulled the latest early testing builds from the kernel ppa

All tested on a 14.04.2 vm.

But I only ran the testcase, not actually Sonarr or Emby.

 

14.04.1 trusty:

3.13.0-53.x was still crashing. (trusty-updates)

3.13.0-54.61 seems to work. (ppa)

 

14.04.2 lts-utopic:

3.16.0-38.30 was still crashing. (trusty-updates)

3.16.0-39.31 seems to work. (ppa)

 

Prolly could use someone versed in linux to try it out on a physical machine. (Obviously only if Emby was crashing on that machine).

But I take no responsibility if it utterly breaks your machine, coz these are early testing builds. Don't blindly add the ppa, it gotta be pinned with lower priority to avoid unwanted updates. 

Edited by Taloth Saldono
  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...