Jump to content

MovieName-Cover.jpg becoming primary image instead of folder.jpg


reddevil
 Share

Recommended Posts

Hi,

 

I have some downloaded covers for movies with the format 'MovieName'-Cover.jpg and it is becoming the primary image instead of folder.jpg.

 

Part of Log:

2015-03-27 07:59:24.9861 Info - App: StartupTrigger fired for task: Log file cleanup
2015-03-27 07:59:24.9861 Info - App: Executing Log file cleanup
2015-03-27 07:59:24.9861 Info - App: Log file cleanup Completed after 0 minute(s) and 0 seconds
2015-03-27 07:59:54.9869 Info - App: StartupTrigger fired for task: Cache file cleanup
2015-03-27 07:59:54.9869 Info - App: Executing Cache file cleanup
2015-03-27 08:00:06.9166 Info - App: Cache file cleanup Completed after 0 minute(s) and 11 seconds
2015-03-27 08:00:07.4737 Debug - App: Running MovieNfoProvider for H:\Movies Library\Movies SHQ 1\Captain America- The Winter Soldier (2014) [MP4 1080p 7.1-AAC]\Captain America- The Winter Soldier (2014).mp4
2015-03-27 08:00:07.5167 Debug - App: Running FFProbeProvider for H:\Movies Library\Movies SHQ 1\Captain America- The Winter Soldier (2014) [MP4 1080p 7.1-AAC]\Captain America- The Winter Soldier (2014).mp4
2015-03-27 08:00:08.6137 Debug - ProviderManager: Saving H:\Movies Library\Movies SHQ 1\Captain America- The Winter Soldier (2014) [MP4 1080p 7.1-AAC]\Captain America- The Winter Soldier (2014).mp4 to Nfo.
2015-03-27 08:00:13.0190 Debug - App: Saving H:\Movies Library\Movies SHQ 1\Captain America- The Winter Soldier (2014) [MP4 1080p 7.1-AAC]\Captain America- The Winter Soldier (2014).mp4 to database.
2015-03-27 08:01:39.3709 Warn - App: Series files missing for series id 80270
2015-03-27 08:01:39.3709 Warn - App: Series files missing for series id 270531
2015-03-27 08:01:39.3709 Warn - App: Series files missing for series id 80344
 
Am using MediaBrowser Server version 3.0.5518.7 on Win 7 Sp1 x64 Ultimate. 'Enable real time monitoring' is turned off. 'Screen grabber' option is turned off. 'Download artwork and metadata from the internet' is off as well (unticked).
 
There are no errors in the log. I use MCM as my info scraper. Movie folder contains backdrops, folder.jpg, poster.jpg, movie.xml, extrafanart folder, 'MovieName'.nfo, 'MovieName'.jpg.
 
Any way to force use of folder.jpg?
 
Regards,
MaKS
Edited by reddevil
Link to comment
Share on other sites

The server is currently looking in the order of

 

{movie}-cover.ext

{movie}.ext

folder.ext

 

(among others i removed for brevity). I will fix this to be

 

{movie}.ext

{movie}-cover.ext

folder.ext

 

The image files containing {movie} are more specific than folder so that is why they are given higher priority. It is something we'd like to make configurable at some point but it hasn't happened yet.

Link to comment
Share on other sites

EMBY Server Version 3.0.5569.0 is successfully loading {movie}.ext or folder.ext for new movies added.

 

For already updated ones, in the metadata manager a manual refresh or advanced refresh is required, after removing the primary image, to set the correct primary image.. i.e. each movie folder has to be done separately because the parent folder manual refresh or advanced refresh (full refresh with replace images) is not affecting the child movie folders. Any advice or fix?

 

Thanks,

MaKS.

Edited by reddevil
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...