Jump to content

Serious frame drops on MKV/AC3 movies


EduardoSantos
 Share

Recommended Posts

EduardoSantos

I am experiencing serious frame drops on several movies when played on any of my Roku3 devices. 

Movies are played directly (without transcoding) but the image has little movement: it seems a sequence of stills with a lot of frames dropped in between them.

 

Same movies play fine on Windows 8 app (direct play) and on Chrome browser (transcoded).

 

This does not occur with all movies, so I did lots of tests to better determine the scenario (e.g.: codecs) that causes this phenomenon.

 

The common factors to every movie with this problem are:

Container: MKV

Audio: AC3

 

AVIs with AC3 audio streams are not problem as they all get transcoded.

 

I disabled AC3 (DD) passthrough on the Roku configuration. This setup made MKVs with AC3 audio streams to be transcoded. As they are transcoded they play fine with no jitter/frame drops.

 

 

This is, though, no solution: disabling AC3 also disables DTS and thus all movies are transcoded resulting on only on 2 audio channels.

 

I suspect this problem relates to Roku's new firmware as these movies used to play fine on same Rokus.

So if anybody could just test MKVs/AC3 on a Roku and share the result it would be very good.

 

My setup is as it follows:

MB Server version: 3.0.5518.7

Roku app version: 1.87

Roku firmware version: 6.1 build 5604

Edited by EduardoSantos
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...