Jump to content


Photo

Delayed collection group display

collection group

  • Please log in to reply
68 replies to this topic

#1 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 27 December 2014 - 06:07 AM

I have about 400 movies, several of which are collections. I have selected the option to group collections on the movie page. When rescanning the library the grouping of the collections on the movies page is not reflected for quite some time. Not sure how long it takes but more than 2 and a half hours (and less than a day) my case. When I check the next day they are grouped.

Apparently, some process other than library scan is performing the grouping. Is there a way to force the grouping to occur in real-time?


Edited by RedStripe, 27 December 2014 - 07:31 AM.


#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50923 posts
  • Local time: 11:32 PM

Posted 27 December 2014 - 07:52 PM

That grouping is done in real time now so something else is going on.



#3 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 27 December 2014 - 08:51 PM

Any suggestions on what I do next to ID the something else that is going on?



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50923 posts
  • Local time: 11:32 PM

Posted 27 December 2014 - 08:56 PM

Screen shots of what you are seeing in the two instances?



#5 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 27 December 2014 - 09:04 PM

Not sure what you mean. A screen shot of the collection grouped and another of it not grouped?!


Edited by RedStripe, 28 December 2014 - 12:22 AM.


#6 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 28 December 2014 - 01:11 AM

Here are the screenies I can think of providing and have available now for "The Godfather Trilogy Collection":

 

Folder structure:

549f904a91d32_collectionfolderstructure.

 

Collection View:

549f90680cf7c_Collectionview.png

 

Godfather Trilogy collection contents:

549f920e1c2df_GFTrilogycollectioncontent

 

Movie View (ungrouped):

549f909453f02_GFTrilogyungrouped.png

 

Display Settings:

549f90a88ced4_Displaysettings.png

 

I will provide a screenie of the grouped Godfather Trilogy collection when it becomes available in some hours.


Edited by RedStripe, 28 December 2014 - 01:17 AM.


#7 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18515 posts
  • Local time: 08:32 PM
  • LocationWashington State

Posted 28 December 2014 - 02:38 AM

Are you using the Auto Boxset plugin?  Or are you manually making all collections?

 

Does each movie have the TheMovieDB Collection ID (230)?



#8 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 28 December 2014 - 03:11 AM

Finally...here is the Movie View with The Godfather Trilogy grouped:

 

549face27ebea_GFTrilogyMovieViewgrouped.

 

 

Please note that the Iron Man collection has not yet grouped itself.



#9 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 28 December 2014 - 03:24 AM

I am manually creating the collections through Media Browser (i.e., NOT via the file system).

 

TheMovieDB Collection ID is indeed 230 for each movie. (no screenshots...trust me :))

 

TheMovieDB Collection ID is blank for "The Godfather Trilogy":

 

549fb0210069e_Capture.png



#10 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18515 posts
  • Local time: 08:32 PM
  • LocationWashington State

Posted 28 December 2014 - 04:13 AM

I am manually creating the collections through Media Browser (i.e., NOT via the file system).

What process are you using to create collections?  Your collections are nested collection (file system).

 

 

TheMovieDB Collection ID is blank for "The Godfather Trilogy":

Possible because TMDB name it collection and not trilogy.  You would have to look at your logs but you will probably see errors trying to look up that name.

https://www.themovie...ion?language=en


Edited by Happy2Play, 28 December 2014 - 08:15 AM.


#11 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 28 December 2014 - 07:04 AM

I believe the issue is resolved. I had enabled "Lock this item to prevent future changes" on all of my collections. At one time I had everything set as I wanted and thought this setting would preserve that state. Once I disabled this setting things began to behave as expected. Hope this helps someone else with similar problems.



#12 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 28 December 2014 - 09:25 AM

I spoke too soon. The issue persists and the screenshots provide earlier remain relevant.



#13 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50923 posts
  • Local time: 11:32 PM

Posted 28 December 2014 - 10:56 AM

"The Godfather Trilogy" in your explorer screen shot is not a collection as far as MB is concerned (unless you put a collection.xml file in it).  It is just an organizational folder with movies in it.

 

You need to get rid of that folder and just put the Godfather movies on the same level as all the others.  Then use either Auto Box sets or the web interface to create your collection and you are done.


  • CashMoney, saajan4u and overClocked! like this

#14 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 31 December 2014 - 05:37 PM

I am sorry ebr...but I do not understand your last response. Although the "The Godfather Trilogy" is an organizational folder the screenshots appear to indicate that the movie files in "The Godfather Trilogy" folder are seen by MB as a collection and displayed as such the Collections view and eventually in the Movies view. For my better understanding please clarify:

"The Godfather Trilogy" in your explorer screen shot is not a collection as far as MB is concerned...

Thanks


Edited by RedStripe, 31 December 2014 - 05:41 PM.


#15 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50923 posts
  • Local time: 11:32 PM

Posted 31 December 2014 - 06:40 PM

If they are showing up in a collections view then that is because you have Auto Box sets installed or you created that collection through some other means.  The fact that they happen to also live under a folder with that name is coincidental.

 

You should move them out of that structure to avoid confusion.



#16 StealthDefender OFFLINE  

StealthDefender

    Advanced Member

  • Members
  • 193 posts
  • Local time: 04:32 AM

Posted 13 February 2015 - 01:25 PM

Seems that other people also have problems with the Collections.

Something went wrong with this............

Makes no sense a powerfull and working feature to delete!


Edited by StealthDefender, 13 February 2015 - 01:25 PM.


#17 CashMoney OFFLINE  

CashMoney

    Advanced Member

  • Members
  • 255 posts
  • Local time: 04:32 AM
  • LocationEngland, UK

Posted 13 February 2015 - 02:59 PM

What ebr is saying is you currently have the media files for that collection as -

 

My Movies

 -Another movie you have

 -More Movies

 -The Godfather Trilogy

  --The Godfather

  --The Godfather part 2

  --The Godfather part 3

 

you need to change that to -

 

My Movies

 -Another movie you have

 -More movies

 -The Godfather

 -The Godfather part 2

 -The Godfather part 3

 

Take the 3 godfather movie folders out of the Godfather Trilogy folder, and put the 3 movies into population with your other movies. Then you can either rely on the Autoboxsets plugin or use the metadata manager to make those 3 movies a collection. 

 

@StealthDefender, going by other posts you have made elsewhere, your problem is more likely that you made the collection in the file system using the [boxset] tag on the directory, a feature that is no longer documented nor needed since you can manually create collections within the metadata manager. If you follow the above as well, it will likely fix your problem too. 

 

HTH


Edited by CashMoney, 13 February 2015 - 03:01 PM.

  • StealthDefender likes this

#18 StealthDefender OFFLINE  

StealthDefender

    Advanced Member

  • Members
  • 193 posts
  • Local time: 04:32 AM

Posted 13 February 2015 - 03:45 PM

I take a look on this, in my opinion the [BoxSet] tag is he easiest way!
I got it to work now, i take a look how long does it takes if its broken again, downgradet the server from beta to public
Dont know if this was the problem!
Greetz Stealth
  • DarkKniyt (John) likes this

#19 RedStripe OFFLINE  

RedStripe

    Advanced Member

  • Members
  • 210 posts
  • Local time: 09:32 PM

Posted 13 February 2015 - 04:11 PM

...in my opinion the [BoxSet] tag is he easiest way!

 

I agree that with you StealthDefender.


  • DarkKniyt (John) and StealthDefender like this

#20 Deathsquirrel OFFLINE  

Deathsquirrel

    Advanced Member

  • Members
  • 2080 posts
  • Local time: 08:32 PM

Posted 13 February 2015 - 05:32 PM

As others have said, the correct, documented, supported method of creating collections is:

  1. Keep your movies for the collections in the same folder structure as any other movie:

    \\share\Movie Title 1 (year)
    \\share\Movie Title 2 (year)
    \\share\Movie Title 3 (year)
     
  2. Allow the library scanner to find and identify the movies.
  3. Allow the autoboxset plugin to create the collection OR create them by hand.

As luck would have it that's also the least work.  It requires absolutely no special folder structure or folder naming conventions.

 

It used to be managed by setting up special folder structure and naming conventions.  That was unpopular and has been retired.







Also tagged with one or more of these keywords: collection, group

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users