Jump to content

MBC or ROC?: loading themevideos takes a while sometimes


heula
 Share

Go to solution Solved by ebr,

Recommended Posts

Some annoying stuff with the MBClassic and Video themes according to my wife and I have seen this to myself. Don't know if this a MBClassic issue or (ROC)Theme issue.


 


When entering a serie it is loading the videotheme but when the video is not playing yet and an episode is selected then the episode sometimes won't play (MPC_HC) and returns back to the episode detail page. When hitting start to play the episode again then the themevideo and episode are playing at the same time. This is mostly the case after MBClassic has been freshly started.


Link to comment
Share on other sites

leedavies

It is a theme issue as MBC does not implement this directly.  Moving to plugins.

 

Is it really that clear?  A theme calls the core API to play something.  I can't say where the fault lies from the description I've read so far.  It could be the theme not picking up the video files, it could be the core not playing them.

 

One clue in the original post suggests the problem is MBC or the core and not the theme - it happens most frequently right after a restart of MBC.  As I'm sure you're aware, a theme startup or behaviour isn't affected by how recently MBC was started.  That leads me to believe it may not be a theme issue.

 

Regardless, I think more data is needed before we can judge.

Link to comment
Share on other sites

Is it really that clear?  A theme calls the core API to play something.  I can't say where the fault lies from the description I've read so far.  It could be the theme not picking up the video files, it could be the core not playing them.

 

One clue in the original post suggests the problem is MBC or the core and not the theme - it happens most frequently right after a restart of MBC.  As I'm sure you're aware, a theme startup or behaviour isn't affected by how recently MBC was started.  That leads me to believe it may not be a theme issue.

 

Regardless, I think more data is needed before we can judge.

I shall test this is another theme to see what happens there.

Link to comment
Share on other sites

leedavies

I shall test this is another theme to see what happens there.

 

Cool, thanks.  I think that would be good info.  As long as we're talking playback of the item and not just video backdrops, as it's only ROC and Crystal that support that feature.

Link to comment
Share on other sites

Cool, thanks.  I think that would be good info.  As long as we're talking playback of the item and not just video backdrops, as it's only ROC and Crystal that support that feature.

In NEO the video backdrops are playing also. Only need to check if this issue is with that theme to. I'll let you know.

Link to comment
Share on other sites

leedavies

Video backdrops will be playing in Neo because you've turned on the 'enable background media in all themes" option in ROC, as Neo doesn't support video backdrops - ROC upgrades it if you turn in that option.

 

So you're not testing Neo, you're just running the same ROC code. The answer may be in the MB log file, as that will tell you the time at which ROC asked the core MB system to play the video backdrop file.

 

Is the delay... you see BEFORE the log file reports ROC requesting the video start playing or after?

Link to comment
Share on other sites

Is it really that clear?  A theme calls the core API to play something.  I can't say where the fault lies from the description I've read so far.  It could be the theme not picking up the video files, it could be the core not playing them.

 

 

The main key to my determination is he said this is an interaction with background theme videos and that feature is only implemented in these themes.  So, the first line of determination needs to be done in the theme and I needed to put the topic where it would garner your attention.

Link to comment
Share on other sites

leedavies

The main key to my determination is he said this is an interaction with background theme videos and that feature is only implemented in these themes.  So, the first line of determination needs to be done in the theme and I needed to put the topic where it would garner your attention.

 

Absolutely, glad you did, as I may not have spotted it otherwise!

 

Will be interesting to see what the logs reveal.

Link to comment
Share on other sites

Okay here is what I have done testing with ROC and default theme.

 

- At first I have restarted my pc because that's where it al starts with in the first place I think.

- Opened MBC with ROC theme.

- Go to my series and select a random serie (Blue bloods) with video backdrop.

- This screen shows what happens. The loading icon is there for a few seconds and then I get the series screen. No sound and no video hearable and visable.

 

Video%20themes%20loading%20issue%20first

 

- I go to the episode and select it and hit play to start the episode.

- The episode starts playing and the theme video starts playing but I can only hear the video backdrop while I can watch the episode.

- Shortley after that the video backdrop ends playing.

- Closed MBC and restarted it and followed the same steps. All goes well now. No delay on anything.

- Put my pc to sleep mode and woke it again.

- Same steps and and all goes just like it should.

 

- Selected default theme and restarted my pc.

- Opened MBC with Default theme.

- Go to my series and select a random serie (Blue bloods) with video backdrop.

- Same screen as in ROC with the loading icon and then after a few seconds I get the series screen. Difference is I can hear the sound of videobackdrop and the video in the small NVP screen.

- The episode starts playing normal after that.

 

Both themes needs to load something that is causing the loading icon to stay for a few second every first time after a pc restart and only then it seems. Wondering why this is? Defaulth theme needs loading but does the job right away after that.

 

* What I will do from now on is no longer restart my pc at a daily scheduled task so that should be helpfull for me bu still the question would be why is this after a pc restart?

 

- What I als notice and I wonder if this supposed to is that when the videobackdrop has stopped playing and I decide to not watch that serie or episode and I hit the back button the theme video starts playing again. This is also the case whren selecting a different episode. In my opinion the videobackdrop should just play once. How should this be by design?

 

These are all the logs while testing things. Hope it clears things up.

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Videobackdrops%20issue%201.log

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Videobackdrops%20issue%202.log

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Videobackdrops%20issue%203.log

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Videobackdrops%20issue%204.log

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Videobackdrops%20issue%205.log

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Videobackdrops%20issue%206.log

 

https://dl.dropboxusercontent.com/u/901529/Media%20Browser/MB3/Videobackdrops%20issue%207.log

Link to comment
Share on other sites

  • Solution

Looks like either a drive or network initialization delay to me.

 

Basically, it is taking WMC a few seconds to start up the playback of the theme video and you start the episode before it has even gotten going.

 

Now, where your problem is coming in is because you use an external for the episode but the theme is playing in the internal player.  We do stop all other playing content before playing something else but, this content hasn't even started playing yet so it cannot be stopped.

 

I'm not really sure what either the theme or MBC can do about this particular situation...

  • Like 1
Link to comment
Share on other sites

Looks like either a drive or network initialization delay to me.

 

Basically, it is taking WMC a few seconds to start up the playback of the theme video and you start the episode before it has even gotten going.

 

Now, where your problem is coming in is because you use an external for the episode but the theme is playing in the internal player.  We do stop all other playing content before playing something else but, this content hasn't even started playing yet so it cannot be stopped.

 

I'm not really sure what either the theme or MBC can do about this particular situation...

Sound logic. Like I said, I'm not going to restart my pc anymore unless it has to. That solves it for me.

 

What about the videobackdrop starts playing over and over once it has finisht playing the first time when selecting an episode etc?

Link to comment
Share on other sites

What about the videobackdrop starts playing over and over once it has finisht playing the first time when selecting an episode etc?

 

I'm guessing here but have you turned on repeat in the WMC player when playing some music?

Link to comment
Share on other sites

I'm guessing here but have you turned on repeat in the WMC player when playing some music?

No I haven't. It's not repeating but when I select an episode to view the overview and in the meantime the videobackdrop has ended and I go back to the episode page the video backdrop starts again. Same for when I select another episode to watch the overview.

Link to comment
Share on other sites

Okay, well that logic is in the theme but it sounds like it is doing what is intended.  Each time you enter the item, it plays the backdrop...

Okay, perhaps a request for only play the video backdrop once per serie is an option then for ROC. Will ask lee if this is possible.
Link to comment
Share on other sites

leedavies

Okay, well that logic is in the theme but it sounds like it is doing what is intended.  Each time you enter the item, it plays the backdrop...

 

Agreed, kinda.  :-)

 

When you browse into a folder/item that suddenly means video backdrops or theme music are found and should start to play, so long as there isn't already a real item from your media collection(s) playing (e.g. you don't have a TV show or music video etc playing in the background whilst you browse), the Crystal/ROC will start to play the first video backdrop/theme music file it found.

 

Say you just browsed into a TV show folder and the above happened and the TV show theme music is now playing in the background.  If you browse into a season, the video backdrops/theme music files are inherited from the TV show folder and because the file that Crystal/ROC wants to play is already playing, nothing should happen, so the theme music/video backdrop doesn't stop/restart each time you browse into or out of a season or episode etc.

 

As soon as you browse a level high enough so those video backdrops or theme music files are no longer relevant, their playback is stopped.  But, as above, if you've already got something other than video backdrops or theme music playing, it should be left well alone by Crystal and ROC.

 

Are you NOT seeing this behaviour whilst browsing around a single TV show or movie boxset hierarchy?

Link to comment
Share on other sites

Agreed, kinda.  :-)

 

When you browse into a folder/item that suddenly means video backdrops or theme music are found and should start to play, so long as there isn't already a real item from your media collection(s) playing (e.g. you don't have a TV show or music video etc playing in the background whilst you browse), the Crystal/ROC will start to play the first video backdrop/theme music file it found.

 

Say you just browsed into a TV show folder and the above happened and the TV show theme music is now playing in the background.  If you browse into a season, the video backdrops/theme music files are inherited from the TV show folder and because the file that Crystal/ROC wants to play is already playing, nothing should happen, so the theme music/video backdrop doesn't stop/restart each time you browse into or out of a season or episode etc.

 

As soon as you browse a level high enough so those video backdrops or theme music files are no longer relevant, their playback is stopped.  But, as above, if you've already got something other than video backdrops or theme music playing, it should be left well alone by Crystal and ROC.

 

Are you NOT seeing this behaviour whilst browsing around a single TV show or movie boxset hierarchy?

Tv shows with one episode don't have this. For boxsets I don't know yet since I have no trailers or video backdrops for them yet.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...