Jump to content
griffen247

'Force close player on stop button' not working with MPC-HC as external player

Recommended Posts

griffen247

'Force close player on stop button' is not working with MPC-HC as external player.  When I press the stop button, playback does into 'stop' and stays in that state.

 

Yes, I'm aware it works with VLC, so please don't post a reply saying this. VLC is causing other issues so I am not using it.

 

I'm using MPC-HC version 1.7.7 which is the current stable build.

 

 

Share this post


Link to post
Share on other sites
foghat

It doesn't work for jriver either.  I have programmed a mce 'close' command to fire (in addition to stop) when I press the stop button on my remote.

Share this post


Link to post
Share on other sites
bret1958

I fought with the same issue.. Didn't get any help from the forums.. I am trying to remeber what I did.. I will post as soon as I remember.. I am looking at my settings..

I thought I had reset a key in the setting but don't see it now.. I need to remember for myself.. Good News is that is is solvable..

 

OK Found it.... in the keys section edit exit.. add MEDIA_STOP from the drop down menu just tried it on a win_10 install ...works..

Edited by bret1958

Share this post


Link to post
Share on other sites
bret1958

in the keys section edit exit.. add MEDIA_STOP from the drop down menu

Share this post


Link to post
Share on other sites
griffen247

I had already tried that before posting..... didn't work.  Thanks for the suggestion tho

Share this post


Link to post
Share on other sites
griffen247

Fixed.....

 

By default madVR is a listed DirectShow Video filter but is **unavailble** and can't be seletcted.  So, I simply took a copy of the madVR folder from 'COMObjects' within MBT and placed it inside the MPC-HC folder, which now gave me access to load madVR as an External Filter.  After a few setting tweaks I'm now using MPC-HC with the madVR filter, and MBT is running perfectly.  The subtitles aren't working but that is a minor fix to address later

Share this post


Link to post
Share on other sites
griffen247

The latest update of Theatre has broken the exit from MPC-HC back to dashboard after playback function. 'Only Official Release' was previous setting, so not sure why fault  has occurred

 

Until final release builds be available for each app, could we get an option to lock any changes being made for users with stable systems.

 

Re-launching after updates is like playing Russian Roulette when you don't have the option.

 

Is anyone else having the same issue now?

Edited by griffen247

Share this post


Link to post
Share on other sites
foghat

 

Didt you set the auto update to 'Offical Release' builds only?

Edited by foghat

Share this post


Link to post
Share on other sites
griffen247

It was set to 'Offical Release' builds only.

Edited by griffen247

Share this post


Link to post
Share on other sites
foghat

 

edit to remove contention.

Edited by foghat

Share this post


Link to post
Share on other sites
griffen247

edit to remove contention

Edited by griffen247

Share this post


Link to post
Share on other sites
foghat

There is a way back.

 

Checkout: C:\Users\<user>\AppData\Roaming\MediaBrowser-Theater\System.old

 

Rename System.old to System.  I believe that will give you the previous version.  Of course you will get hooped again with the next update - unless that update does has fixed the issue.

 

If I were you, I'd make a copy of the system.old folder and name it something else - so you always have your working version.  Then also reaplace the current system folder (maybe make a copy of that as well - just in case) with the system.old.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...