Jump to content

Option to disable automatic server discovery


ng4ever
 Share

Recommended Posts

Happy2Play

Isn't the only option blocking UDP port 7359 on the server firewall as mentioned in your other topic?

Or are you wanting a Network config in Emby to disable "Network Broadcast Discovery"?

Link to comment
Share on other sites

1 minute ago, Happy2Play said:

Isn't the only option blocking UDP port 7359 on the server firewall as mentioned in your other topic?

Or are you wanting a Network config in Emby to disable "Network Broadcast Discovery"?

I think I am wanting a Network config in Emby to disable "Network Broadcast Discovery" please

 

 

Link to comment
Share on other sites

@Happy2Play

 

I want to hide the server from this page.

 

702225144_wanttohidesecondserverfromthispageplease.thumb.jpg.2ef3a07b33a6d0b10fd42420cdb11608.jpg

 

 

P.S. yes there is not a second server right now but that because I turned it off/uninstalled the second server for now.

Link to comment
Share on other sites

Happy2Play

Pretty sure is the only way is blocking the UDP port right now as it should already exist in your firewall rules.

Example from Windows

image.png.839e667ae560e899d746d41fc52681fa.png

Link to comment
Share on other sites

Just now, Happy2Play said:

Pretty sure is the only way is blocking the UDP port right now as it should already exist in your firewall rules.

Example from Windows

image.png.839e667ae560e899d746d41fc52681fa.png

 

Thanks but will it disable or prevent my family Emby server stop working all together or with anything ?

 

 

Link to comment
Share on other sites

Happy2Play
1 minute ago, ng4ever said:

 

Thanks but will it disable or prevent my family Emby server stop working all together or with anything ?

 

 

It just prevents clients from automatically discovering the server on your network.  So if the client does not know about the server you have to make a manual connection ie add server.

Link to comment
Share on other sites

Happy2Play

Note this does not remove the server from devices that already know the server.  Just testws this on my iPhone as I have test servers on different machines.

Had to manual remove the already discovered server and it was not rediscovered on the machine I disabled the rule on.  Reenabling the port allowed the client to discover the server again.

Edited by Happy2Play
Link to comment
Share on other sites

2 minutes ago, Happy2Play said:

Note this does not remove the server from devices that already know the server.  Just testws this on my iPhone as I have test servers on different machines.

Had to manual remove the already discovered server and it was not rediscovered on the machine I disabled the rule on.  Reenabling the port allowed the client to discover the server again.

 

Ok thanks.

This should work well then.

Link to comment
Share on other sites

@Happy2Play  does not seem to work on the Roku or Amazon Fire Stick :(

 

I keep seeing the second server. Please help if possible. I have UDP port 7359 blocked too.

 

What could I be doing wrong if anything?

 

It worked on my iPhone though.

Link to comment
Share on other sites

Happy2Play

Can't test on my Roku right now.  Should be able to test in a bit.  But if it worked on one client, I would expect it to work on all.

Link to comment
Share on other sites

1 minute ago, Happy2Play said:

Can't test on my Roku right now.  Should be able to test in a bit.  But if it worked on one client, I would expect it to work on all.

 

Your right. I think I got it to work now! Thanks.

 

Please test on Roku when you can get a chance just to double check! Thank you again!

Link to comment
Share on other sites

Happy2Play

Tested this on ET and had not issues, just had to delete the already known server.  Will follow up when I test my Roku.

Link to comment
Share on other sites

1 minute ago, Happy2Play said:

Tested this on ET and had not issues, just had to delete the already known server.  Will follow up when I test my Roku.

So it shows up initially ? The second server?

I hope not.

 

 

 

 

Link to comment
Share on other sites

I only can connect to the server locally as well not remotely :(

 

Oh well. I do not think this will work.

Link to comment
Share on other sites

Happy2Play
6 minutes ago, ng4ever said:

So it shows up initially ? The second server?

I hope not.

Yes as clients cache this information.  Think the only way around that would be changing your serverid.

Link to comment
Share on other sites

Just now, Happy2Play said:

Yes as clients cache this information.  Think the only way around that would be changing your serverid.

 

How do you do that please ?

Link to comment
Share on other sites

Happy2Play
1 minute ago, ng4ever said:

I only can connect to the server locally as well not remotely :(

 

Oh well. I do not think this will work.

Will test but this has nothing to do with remote connections as those connections will be port 8096/8920.

Link to comment
Share on other sites

Just now, Happy2Play said:

Will test but this has nothing to do with remote connections as those connections will be port 8096/8920.

 

Ok well I just tested my second server and it always wants to connect to the family NAS not mine.

I did change the ports once to 8097 and 8921 but it would never work. Emby on iPad would always complain about updating Emby version :(

Link to comment
Share on other sites

Happy2Play
3 minutes ago, ng4ever said:

 

How do you do that please ?

You mean change serverid?  You shut down Emby and delete the device.txt in the /data folder.  Starting Emby will generate a new serverid.

But do not know for sure if old servers have to be manually removed.  As there are topics on deleted servers still appearing on clients.

Link to comment
Share on other sites

Happy2Play
10 minutes ago, ng4ever said:

I only can connect to the server locally as well not remotely :(

 

Oh well. I do not think this will work.

Had no issue adding and connecting to my server with 7359 disabled or blocked.

Link to comment
Share on other sites

3 minutes ago, Happy2Play said:

Had no issue adding and connecting to my server with 7359 disabled or blocked.

I must be doing something wrong. Do I change both the local and remote port? 

Link to comment
Share on other sites

Happy2Play
1 minute ago, ng4ever said:

I must be doing something wrong. Do I change both the local and remote port? 

Don't follow as you don't change anything here related to Remote connection.

Just tested my Roku and had to manually delete multiple servers as all my test system whether on or off appeared.  With firewall ruled disable/blocked the client no longer auto discovered the server.  Going to Add server and entering its info allowed connection and saved cached the server.

Link to comment
Share on other sites

Happy2Play

Only guess on failed connection is maybe device cached info.  If you remove the server are you able to readd it and connect?

Link to comment
Share on other sites

Just now, Happy2Play said:

Don't follow as you don't change anything here related to Remote connection.

Just tested my Roku and had to manually delete multiple servers as all my test system whether on or off appeared.  With firewall ruled disable/blocked the client no longer auto discovered the server.  Going to Add server and entering its info allowed connection and saved cached the server.

 

I have a new issue where I can't connect to my second server remotely sorry. It refuses to connect. :(

 

Thanks for the second part.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...