Jump to content

External ass subtitles are not propagated to kodi


dianlujitao
 Share

Go to solution Solved by quickmic,

Recommended Posts

dianlujitao

I have a .mkv video with embedded subtitles, and external .ass subtitles in other languages within the same directory, e.g.,

- Sword Art Online the Movie -Progressive- Aria of a Starless Night (2021) Bluray-1080p.mkv

- Sword Art Online the Movie -Progressive- Aria of a Starless Night (2021) Bluray-1080p.Chinese.ass

The problem is when streaming with emby, Kodi shows embedded subtitles only, i.e. the .ass is not detected at all. But when directly playing the .mkv file with Kodi via windows explorer, both of the embedded and external subtitles are detected and loaded properly. Emby web player detects both of them as well.

 

Kodi version: 19.4 UWP

Emby server: 4.7.5.0

Emby-next-gen: 6.2.15, plugin mode

 

emby.log is kodi debug log when streaming with emby, direct.log is the one when directly playing via windows explorer

 

Edited by quickmic
  • Like 1
Link to comment
Share on other sites

  • Solution
quickmic
Posted (edited)
10 hours ago, dianlujitao said:

I have a .mkv video with embedded subtitles, and external .ass subtitles in other languages within the same directory, e.g.,

- Sword Art Online the Movie -Progressive- Aria of a Starless Night (2021) Bluray-1080p.mkv

- Sword Art Online the Movie -Progressive- Aria of a Starless Night (2021) Bluray-1080p.Chinese.ass

The problem is when streaming with emby, Kodi shows embedded subtitles only, i.e. the .ass is not detected at all. But when directly playing the .mkv file with Kodi via windows explorer, both of the embedded and external subtitles are detected and loaded properly. Emby web player detects both of them as well.

 

Kodi version: 19.4 UWP

Emby server: 4.7.5.0

Emby-next-gen: 6.2.15, plugin mode

 

emby.log is kodi debug log when streaming with emby, direct.log is the one when directly playing via windows explorer

Yes, correct. This feature is only available in 7.x versions.

fyi, I removed the (debug) logs. They include api-keys, regular log are save to upload in public.

Edited by quickmic
Link to comment
Share on other sites

dianlujitao
26 minutes ago, quickmic said:

Yes, correct. This feature is only available in 7.x versions.

fyi, I removed the (debug) logs. They include api-keys, regular log are save to upload in public.

Thanks for the clarification.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...