Jump to content

High Bitrate 4k playback switching to transcode after 2.5 minutes.


nomatches4mikey
 Share

Go to solution Solved by nomatches4mikey,

Recommended Posts

nomatches4mikey

I'm trying to play UHD video at its native bitrate without re-encoding.  It plays fine for about 2.5 minutes, but then the Direct Play stream is interrupted.  The server then tries to switch to transcoding, but doesn't have the hardware to convert these files, so the playback is poor. The drive read and network speed is sufficient to support the bitrate, but I'm not sure why the stream is being interrupted.  Thanks for looking at this!


Server: Windows 10 Pro with latest updates, Emby Server 4.6.7.0
Client: Emby for Android on nVidia Shield
All times are EDT.
Log sent from Sheild at 5/10 12:58PM Eastern. 

12:27PM Reboot nVidia Shield

12:28PM Enable Debug Logging and rotate log file
12:29PM Login "Adults" user
12:29PM Verify Enable debug options set on nVidia Shield
12:30PM Start Playing Godzilla and turn on Stats for Nerds
        Direct Play, HTTP, Bitrate 74.93 Mbps
12:32PM Network activity monitor shows streaming activity stopped
        Video playback continues for a bit before transcoding starts
12:33PM Transcoding playback, Direct Stream, HLS
    Playback starts and stops due to transcoding speed.
12:35PM Stop playback.

12:37PM Start Playing Finding Nemo
        Direct Play, HTTP, Bitrate 60.32 Mbps
    Network Activity monitor reflects 60Mbps network utilization
12:39PM Network activity monitor shows streaming activity stopped (Playback at 2:40)
        Video playback continues, stutters at timecode 3:30 to switch to transcoding
12:40PM Transcoding playback, Direct Stream, HLS
    Playback starts and stops due to transcoding speed, sometimes displays weird pixelated colors on screen.
12:43PM Stop playback.

12:44PM Start Playing Tomb Raider
        Direct Play, HTTP, Bitrate 20.66 Mbps
    Network Activity monitor reflects 18 to 25 Mbps network utilization
    No network dips, no playback interruptions.  
12:54PM Stopped playback. Video stuttered, then Shield stopped responding.
    Screen displays blue screen, the same as if the Shield were off or sleeping.
12:57PM Hard restart of Shield by disconnecting power.
12:58PM Logged into "Adults" user and sent developer log.

Searching through the forum, I saw a suggestion to change the Max bitrate on the device from AUTO to 1000Mbps.
I tried this, and still observed the network dropoff.  When playback was stopped, the Shield blue screened again.
The blue screen is new, it may be due to turning on logging mode or could be due to resolution matching switching.

embyserver-63787784375.txt

Link to comment
Share on other sites

3 minutes ago, nomatches4mikey said:

12:57PM Hard restart of Shield by disconnecting power.
12:58PM Logged into "Adults" user and sent developer log.

Hi.  This process cleared out the log so we didn't really get anything useful.  My guess is that the device is running out of memory but if you could just play one item until it does the switch and then immediately send the log (right from the cog menu during playback) we can confirm.

Link to comment
Share on other sites

nomatches4mikey

I was afraid that may have happened.  I ran the test again as you asked and sent the logs at 2:13PM. Attached new corresponding server log.

embyserver (2).txt

Link to comment
Share on other sites

  • Solution
nomatches4mikey

I read your guess about the device running out of memory.  I checked the playback settings, and the Player Buffer Size was set to Large.  On a hunch, I changed it to Small.  Once playback started, I noticed that the disk read and network utilization switched from a low steady stream to a series of bursts.  More importantly, playback continued flawlessly through all the points it had failed before.  Even the Stop function returned to the movie menu page.  I'm not sure what the settings are for Small/Medium/Large buffer size, but if it's based on the file size or bitrate, it may have been too large for the device to handle?

I sent the log from the device at 2:50PM Eastern.

Link to comment
Share on other sites

Great. That was what I was going to suggest you try. Well done. 

  • Like 1
Link to comment
Share on other sites

nomatches4mikey

I tested it with Medium and it played for at least 20 minutes, so I think that setting also works ok.

Link to comment
Share on other sites

We're just going to remove that option since it shouldn't be needed anymore.  Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...