Jump to content

Cannot play Live camera feed from security CAM


HSEmbyBox
 Share

Recommended Posts

HSEmbyBox

Upgraded to new version. Still cannot play live RTSP stream:

image.png.5dbf063ce34a94666c8b5c17f8ff0d25.png

Link to comment
Share on other sites

I'm afraid, there's nothing that Emby can do about this, this is something outside the reach of Emby.

Let's summarize the situation:

  • You have on computer (A) on which you can receive packets from the camera with ffmpeg
  • You have another computer (B) (on which you run Emby) where you cannot receive packets from the camera with ffmpeg (using the same command and the same ffmpeg).,
  • You say you can receive the stream with VLC - but only from computer A

It must be something about network communication, firewall, nat (if involved), port forwarding (if involved) or similar.

Unless you can't receive the stream on computer B at all, there's nothing that Emby can do.

Link to comment
Share on other sites

HSEmbyBox

I am gonna test one more thing. I am going to install Emby (non - premium version) on computer A where VLC works, and see how it goes.

Link to comment
Share on other sites

Happy2Play

@Abobaderwould that be you or another admin to update Website footer?

  • Like 1
Link to comment
Share on other sites

Well, simple code can add year auto without the need to edit manually.

  • Like 1
Link to comment
Share on other sites

HSEmbyBox
5 hours ago, bigjohn said:

@Happy2Play @Abobader That's something I am not directly involved in but I believe anyone can contribute:
https://github.com/MediaBrowser/website

Looks like there was a pull request from last year for the same thing that never got merged.

Is this the Emby website or the actual software web interface code?

Link to comment
Share on other sites

Happy2Play
1 minute ago, HSEmbyBox said:

Is this the Emby website or the actual software web interface code?

It is just the website.  No server or web client code is public.

 

  • Like 1
Link to comment
Share on other sites

HSEmbyBox

Getting back to topic, just upgraded to 4.7.0.40 Beta.
Still no joy.

Link to comment
Share on other sites

HSEmbyBox

Keep in mind that firewall is switched off on Emby box (bare-metal).

Link to comment
Share on other sites

On 5/15/2022 at 11:09 PM, softworkz said:

I'm afraid, there's nothing that Emby can do about this, this is something outside the reach of Emby.

Let's summarize the situation:

  • You have on computer (A) on which you can receive packets from the camera with ffmpeg
  • You have another computer (B) (on which you run Emby) where you cannot receive packets from the camera with ffmpeg (using the same command and the same ffmpeg).,
  • You say you can receive the stream with VLC - but only from computer A

It must be something about network communication, firewall, nat (if involved), port forwarding (if involved) or similar.

Unless you can't receive the stream on computer B at all, there's nothing that Emby can do.

Link to comment
Share on other sites

On 5/16/2022 at 2:14 AM, HSEmbyBox said:

I am gonna test one more thing. I am going to install Emby (non - premium version) on computer A where VLC works, and see how it goes.

How did that go, actually?

Link to comment
Share on other sites

HSEmbyBox
5 minutes ago, softworkz said:

How did that go, actually?

I have yet to find free time to give this a go. I am probably gonna test it around weekend.

  • Thanks 1
Link to comment
Share on other sites

HSEmbyBox

TV is only available in Emby Premiere. Is it possible to move the license key temporarily to test Windows box and then pull it back to original hardware?

Link to comment
Share on other sites

  • 2 months later...
HSEmbyBox

image.png.8e5650eb44c0b2cd9b0213a680cefdae.png

* Emby box has firewall totally disabled. Computer is restarted i.e. power cycled.
* Using Emby 4.8.0.7 Beta
* OS is fully updated as of this writing 
* ffmpeg version 4.2.7-0ubuntu0.1
* VLC works OK with the RTSP URL, on Emby box and from any other devices on the LAN. As of now I have connected a monitor with Emby box for troubleshooting. 
* Tried Emby on Windows 10 Pro, (separate bare-metal) using same camera, but no joy so far

Any further suggestions?

 

 

 

Link to comment
Share on other sites

HSEmbyBox

Also, is this normal?

Quote

$ /opt/emby-server/bin/ffmpeg       
/opt/emby-server/bin/ffmpeg: error while loading shared libraries: libavdevice.so.59: cannot open shared object file: No such f
ile or directory

 

Link to comment
Share on other sites

7 minutes ago, HSEmbyBox said:

Also, is this normal?

 

If you're trying to use our ffmpeg build from the command line, yes that is normal. there is a way though, it's just not as simple as that.

Link to comment
Share on other sites

HSEmbyBox
On 5/15/2022 at 10:09 PM, softworkz said:

I'm afraid, there's nothing that Emby can do about this, this is something outside the reach of Emby.

Let's summarize the situation:

  • You have on computer (A) on which you can receive packets from the camera with ffmpeg
  • You have another computer (B) (on which you run Emby) where you cannot receive packets from the camera with ffmpeg (using the same command and the same ffmpeg).,
  • You say you can receive the stream with VLC - but only from computer A

It must be something about network communication, firewall, nat (if involved), port forwarding (if involved) or similar.

Unless you can't receive the stream on computer B at all, there's nothing that Emby can do.

Computer "B", where Emby is installed, also has VLC working without any issue with that rtsp URL.
Firewall is disabled on Computer "B"

Link to comment
Share on other sites

1 hour ago, HSEmbyBox said:

Also, is this normal?

Quote

$ /opt/emby-server/bin/ffmpeg       
/opt/emby-server/bin/ffmpeg: error while loading shared libraries: libavdevice.so.59: cannot open shared object file: No such f
ile or directory

Run /opt/emby-server/bin/ffmpeg-emby instead.

Link to comment
Share on other sites

Can you please provide a new log file example from the latest version of the server? Thanks.

Link to comment
Share on other sites

9 hours ago, HSEmbyBox said:

Any further suggestions?

 

19 hours ago, softworkz said:

Run /opt/emby-server/bin/ffmpeg-emby instead.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...