Jump to content

Album display bug, with punctuation in the album name


Shpongle
 Share

Recommended Posts

Shpongle

Hi

I noticed the album "( )" by "Sigur Rós" doesn't display properly for me. I see the following, on multiple client apps:

51709043_albumbug.thumb.jpg.d0485bfebf38e8e2467a841e00bec3a3.jpg'

It also appears like this on the artist page where their albums are listed. The album appears duplicated with one song in each.

The 8 songs on the album all have the same artist and album metadata. In other music players the songs are grouped correctly.

It only happens if the album name is set to "( )" (i.e. open parenthesis, space, close parenthesis), and it doesn't matter what the folder name is. I also have an album that starts with an open parenthesis but contains letters too, and that behaves properly. If I change this album name to "( )a" it works properly. So I assume it's a bug with grouping songs by albums with strange non-alphabet characters only. I think you should be able to replicate it by setting any album to have this name and scanning the library files.

I am running the server (version 4.6.7.0) on a raspberry pi in docker, and I have seen this symptom on the web browser, samsung TV and android app. I assume it's a server bug.

My library has the folder structure setting: "Perfectly organised into artist\album folders, with tracks directly in the album folders." I have metadata downloading turned off for this library as it's all embedded in the music files already.

Thanks

Edited by Shpongle
Added some more information to initial post
Link to comment
Share on other sites

Hello Shpongle,

** This is an auto reply **

Please wait for someone from staff support or our members to reply to you.

It's recommended to provide more info, as it explain in this thread:

Thank you.

Emby Team

Link to comment
Share on other sites

HI, this is an issue specific to the album title () and is resolved for the next release. Thanks.

Link to comment
Share on other sites

Happy2Play

Yes there are a few topic on this specific album

 

Link to comment
Share on other sites

Shpongle

Hah. I searched the forum for "album punctuation" but never considered looking for the specific album or artist name.

Maybe they called it that because they knew people might talk about it on music software forums and it would generate some free publicity.

Thanks for the quick responses.

Link to comment
Share on other sites

Bigmack3000

Ha, I saw this linked to when I was having the problem.  Just a heads up, that it still doesn't work for me.  

Link to comment
Share on other sites

Happy2Play
43 minutes ago, Bigmack3000 said:

Ha, I saw this linked to when I was having the problem.  Just a heads up, that it still doesn't work for me.  

Will test some more but what tags do you have?

image.thumb.png.206374163885c5bc450b229ea2cdd968.png

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...