Jump to content

Custom Local network defenition seems to be broken


TheFujin
 Share

Recommended Posts

TheFujin

Hi, I have configured my local network as `192.168.1.0/24` in the network settings in Emby. Then I have configure some of my users with the option "Do not require an password on the local network". This seems to be working and I can now login without an password.

The problem starts when I try to contact the server from an different network (172.16.1.0/24). When I click on my user it signs in without an password. I would expect it to ask for my password because this isn't defined as an local network. In the dashboard the successful login is reported with the ip address 172.16.1.30, which is expected.

I am directly connecting to the Emby server (no proxy), tcpdump also shows incoming network packets from the source ip 172.16.1.30 as expected.

Tested versions: 4.7.0.18 beta and 4.6.7.0 stable

System: Linux Debian 10 (4.19.0-18-amd64)

Edited by TheFujin
Link to comment
Share on other sites

Hi, yes we either need to adjust the help text or rework the option, but as 172.16.X falls under rfc1918 there is currently no way to prevent it from being treated as on the local network.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...