Jump to content

Quest to get Direct Play in Edge Browser..


rbjtech
 Share

Recommended Posts

rbjtech

So in my quest to get Direct Playback of 4K HEVC Content in my browser, I have identified that I need to have AC3 (or I assume AAC) as the first Audio track - ie track 2.

Even if I set the 'Default' Audio track to the AC3 track (other that track 2) it immediately starts transcoding.

Is this a 'browser' limitation (ie it cannot switch Audio Tracks) or is it an Emby web client limitation ?

Other clients all seem to be fine - and will play the 'Default' Audio track regardless of it's real track position.

I tried messing with the headers but that did not seem to work - I'd rather not have to remux my 4K collection to put the AC3 track 'first'... :(

Has anybody else seen this issue or have any workarounds ?

Thanks!

Link to comment
Share on other sites

rbjtech
2 minutes ago, GrimReaper said:

Marmaduke's Chromium...? 

Possibly - but ideally wanna stay on the standard Edge release branch.

I was hoping for a extension setting or something like that .. 🤓 

Link to comment
Share on other sites

GrimReaper
18 minutes ago, rbjtech said:

Possibly - but ideally wanna stay on the standard Edge release branch.

I was hoping for a extension setting or something like that .. 🤓 

Sure thing, was just throwing a suggestion as per query. I myself have fairly recently switched to MC portable as Emby-client only - have yet to find something that ain't direct playing. 

Edit: Guess you just found me some, went to check few 4K HEVCes with both AAC and AC3 - it's failing on latter. So no joy there. Though my build is several months old 32-bit, maybe there was some progress on current 64-bit version. As maybe there wasn't. 🤷‍♂️

Edited by GrimReaper
Append
Link to comment
Share on other sites

rbjtech

Resorted to a quick script .. I'm using mkvmerge with --track-order to (funnily enough..) re-order/re-mux the tracks.    Unfortunately, you can't just use mkvpropedit/header edit - as that doesn't appear to work for the browser .. it can't handle the default Audio track being track 3 for example.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...