Jump to content

Some users are not able to remote into the server.


Osorus
 Share

Go to solution Solved by Osorus,

Recommended Posts

Hello! Hope everyone is doing well today. I am getting reports from a few users stating they are not able to remote into the server via console, smart tvs, and phones. I have confirmed that when wifi is off on my phone, I have no issue. I confirmed with my own TV and console that I have remote access to the server. I see other users on and watching movies, so it appears to be an odd situation. Wondering if anyone mind taking a peek at the debug ran. This debug was run during one of my users attempting access via phone and via Samsung smart TV. My TV is also Samsung, and sadly I am not able to duplicate the reported issue. Thanks in advance!!!

embyserver.txt

Edited by Osorus
Link to comment
Share on other sites

Happy2Play
14 minutes ago, Osorus said:

Hello! Hope everyone is doing well today. I am getting reports from a few users stating they are not able to remote into the server via console, smart tvs, and phones. I have confirmed that when wifi is off on my phone, I have no issue. I confirmed with my own TV and console that I have remote access to the server. I see other users on and watching movies, so it appears to be an odd situation. Wondering if anyone mind taking a peek at the debug ran. This debug was run during one of my users attempting access via phone and via Samsung smart TV. My TV is also Samsung, and sadly I am not able to duplicate the reported issue. Thanks in advance!!!

embyserver.txt 7.78 MB · 1 download

How are they connecting?

Do you have any device access restrictions applied to user accounts?

 

But I don't see any remote access issues as I can see your login page from info in you log. 

Link to comment
Share on other sites

JasonNalley

It's the same for me... all connect via Emby Connect...  Also, my WAN IP changed over to an IPV6 address and I suspect this is the problem... @Osorus does your WAN show an IPV4 or IPV6 address?

Link to comment
Share on other sites

44 minutes ago, JasonNalley said:

It's the same for me... all connect via Emby Connect...  Also, my WAN IP changed over to an IPV6 address and I suspect this is the problem... @Osorus does your WAN show an IPV4 or IPV6 address?

Correct. I noticed today that it switched to ipV6. Prior, it was a public IP.

Link to comment
Share on other sites

49 minutes ago, Happy2Play said:

How are they connecting?

Do you have any device access restrictions applied to user accounts?

 

But I don't see any remote access issues as I can see your login page from info in you log. 

Not sure what you mean by "how are they connecting?". They log in, and select my server. After what I imagine are several attempts to reach my server, it times out with a Connection Failure error.

 

No, I do not have any device access restrrictions.

Link to comment
Share on other sites

Happy2Play
3 minutes ago, Osorus said:

Correct. I noticed today that it switched to ipV6. Prior, it was a public IP.

Hmm It would appear everyone that is still connecting is using your IPv4 address.

I am guessing existing user are still seeing IPv4 and other users no longer see that address.

Are you saying the Dashboard is showing a IPv6 WAN address?  As I can connected with your IPv4 address.

Does a site like canyouseeme.org show a IPv4 address?

Link to comment
Share on other sites

2 minutes ago, JasonNalley said:

@Happy2Play that's 2 of us same situation, today Emby decided to use IPV6 and users are getting connection failures (from @Osorus description it sounds like he also has his users connecting via Emby Connect)

Ah, Gotcha. Honestly, I thought the only way remote users could access the server is through Emby Connect. And yeah, ipv6 happened today, I assume. Everyone was watching Shang Chi last night with no issues.

Link to comment
Share on other sites

Happy2Play
3 minutes ago, JasonNalley said:

@Happy2Play that's 2 of us same situation, today Emby decided to use IPV6 and users are getting connection failures (from @Osorus description it sounds like he also has his users connecting via Emby Connect)

Emby uses what ever your system provides.  But I don't really know as I am not on IPv6 but others have reported no issue but don't know if they are Connect users.

Link to comment
Share on other sites

JasonNalley
1 minute ago, Happy2Play said:

Hmm It would appear everyone that is still connecting is using your IPv4 address.

I am guessing existing user are still seeing IPv4 and other users no longer see that address.

Are you saying the Dashboard is showing a IPv6 WAN address?  As I can connected with your IPv4 address.

Does a site like canyouseeme.org show a IPv4 address?

Yes, the Dashboard is showing IPv6 WAN Address instead of the normal IPV4 address that is there.

canyouseeme.org shows IPV4 address

My users all utilize Emby Connect to connect to my server, when they see the server and select it it says that it cannot connect to that server right now... 

Link to comment
Share on other sites

19 minutes ago, Happy2Play said:

Hmm It would appear everyone that is still connecting is using your IPv4 address.

I am guessing existing user are still seeing IPv4 and other users no longer see that address.

Are you saying the Dashboard is showing a IPv6 WAN address?  As I can connected with your IPv4 address.

Does a site like canyouseeme.org show a IPv4 address?

I use ipchicken, but I understand your ask. ipchicken is showing a public IP. whois is showing my ipV6.

Edited by Osorus
Link to comment
Share on other sites

Happy2Play
4 minutes ago, Osorus said:

Ah, Gotcha. Honestly, I thought the only way remote users could access the server is through Emby Connect. And yeah, ipv6 happened today, I assume. Everyone was watching Shang Chi last night with no issues.

Connect is optional and not required as you can connect via IP or domain if you have one.

But @Lukemay have to comment as both of you sort of have the same issue but @JasonNalleyhas mixed results from WAN address.

Link to comment
Share on other sites

Just now, Happy2Play said:

Connect is optional and not required as you can connect via IP or domain if you have one.

But @Lukemay have to comment as both of you sort of have the same issue but @JasonNalleyhas mixed results from WAN address.

True. Not a fan of giving out my IP. And a domain (to me) is not useful. So I tunnel visioned "emby connect" as the "only" option. Forgive me.

Link to comment
Share on other sites

JasonNalley

That's the same for me, I don't want to constantly give out my IP (not because it's unsafe, they can see it anyways when using the web app) but because my users are all blockheads that couldn't enter an IP address if it was needed to save their life, so emby connect is the easy way... 

Link to comment
Share on other sites

JasonNalley

@Happy2Play is there a sync time for Emby Connect connectivity?  If someone's dynamic IP changes, is there some sort of lead time before Emby Connect gets the new information and points users in the right direction?  

If not, could it possibly be that the redirect is either not redirecting to the IPV6 address, or that it *is* but that service is incapable of using IPV6?  Just trying to figure out what's causing it really... 

Link to comment
Share on other sites

1 minute ago, JasonNalley said:

That's the same for me, I don't want to constantly give out my IP (not because it's unsafe, they can see it anyways when using the web app) but because my users are all blockheads that couldn't enter an IP address if it was needed to save their life, so emby connect is the easy way... 

Hahaha. Mine are not technical enough to be interested in my IP. But just old school practice.  Kind of like my home address. Sure, it can be found on public access, but giving it out so freely...call it superstitious routines. lol

Link to comment
Share on other sites

  • Solution

Ok. Temp resolve. I set my router to ipV6 passthrough, thus forcing the router to take back ipV4 on the ISP side. Is there anyway we can revisit this from an ipV6 perspective? Seeing that this is our future?

Link to comment
Share on other sites

JasonNalley
1 minute ago, Osorus said:

Ok. Temp resolve. I set my router to ipV6 passthrough, thus forcing the router to take back ipV4 on the ISP side. Is there anyway we can revisit this from an ipV6 perspective? Seeing that this is our future?

Heh, wish my router had that... the google fiber box is so limiting in what you can do with it, and sadly I can't just use any old modem/router off the shelf with this service, the only other one I know that works is like $600... so I have my 3 Nighthawks all in Access point mode and let the Google fiber box handle the DHCP addressing... 

Link to comment
Share on other sites

13 minutes ago, JasonNalley said:

Heh, wish my router had that... the google fiber box is so limiting in what you can do with it, and sadly I can't just use any old modem/router off the shelf with this service, the only other one I know that works is like $600... so I have my 3 Nighthawks all in Access point mode and let the Google fiber box handle the DHCP addressing... 

Ya. I have a Linksys Velop. 10 years in telecom working Cisco ISR routers, I prefer something with as much freedom as a router can give me. Sadly consumer routers are very restrictive. This one seems to play nice when it comes to what control it allows me to have. 

Edited by Osorus
Link to comment
Share on other sites

hackthis02

I can confirm I'm in the same boat. IPV6 on the dashboard w/ some users not being able to connect via Emby Connect.
I have fixed the issue by using DuckDNS then under Network, setting my DuckDNS address as the External domain

Edited by hackthis02
Link to comment
Share on other sites

2 minutes ago, hackthis02 said:

I can confirm I'm in the same boat. IPV6 on the dashboard w/ some users not being able to connect via Emby Connect.

Are you able to set ipv6 as pass-through, or force WAN back to ipv4 at your router level?

Link to comment
Share on other sites

hackthis02
1 minute ago, Osorus said:

Are you able to set ipv6 as pass-through, or force WAN back to ipv4 at your router level?

I have fixed the issue by using DuckDNS then under Network, setting my DuckDNS address as the External domain

Link to comment
Share on other sites

14 minutes ago, hackthis02 said:

I have fixed the issue by using DuckDNS then under Network, setting my DuckDNS address as the External domain

Your external default domain must be ipv4, I assume? Either way, the issue stems from some users with routers that can only operate under ipv4. Until every user can traverse using ipv6, we might be at a cross road. This might be a problem, if my assumptions are correct.

Link to comment
Share on other sites

JasonNalley
2 minutes ago, Osorus said:

Your external default domain must be ipv4, I assume? Either way, the issue stems from some users with routers that can only operate under ipv4. Until every user can traverse using ipv6, we might be at a cross road. This might be a problem, if my assumptions are correct.

yep, that was what I was thinking...  loads of ISP's are behind the times with IPV6, it's a shame... 

  • Like 1
Link to comment
Share on other sites

JasonNalley
34 minutes ago, hackthis02 said:

I have fixed the issue by using DuckDNS then under Network, setting my DuckDNS address as the External domain

Thank you, that way worked for me as well :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...