Jump to content

xpenology - Unable to turn on hardware decoding


Sailence
 Share

Go to solution Solved by cayars,

Recommended Posts

GrimReaper

Since it appears that only @cayars read this thread completely, I'll summarize it here for any future input:

1) Initial log, AVC Hi10p playback, naturally no HW acceleration on either VAAPI or QS, decoding in software only

2) BDMV playback, HW decoders not listed at all, decoding in software only 

3) Plain AVC 8-bit playback, HW mode:Yes, VAAPI decoder, Processing Plan correct, errs on playback, log saturated with decoder errors 

4) Plain AVC 8-bit playback, HW mode: Advanced, QS decoder, Processing Plan correct, errs on playback, log saturated with decoder errors

Next step: awaiting Carlo to test actual media file, which OP shared together with hardware detection log. 

Link to comment
Share on other sites

Could you please try the following to change the VAAPI driver:

  • install the Diagnostics Plugin from the Catalog
  • Reboot
  • Make the settings as indicated below
  • Reboot
  • Retry with VAAPI

 

image.png.458f9714a05072be3fb973fc126bf37c.png

Edited by softworkz
Link to comment
Share on other sites

8 hours ago, GrimReaper said:

Next step: awaiting Carlo to test actual media file, which OP shared together with hardware detection log. 

Having a bit of trouble downloading the file. Downloading now at a steady 2Mb. :)
Waiting to see how the changes softworkz mentioned work out as well.

  • Like 1
Link to comment
Share on other sites

Sailence
16 minutes ago, softworkz said:

It wasn't always same file - was it?

@Sailence - Have you had any videos with which VAAPI is working?

 

2 hours ago, softworkz said:

Could you please try the following to change the VAAPI driver:

  • install the Diagnostics Plugin from the Catalog
  • Reboot
  • Make the settings as indicated below
  • Reboot
  • Retry with VAAPI

 

image.png.458f9714a05072be3fb973fc126bf37c.png

I try that,it can't play also.

Playback Error

No compatible streams are currently available. Please try again later or contact your system administrator for details.

ffmpeg-transcode-8c953f23-ad30-42ea-aaaa-157cd6ea7340_1.txt

Link to comment
Share on other sites

Sailence
32 minutes ago, softworkz said:

It wasn't always same file - was it?

@Sailence - Have you had any videos with which VAAPI is working?

I tried to play other files in my video library, and the hardware decoding never work,include H264,H265,HEVC,8bit,4K,1080P,720P.

Link to comment
Share on other sites

OK thanks, this looks good.

In your recent ffmpeg log - did you have hw acceleration disabled?
Please go to "Transcoding" and change to "Yes"
(not Advanced, you can change back to Advanced later)

Link to comment
Share on other sites

Sailence
2 小时前,softworkz 说:

好的,谢谢,这看起来不错。

在您最近的 ffmpeg 日志中 - 您是否禁用了硬件加速?
请转到“转码”并更改为“是”
(不是高级,以后可以改回高级)

I try i965+advanced and i965+yes,it can't play also.

ffmpeg-transcode-25ace6dc-1070-439d-87b8-c47a9614747f_i965&advanced.txt ffmpeg-transcode-493bdede-2792-4e23-ab6e-ae15cb3f97cf_i965&yes.txt

Link to comment
Share on other sites

That's weird. When it doesn't work with both drivers there must be some issue at the side of the hardware or OS configuration.

It is possible to connect a monitor to the box?

Link to comment
Share on other sites

Sailence
38 minutes ago, softworkz said:

这很奇怪。 当它不适用于两个驱动程序时,硬件或操作系统配置方面一定存在一些问题。

可以将显示器连接到盒子吗?

I can connect a monitor to the xpenology. Is this what you need?

Link to comment
Share on other sites

1 minute ago, Sailence said:

I can connect a monitor to the xpenology. Is this what you need?

Yes, please try this:

  • Connect a monitor
  • Restart the xpenology
  • Check whether the monitor works
  • Check whether transcoding works

Thanks

Link to comment
Share on other sites

Sailence
59 minutes ago, softworkz said:

是的,请试试这个:

  • 连接显示器
  • 重启xpenology
  • 检查显示器是否工作
  • 检查转码是否有效

谢谢

I connect a monitor to the xpenology, then reboot the xpenology, please see the picture for the information displayed.

420842740_.png.eb7b079719c495711bc0c554b21c4d4e.png

428363938_.png.5e96435a22d7afd456deb6f6566d9654.png

376844274_.png.0a297eb8e96cd96db0f7ff0cf9370f05.png

Then enter the xpenology, the display has no information, the indicator light of the display is green.

Following is the interface of BIOS.

1410190840_.png.60a586cb4cefdd5dac1b46e1af95fcc6.png

Link to comment
Share on other sites

Sorry, I just realized that xpenology is a hack for running Synology software on any computer.

I'm not familiar with this and can't provide much help here. The only other reason I can think of is that maybe the kernel is too old or something else is wrong with that OS image.

  • Like 1
Link to comment
Share on other sites

  • Solution

I too did not realize this was xpenology as the title says DS918+ which it isn't.  918+ is a reference to the actual hardware, not the software running on which would likely be DSM 6 or DSM 7 these days.

Xpenology is neither as it does hardware emulation and includes a patched (not true) version of an older DSM release.

Generally speaking xpenology will work ok for normal things that don't care about hardware but may have issues with actual hardware interaction as it's not really present.

As an interesting test I created a VM on my actual Synology 920+ and installed xpenology in it. I was not able to get hardware transcoding to work this way either and that's on actual Synology hardware. I did not spend a lot of time on this so I'm not saying it can't be done, but it would probably require a lot of tinkering with at the OS level and isn't something Emby can directly support.

Here is the actual file downloaded playing on my actual Synology. Work with VAAPI or QUICKSYNC.
image.png.4f91aab533ceab1b3b75dda6095c65c6.png

image.png.b3e693f6d3bd891e71b014e14db5a966.png

Edited by softworkz
Bolded solution text
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

 

1 hour ago, cayars said:

I too did not realize this was xpenology as the title says DS918+ which it isn't.

I updated the title to reflect this.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...