Jump to content

Video files can not avaliable to see and play.


firefox66
 Share

Recommended Posts

firefox66

As i mention above, i setup Emby Web app as the server on Rasp Pi throught DietPi to play media files. The music is easy to play, just place file flac, mp3 ... on the folder and play. But the movie file is not the same act like this,  i have follow the instruction to organize like /Movies/ [name of film (year)] / name of film (year).extemsion ... with no luck. on dashbar i have just see the name of the folder i create without video files exist to play... any help for this ??? 

pls: rasperry pi 3 B, already premium purchased Emby. File exsit on the server can be seen and play throught another media player.

thanks for help

Link to comment
Share on other sites

Hi there, how did you setup the video library in emby library setup?

Link to comment
Share on other sites

firefox66

Add Library, all setting by default, just point to direction video belong to be. Content type > Movies (for kvm, mp4 ... medias) > folder is: /Movies/ media name (year).ext

Capture_01.PNG

Capture_02.PNG

Edited by firefox66
Link to comment
Share on other sites

Did you run a scan of all libraries after doing that? It gets started automatically so normally there is nothing you need to do, unless you might have stopped it.

Link to comment
Share on other sites

firefox66

I have already scan by manual, nothing happen. i am in version 4.6.4.0 ... is it correct? in Plex server, everything act live normal for media file exsit.

Link to comment
Share on other sites

Please run another library scan and then after it completes, please attach the emby server log. Thanks.

Link to comment
Share on other sites

firefox66
6 minutes ago, Luke said:

Please run another library scan and then after it completes, please attach the emby server log. Thanks.

make new library in Content type is Movies

embyserver.txt

Link to comment
Share on other sites

firefox66

if you want to inspect on the realtime, i will sent you the address website to signin and do what you want to find out what wrong. may be your telegram or whatapp avaliable to contact. thanks for help.

Link to comment
Share on other sites

Hi, I can certainly help you remotely, but I took a look at your log and see a couple of problems.

2021-10-26 20:48:37.082 Info LibraryMonitor: Stopping directory watching for path /mnt/datas/dietpi_userdata
2021-10-26 20:48:38.600 Info App: Found duplicate path: /mnt/datas/dietpi_userdata/Movies
2021-10-26 20:48:38.600 Info App: Found duplicate path: /mnt/datas/dietpi_userdata/Video
2021-10-26 20:48:39.437 Info App: Found duplicate path: /mnt/datas/dietpi_userdata/Movies
2021-10-26 20:48:39.437 Info App: Found duplicate path: /mnt/datas/dietpi_userdata/Video

 

It looks like you might have /mnt/datas/dietpi_userdata setup as a mount point but then also mount these folders in another library.  It also appears you've used the Video and Movies multiple times as well.  You want to setup your libraries so content is added once and only once to any library.  So you would never directly mount dietpi_userdata but instead would mount Movies in one library and Video in another library.

 

The log is also showing a permission problem:
Access to the path '/mnt/datas/dietpi_userdata/filebrowser' is denied.

Make sure that's a proper folder and that you've set permissions for Emby Server to access it.

 

I'm also seeing these errors:
Access to the path '/mnt/datas/dietpi_userdata/mysql' is denied.

Access to the path '/mnt/datas/dietpi_userdata/nextcloud_data' is denied.

 

@Luke Do you know where Emby Server gets installed on this OS?
I ask because of this access error with mysql folder: Access to the path '/mnt/datas/dietpi_userdata/mysql' is denied.

  • Like 1
Link to comment
Share on other sites

From the top of the log:

	Data path: /var/lib/emby
	Application path: /opt/emby-server/system

 

Link to comment
Share on other sites

firefox66

i would consider your post but there are 2 things you have to notice that is: @Luke @cayars

1. I have two medias server in one machine, one is Emby and another is Plex -> why Plex can access to the same folder and play all music and video files ? (Emby access denied)

2. I Create the structure in Emby like the advice on web -> if Emby has access denied, how can it see the subfolder in Movies folder but it can not get the files exist?

Edited by firefox66
Link to comment
Share on other sites

Did you fix the issues I pointed out in the above post with possible multiple libs pointing to the same media folders?
You also get denied access errors which means there is a permission problem.

I can't answer your question about why Plex can access the files and Emby can't without looking at things but normally things that could cause this are all permission issues such as Plex is the owner of the folders, Plex belongs to a different group then Emby does that has permissions, etc.

When Emby reports a denied access message it's getting that from the file system which isn't letting it access the folder/media.

 

Link to comment
Share on other sites

firefox66

Thanks to my heroes. i have solved the problem by fresh install Emby and settup Library all again. Like @cayars mention above about the folders of this content library exist in another folder content library cause this problem (i dont set permission to media folder in fresh setup Emby).

 

btw thanks all. i am in testing for more format with Library Content...

Edited by firefox66
Link to comment
Share on other sites

Sounds good.  Let us know how you make out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...