Jump to content

Dynamic Library Not Loading all Videos


feerlessleadr
 Share

Go to solution Solved by quickmic,

Recommended Posts

feerlessleadr

Hi - I think I accidentally stumbled upon a bug. I currently backup a bunch of videos from NHL.com and dump them all into a folder organized by date using the following folder structure: Devils Website -> Year -> Month -> Video Files.

When I navigate in kodi to the dynamic library, then all the way down to the month folder for October, only the first video file is included in Kodi. When I go to that same folder in the emby web-interface, all of the video files are listed. 

I've tested this on multiple boxes (shield, N2, windows) and I get the same issue. 

Here is a log from kodi navigating to that specific folder with only the 1 video shown. 

https://paste.ubuntu.com/p/QwS9wRmXxj/

My emby server is running on a Windows 10 Pro machine and is version 4.6.4.0. Please let me know if anything else is needed for debugging. Thanks

Link to comment
Share on other sites

obituary

I've noticed this too with my Olympic directory structure - even for syncing. It's been a while since I've looked though. I'll recheck things

Link to comment
Share on other sites

quickmic

I'll check that.

@TeamB

Probably you should also have a look into the log file. Seems there is an Websocket upgrade issue, which probably comes from Embycon?

Link to comment
Share on other sites

TeamB

I had a quick look but could not see any issues. What line was the error on?

Link to comment
Share on other sites

quickmic
2021-10-12 18:53:23.940 T:7115    DEBUG <CAddonSettings[plugin.video.embycon]>: trying to load setting definitions from old format...
2021-10-12 18:53:23.952 T:7115    DEBUG <CSettingsManager>: requested setting (saved_user_password_b528908a972803e6056a8f995c6e679a) was not found.
2021-10-12 18:53:23.983 T:7111     INFO <general>: Python interpreter stopped
2021-10-12 18:53:23.983 T:7111    DEBUG <general>: Thread LanguageInvoker 3664011904 terminating
2021-10-12 18:53:24.005 T:7115    ERROR <general>: --- request header ---
                                                   
2021-10-12 18:53:24.006 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.006 T:7115    ERROR <general>: GET /embywebsocket?api_key=f070a536819e486b96b1fbf807eb950f&deviceId=1ea965fd75924e55be0640af6468f9c0 HTTP/1.1
                                                   Upgrade: websocket
                                                   Connection: Upgrade
                                                   Host: 192.168.1.16:8096
                                                   Origin: http://192.168.1.16:8096
                                                   Sec-WebSocket-Key: DuIQ3mDtndywI2SWj3Te7Q==
                                                   Sec-WebSocket-Version: 13
                                                   
                                                   
                                                   
2021-10-12 18:53:24.006 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.006 T:7115    ERROR <general>: -----------------------
                                                   
2021-10-12 18:53:24.006 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.006 T:7115    ERROR <general>: --- response header ---
                                                   
2021-10-12 18:53:24.006 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.023 T:7115    ERROR <general>: HTTP/1.1 101 Switching Protocols
                                                   
2021-10-12 18:53:24.024 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.029 T:7115    ERROR <general>: Connection: Upgrade
                                                   
2021-10-12 18:53:24.029 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.031 T:7115    ERROR <general>: Date: Tue, 12 Oct 2021 22:53:23 GMT
                                                   
2021-10-12 18:53:24.031 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.031 T:7115    ERROR <general>: Server: Kestrel
                                                   
2021-10-12 18:53:24.031 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.032 T:7115    ERROR <general>: Upgrade: websocket
                                                   
2021-10-12 18:53:24.032 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.034 T:7115    ERROR <general>: Sec-WebSocket-Accept: V3Hy2dlSho3N8s6p494S0DOPs3Q=
                                                   
2021-10-12 18:53:24.034 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.034 T:7115    ERROR <general>: -----------------------
                                                   
2021-10-12 18:53:24.034 T:7115    DEBUG <general>: .
2021-10-12 18:53:24.037 T:7115    DEBUG <CAddonSettings[plugin.video.embycon]>: trying to load setting definitions from old format...

 

Link to comment
Share on other sites

TeamB

That looks ok, are you referring to the ERROR lines? That might just be an incorrect log level log line

  • Like 1
Link to comment
Share on other sites

quickmic

ok, then it's all good. It was just an assumption cause it looked strange to me.

Link to comment
Share on other sites

quickmic
1 hour ago, feerlessleadr said:

Thanks all

what's the library type? Homevideos or mixed or something else?

Link to comment
Share on other sites

feerlessleadr
1 minute ago, quickmic said:

what's the library type? Homevideos or mixed or something else?

It's set to 'Home videos & photos'

Link to comment
Share on other sites

  • Solution
quickmic
3 minutes ago, feerlessleadr said:

It's set to 'Home videos & photos'

I've send you a test version.

Link to comment
Share on other sites

feerlessleadr
46 minutes ago, quickmic said:

I've send you a test version.

Thanks - that fixed it. 

  • Like 1
Link to comment
Share on other sites

quickmic
10 hours ago, obituary said:

I've noticed this too with my Olympic directory structure - even for syncing. It's been a while since I've looked though. I'll recheck things

You mentioned this also happens to synced content? This seems not possible, cause Folder view is not even offered for synced content. Maybe you are talking about partial synced content?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...