Jump to content

Raspberry Pi 3 - Emby Theatre jerky / low fps


ScottBouch
 Share

Recommended Posts

ScottBouch

Hi, I have just installed the latest Emby Theatre iso on a Raspberry Pi 3.

Info:

This Raspberry pi 3 has previously been fine operating Kodi (OSMC, Libreelec), and RasPLEX clients. It is connected to the network by Ethernet.

Image used: 2021-03-31-emby-theater-rasp.img from: https://emby.media/emby-theater-rpi.html

Issue:

Browsing the menus is very laggy and clunky, and when you try to play (either an HD movie or low-res episode of Peppa Pig), the video playback is so very slow, maybe 3 or 4 frames per second. The low FPS witnessed in the video does resemble the menu issue, so I'm thinking it's a general OS / device issue, ie: not just video playback issue.

The sorry part of this story is that I yesterday also just paid for lifelong Emby Premiere to unlock the playback feature of Emby Theatre for this Raspberry Pi, only to find that it doesn't work. If it remains not working I will ask for a refund as I don't need a premiere account for any other reason.

Please can anyone suggest how to make this work? I raised this issue on github, but thought I may look for a solution form the forum too.

Edited by ScottBouch
Link to comment
Share on other sites

ScottBouch

Hi Luke, thanks.. I know with dev work it's like asking how long a piece of sting is, but is there any idea of an expected timescale on this project; or perhaps a better question is the priority it's being given alongside other projects?

Just that my wife is (quite rightly) questioning the ~£80 lifetime premiere investment we have just made for Emby Theatre - it's a bit embarrassing that I can't make it work.

Cheers, Scott

Link to comment
Share on other sites

daldana

Scott,

I also am using a Pi 3 as an Emby client, albeit with the Debian image, and I've found that a few changes in the raspi-config really made a difference. You may have already tried these so I apologize if I'm repeating anything.

1. Increase the GPU memory to 128 or 256.

2. Enable the "Fake KMS" driver. To do this go to Advanced Options, GL Driver, enable "Fake KMS". Note, this may kill HDMI audio, but there is a fix for that. You would have to modify the /boot/config.txt file with the below changes, then selecting the second choice for audio in raspi-config (in my case it was MAI PCM i2s-hifi-0).

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2
hdmi_force_edid_audio=1

Hope this helps.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...