Jump to content

Seeking help on getting trailers working


jmos1277
 Share

Go to solution Solved by quickmic,

Recommended Posts

jmos1277

Anyone have any suggestions on how I can get my LOCAL trailers working?  Any debugging suggestions might be helpful as well.
I'm running the Embuary skin on Kodi 19.1 with Emby for Kodi Next Gen add-on.  When I select a movie, and then view the info for that movie there is a trailer button to play the trailer (see attached image).  However, when I click the trailer button, my UI flashes, my trailer does NOT play, and I get kicked back to my movie list.

I've attached my Kodi log file -- relevant lines appear to be 3171 - 3188.  
On line 3171, you can see the Emby next get plugin attempts to play the video file. I've confirmed that the id is correct.
On line 3188, you can see I get kicked back to the main Kodi screen and the trailer never plays.

You'll notice that I did NOT include an Emby log file.  That's because the request from Kodi never seems to hit my Emby server.  At least, there is no record of the request in my Emby log files ... even with debug info enabled.

Some more info:

  • All trailers are stored as MKV files on my unRAID NAS using the recommended naming scheme (i.e. "movieName/trailers/movieName-trailer.mkv").
  • Emby is running in a Docker container on my unRAID server.
  • Trailers play correctly when I browse my Emby server via the web interface in my web browser, but they don't work in Kodi
  • Emby Next Gen Add-on (ver.5.3.2), Playback mode = "Add-on (default)"
  • I don't use CinemaMode, so that's disabled.
  • All movies play just fine.  It's just the trailers that don't work.

 

screenCap.png

kodi.log

Link to comment
Share on other sites

DiscoDuck79

Have you tried to instead of:

movieName/trailers/movieName-trailer.mkv

change to

movieName/movieName-trailer.mkv

From what I can see here https://support.emby.media/support/solutions/articles/44001159193-trailers the separate folder is for complete rips. I don't use local trailers myself but might be worth to test to copy one file as suggested and then refresh the movie in Emby afterwards to trigger the sync. Kodi uses the same structure so should I would give it a go https://kodi.wiki/view/Trailers

Link to comment
Share on other sites

  • Solution
quickmic

Unfortunately, (local) trailers are not synced (available) yet 😞 It's still on my todo list.

Link to comment
Share on other sites

jmos1277
1 hour ago, quickmic said:

Unfortunately, (local) trailers are not synced (available) yet 😞 It's still on my todo list.

quickmic ... I've been out of the loop.
However, I just looked up your posting history and see that you're one of the devs on the next gen add-on.
Thanks for the great add-on and for updating me on the official status with regard to trailer support.
 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...