Jump to content

Search the Community

Showing results for tags 'vhost'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. Okeur75

    [Solved] Emby apach vhost

    Hello guys, Yes another apache reverse proxy tuto but I'm a bit stuck ! I found a vhost config that works in my case : <VirtualHost *:80> ServerName my.website Redirect permanent /emby https://my.website/emby </VirtualHost> <VirtualHost *:443> ServerName my.website ErrorLog ${APACHE_LOG_DIR}/emby-error_log LogFormat "%t \"%r\" %>s" common CustomLog ${APACHE_LOG_DIR}/emby-access_log common RewriteEngine on RewriteRule ^/emby$ /emby/ [R] <proxy *> AddDefaultCharset off Order Allow,Deny Allow from all </proxy> ProxyRequests Off ProxyPreserveHost On <Location /emby> ProxyPass http://localhost:8096 ProxyPassReverse http://localhost:8096 </Location> <Location /emby/emby> ProxyPass ws://localhost:8096/emby ProxyPassReverse ws://localhost:8096/emby </Location> </VirtualHost> If I only enable this vhost it's working. But ! I also have transmission running with the following configuration: <VirtualHost *:443> ServerName my.website ServerAlias www.my.website Redirect permanent /transmission https://my.website/transmission RewriteEngine on RewriteRule /transmission[/]?$ /transmission/web/ [R=permanent] ProxyRequests On ProxyPreserveHost Off <Proxy *> Order allow,deny Allow from all </Proxy> ProxyPass /transmission http://127.0.0.1:9091/transmission ProxyPassReverse /transmission http://127.0.0.1:9091/transmission </Virtualhost> <VirtualHost *:80> ServerName my.website ServerAlias www.my.website Redirect permanent /transmission https://my.website/transmission </Virtualhost> If I enable emby first (by renaming the file 01-emby and 03-transmission) : emby is working but transmission is not. If I enable transmission first (01-transmission and 03-emby) : transmission is working and emby is not with the following error message : You don't have permission to access /emby on this server. So I guess there is some issue with the rewrite rule. In emby dashboard I selected the "Secure connection mode" parameter to "Handled by reverse proxy". For info https://my.website:8920/emby is working. I'm not really familiar with Apache so I may have missed something obvious. Thanks for your help guys !
×
×
  • Create New...