Jump to content

Search the Community

Showing results for tags 'server'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hello fellow Emby Users, lately i encounter extreme loading times, when i open emby on web/mobile app/desktop app it takes 10 seconds easy to load all the preview. Same for searching or any click, it takes ages. Starting a video file sometimes can take up to 30-60 seconds. If i go into the Database Settings and vacuum the database on next start up and restart Emby, everything is blazing fast again as it should be. But pretty much as soon as i start a library scan it slows down pretty fast till it's not usable anymore. A library scan takes +18 hours in this state. The VM is installed on SSDs and runs Ubuntu 22.04 minimal version. I set up a new VM and installed Emby again but i run into the same issues. I am trying to troubleshoot this for a couple of weeks now but i sorta run out of ideas. For storage i use cloud storage mounted via rclone and image extraction off. The VM has 8GB ram and 8 cores of a i9-10850K CPU assigned which is plenty so there shouldn't be any bottleneck. I sadly can't tell when this issue starts if it came with a new Emby version or not since i've got this for a while and only occasionally bothered to check what could cause it, so i have it for a while. If it requires me to test different scenarios and or send more files please let me know. Thanks for any help in advance! embyserver.txt
  2. I am also having this exact issue and this is extremely frustrating. The stream will hang randomly (it could be 5, 15 or 30 mins) but if it doesn't, it will ultimately crash at around 4 hours of continuous playing. The transcoding log gives zero information as it only hangs there until I quit the frozen stream and then it logs "user quit"... The emby server log has the errors as mentionned by the first posts in this thread. In exemple : 2022-07-31 09:47:41.193 Info HttpClient: Http response 404 from http://host6/x_path4_x/x_path21_x after 175ms. HeadersServer=nginx, Date=Sun, 31 Jul 2022 13:47:41 GMT, Connection=close, Access-Control-Allow-Origin=* The most frustrating part is if and when I use VLC to watch/decode the M3U link, the stream works flawlessly and will keep going for days. There must be something you guys can do about it..?
  3. EmbyStat is a personal web server that can calculate all kinds of statistics from your (local) Emby server. Just install this on your server and let him calculate all kinds of fun stuff. This project is still in Alpha fase, but feel free to test it on your computer. Packages Supported platforms as the moment are: Windows x64 (IIS and Kestrel) Windows x86 (IIS and Kestrel) Docker https://hub.docker.com/r/uping/embystat/ Debian package I will try to support as many platforms as possible. More and more will come in the future! If you have knowledge about building Unix packages please feel free to contact me so I can support as many platforms as possible. Feature request If you have some crazy idea you want to see implemented in EmbyStat you can create a feature request here => https://embystat.featureupvote.com/ Or just go and upvote your favorite features so I have a better idea about what I should build next. Installation Guides Go to https://github.com/mregni/EmbyStat/releases and grab the latest release. The packages are selfcontained so you don't need to install dotnet runtime on your host. Run the server (Kestrel on Windows example) Embystat.exe --port <port> Passing a port is optional, default port is 6555 To host it in a Docker container you can use the following command docker run -p <port>:6555 -v <hostpath>:/app/config uping/embystat:beta Translations Translations are managed with the Crowdin web service. Feel free to help me translate the application in your own language here: https://crowdin.com/project/embystat. If your language is not listed just create a new feature request or ping me. Technology This project is build from scratch with the following technologies: .NET CORE 2.2 LiteDB SignalR NLog Angular 5 Rollbar Roadmap A lot of things need to be done before I can go life with this and publish my first 1.0 release. This will happen when all features from the Emby statistics plugin are implemented in EmbyStat.
  4. When I click 'Save' Button, the problem will occur.(Picture 1) But When I return to the user page, it seems that it has been created successfully. Also, I can log in with this 'Ghost User'. However I cant edit any settings of this user, there is no any new user in /config/user, user.db in /data wasnt updated. Restarting emby and vps has been tried but doesnt work. Anyone know how to deal with it plz?
  5. speedingcheetah

    Record failing at random times/closed connection

    I have having recording failures. Sometimes its 40 min, sometimes 15min. The server reports stream server closed connection. and it retries, but gets 403 error. and quits after 435ms. I need this to be much longer and have it try more.... From the log, i gather my iptv service is dropping connection, and it take several seconds for it to accept a new connection. here is what log says, removed the iptv url. 2020-07-13 16:15:53.562 Info SharedHttpPipelineSource: Remote server closed stream http:// 2020-07-13 16:15:53.563 Info SharedHttpPipelineSource: Retry opening stream http:// 2020-07-13 16:15:53.563 Info SharedHttpPipelineSource: Opening SharedHttpPipelineSource Live stream from http:// 2020-07-13 16:15:53.563 Info HttpClient: GET http:/ 2020-07-13 16:15:53.999 Info HttpClient: Http response 403 from http:// after 435ms. HeadersServer=nginx, Date=Mon, 13 Jul 2020 21:15:53 GMT, Connection=close, Access-Control-Allow-Origin=* 2020-07-13 16:15:54.001 Error SharedHttpPipelineSource: Give up retries copying live stream http:// *** Error Report *** Version: 4.4.3.0 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb Operating system: Unix 5.3.0.62 64-Bit OS: True 64-Bit Process: True User Interactive: True Runtime: file:///opt/emby-server/system/System.Private.CoreLib.dll System.Environment.Version: 3.1.2 Processor count: 4 Program data path: /var/lib/emby Application directory: /opt/emby-server/system MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: Forbidden at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod) at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod) at Emby.LiveTV.TunerHosts.SharedHttpPipelineSource.OpenStream(IDisposable connectionContext, MediaSourceInfo mediaSource, String url, MediaProtocol protocol, CancellationToken cancellationToken, Int32 recursion) at Emby.LiveTV.TunerHosts.SharedHttpPipelineSource.<>c__DisplayClass8_0.<<StartStreaming>b__0>d.MoveNext() Source: Emby.Server.Implementations TargetSite: Void MoveNext() 2020-07-13 16:15:54.003 Error SharedHttpPipelineSource: Error copying live stream. *** Error Report *** Version: 4.4.3.0 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffdetect /opt/emby-server/bin/ffdetect -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb Operating system: Unix 5.3.0.62 64-Bit OS: True 64-Bit Process: True User Interactive: True Runtime: file:///opt/emby-server/system/System.Private.CoreLib.dll System.Environment.Version: 3.1.2 Processor count: 4 Program data path: /var/lib/emby Application directory: /opt/emby-server/system MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: Forbidden at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod) at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod) at Emby.LiveTV.TunerHosts.SharedHttpPipelineSource.OpenStream(IDisposable connectionContext, MediaSourceInfo mediaSource, String url, MediaProtocol protocol, CancellationToken cancellationToken, Int32 recursion) at Emby.LiveTV.TunerHosts.SharedHttpPipelineSource.<>c__DisplayClass8_0.<<StartStreaming>b__0>d.MoveNext() --- End of stack trace from previous location where exception was thrown --- at Emby.LiveTV.TunerHosts.SharedHttpPipelineSource.<>c__DisplayClass8_0.<<StartStreaming>b__0>d.MoveNext() Source: Emby.Server.Implementations TargetSite: Void MoveNext() 2020-07-13 16:15:54.003 Info SharedHttpPipelineSource: SharedHttpPipelineSource is done streaming.
  6. Funkie

    HTTPS 8920 internal not running

    Hi @Luke I am running emby server 4.7.5.0 on Ubuntu 20.04.4 LTS. Not sure when this stopped working as I mainly access my server locally via http but setup HTTPS on port 8920 behind HAProxy and was working fine. I saw an error no backend to emby in HAProxy so investigated and indeed I cannot access the server at all on https. If I curl from the emby server I get this error curl: (7) Failed to connect to localhost port 8920: Connection refused
  7. Hi, When I watch something on my LG TV, it sometimes pauses the show then a couple of seconds later it continues. Other times it just totally goes to a black screen with the circle in the middle going around and around. The only way to fix it is go into Task manager and close the embyserver process and then re-open the emby server. I have included my log file hoping someone might have a clue or an idea why it keeps doing this. embyserver.txt
  8. sakings7402

    Open Media Vault Server

    I just recently set up a file server running Open Media Vault and I saw that you can run your Emby Server on that. But I am confused at how to install it because it has no graphic interface and I manage it remotely with the Web UI that is provided with it. I would like to install it on there and then move all of my movies to it so that it is no longer reliant on my desktop computer. If someone could please provide me with the details on how to install it, I would greatly appreciate it.
  9. I love the additional subfolders for Movie Extras (eg, Shorts, Scenes, Interviews, etc.)! I would like to propose an additional folder: "Galleries". Within the Galleries folder the user would place subfolders (only one level of nesting) and each subfolder could contain any images the user chooses. Then, Emby would display the subfolder name as an Extra (in Emby Theater) and opening that extra would launch an image gallery of the containing images. For example: Movies\Disney\The Sword In The Stone (1963)\Galleries\Scrapbook Movies\Disney\The Sword In The Stone (1963)\Galleries\Film Facts "Scrapbook" is what would be listed among other Extras in Emby Theater, and the Scrapbook folder contains various images to be displayed in a slideshow that the user can navigate with their left/right arrows. This feature request is motivated by the following related post: https://emby.media/community/index.php?/topic/55912-video-ts-folder-no-longer-recognized-in-movie-extras-folder/ Basically, sometimes there are extras such as image galleries and text content which are only available via the DVD menu. I have found that I can use FFMPEG to extract all the frames from a video file, and so use that on the appropriate VOB file from the original DVD. Then I can use VisiPics to delete all the duplicates, resulting in content I can then sort into folders (eg, Concept Art, Storyboards, etc.). All I need is for there to be the above support for a Galleries extras folder, which could contain multiple subfolders (only one level deep), each containing images to be displayed as image galleries in Emby Theater, etc. Thanks for your consideration! PS - If this is something you might like to see implemented, be sure to "Like" this top/first post (as well as any subsequent posts in this thread that highlight particular aspects of what you are interested in) -- "Liking" the top/first post helps the Devs to know how much interest there is in a given Feature Request.
  10. Hi there! I noticed after installing 4.7.4.0 that there is a bug in the Dashboard for the server's network address. I'm not sure if this existed prior to 4.7.4.0 because I just recently changed the default HTTPS port. Anyway as per the screenshot, the listed WAN address shows the default 8920 port and not the custom port. I can confirm that Emby really is listening on the custom port and not 8920, so this seems to simply be a display artifact.
  11. I did a quick search and didn't see this anywhere so apologies if this is a duplicate issue. I have updates turned on and the server should reboot itself, however, whenever it "updates" it reboots and loads to the previous version (currently 4.7.1.0 trying to update to 4.7.2.0) and then continues to give a "Please restart the server to finish applying updates." It did this when updating to 4.7.1.0 from the version before that as well and i manually downloaded and installed the version. But i don't want to have to keep doing that. How can I get the server to actually complete the installs to the new versions? Operating in Windows 10 (Pro)
  12. As I mention in a related post, I love the additional subfolders for Movie Extras (eg, Shorts, Scenes, Interviews, etc.)! It would be awesome to extend this functionality to TV Series as well. Specifically to add support for many/all of the same folders supported for Movie Extras, eg, extras specials shorts scenes featurettes behind the scenes deleted scenes interviews trailers As well as any additional folders that get added in the future (eg, hopefully Galleries). Support Placement of "Extras" Folders Within Each Season Folder, Plus A Naming Scheme to Link A Particular Extras Folder with a Specific Episode (eg, "\Season 1\E1 - Deleted Scenes\" for episode 1 deleted scenes): I want to clarify that it would be great if these various "extras" folder types could reside within each Season folder. So for example, within a Season 1 folder we could then have an "Extras" folder, a "Deleted Scenes" folder, a "Featurettes" folder, etc. And furthermore, that we could designate a particular folder to refer to a specific episode (eg, "\Season 1\E1 - Deleted Scenes\" for episode 1 deleted scenes). See more below, particularly why I think this would be so useful: https://emby.media/community/index.php?/topic/55915-emby-server-theater-additional-extrasspecial-folder-types-for-tv-series-similar-to-movies/&do=findComment&comment=587195 Thanks for your consideration! PS - If this is something you might like to see implemented, be sure to "Like" this top/first post (as well as any subsequent posts in this thread that highlight particular aspects of what you are interested in) -- "Liking" the top/first post helps the Devs to know how much interest there is in a given Feature Request.
  13. jeffersoncg

    "Better" identify library

    Hi, I'm new here. I added several movies to my library, but the names weren't 100% accurate, for example: "expendables.mkv", which was recognized as "expendables 4" I don't know if Emby would need the information there like "expendables 1.mkv", but there are several of these movies that were added that ended up like this, having only the name of the movie, without informing the "order" (like the movie "Scream .mkv" which emby recognized as "Scream 5"). In a "Manga" reader that i did, i make this code to "find" the most probably correct match. I'm not a developer, i just tryed make the code until it give-me a good result. Code running with 2473 movies in db, and it find the match easily (I used it a lot with all 1.378 manga that i have, and it update each correctly, without a problem), so... Is there a way to implement something like this on emby? I know that the code is way to not optimized, but, for now is what i can do. Code: function GetAllMangaMatches(Lista, Nome){ let NovaLista = Clone(Lista); let Retorno = {Vazio: ''}; let Mangas = []; let Counter = 0; while (!Empty(Retorno)) { if(Counter > Lista.length) break; Retorno = FiltrarManga(NovaLista, Nome); if(!Empty(Retorno)) { Mangas.push(Retorno); delete(NovaLista[NovaLista.indexOf(Retorno)]); NovaLista = CleanArray(NovaLista); } Counter++; } return Mangas; } function Clone(Objeto) { let Copia = null; if(!Array.isArray(Objeto)) Copia = Object.assign({}, Objeto) else Copia = Object.keys(Objeto).map((key) => Objeto[key]); return Copia; } function Empty(Object) { return $.isEmptyObject(Object); } function FiltrarManga(Lista, Nome){ if (Lista.length == 0) return ''; let Manga = []; let CountMax = 0; let Count = 0; let ListaNomes = arrayColumn(Lista, "Name"); ListaNomes = ChangeCase(ListaNomes, toLowerCase); Nome = RemoverCaracteresEspeciais(Nome.toLowerCase()); let NomeArray = Nome.split(' '); NomeArray = CleanArray(NomeArray); let isOrigemDoujinshi = NomeArray.includes('doujinshi'); let SelectedValue = []; let isMatchDoujinshi = false; x = 0; let foundExact = false; ListaNomes.map(function(value){ if(foundExact) return; value = RemoverCaracteresEspeciais(value); if (value == Nome) { Manga = Lista[x]; foundExact = true; return Manga; } Count = GetOcorrencias(value, Nome); if (Count > CountMax) { CountMax = Count; Manga = Lista[x]; SelectedValue = value.split(' '); SelectedValue = CleanArray(SelectedValue); isMatchDoujinshi = SelectedValue.includes('doujinshi'); } x++; }) let NomeArraySize = NomeArray.length; if (((CountMax > NomeArraySize*0.9) && (NomeArraySize + 3 > SelectedValue.length) || (foundExact)) && (isMatchDoujinshi == isOrigemDoujinshi)) { if(Manga != undefined) { if(Manga.length == 0) { Manga = Lista[0]; } } else { Manga = Lista[0]; } } else { return []; } return Manga; } function arrayColumn(array, columnName) { return array.map(value => value[columnName]) } function ChangeCase(Elemento, CaseFunction, Parameters) { switch (typeof(Elemento)) { case 'string': return CaseFunction(Elemento, Parameters); break; case 'object': if(Array.isArray(Elemento)) { return Elemento.map(x => ChangeCase(x, CaseFunction, Parameters)); } else { if(Elemento != null) { let ElementTemp = {}; Object.keys(Elemento).map(function(key){ ElementTemp[key] = ChangeCase(Elemento[key], CaseFunction, Parameters); }) return ElementTemp; } else return null; } break; default: return Elemento; break; } } function RemoverCaracteresEspeciais(texto, subst = ' ') { let pattern = /[^a-z1-9]/gi; return texto.replaceAll(pattern, subst); } function CleanArray(Array) { return Array.filter(x => !$.isEmptyObject(x)); } function GetOcorrencias(Fonte, Busca) { let ArBusca = RemoverCaracteresEspeciais(Busca).toLowerCase().split(' '); ArBusca = CleanArray(ArBusca); Fonte = RemoverCaracteresEspeciais(Fonte).toLowerCase(); let Contagem = 0; ArBusca.map(function(value){ if(Fonte.indexOf(value) != -1) Contagem += 1; }) return Contagem; } function GetAllMangaMatches(Lista, Nome){ let NovaLista = Clone(Lista); let Retorno = {Vazio: ''}; let Mangas = []; let Counter = 0; while (!Empty(Retorno)) { if(Counter > Lista.length) break; Retorno = FiltrarManga(NovaLista, Nome); if(!Empty(Retorno)) { Mangas.push(Retorno); delete(NovaLista[NovaLista.indexOf(Retorno)]); NovaLista = CleanArray(NovaLista); } Counter++; } return Mangas; } function toLowerCase(Texto) { return Texto.toLowerCase(); } function AddScriptByJavascript(src){ script = document.createElement('script'); script.src = src; document.body.appendChild(script); } AddScriptByJavascript("https://cdnjs.cloudflare.com/ajax/libs/jquery/3.6.0/jquery.min.js"); Ps: I Also add there a code "Importer" to add jquery, because the function from jquery "$.isEmptyObject(Object)" is needed. If wanna me to translate the function/parameters to english, i can do too.
  14. Emby client started a conversion process and I noticed it and stopped the process on the server-side. Now, the client's device tries polling the server on the conversion/sync progress and it appears to make Emby refuse all connections from that source (from my nginx proxy, so basically any connections through my duckdns.org domain) and results in a 502 error. My setup is: Router port forward ports 80, 443 --> nginx-proxy-manager hosted on docker on my Ubuntu (192.168.1.13), which routes to my Emby Server on Docker Nginx logs attached, Emby Server logs attached as well. # EMBY SERVER LOGS 2022-02-08 02:27:26.449 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/6/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.450 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/3/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.451 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/4/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.453 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/5/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.455 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/7/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.462 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/8/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.464 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/9/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.464 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/10/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.465 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/14/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.465 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/12/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.465 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/13/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.465 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/15/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 2022-02-08 02:27:26.466 Info Server: http/1.1 GET http://emby.mydomain.duckdns.org/Sync/JobItems/16/File. UserAgent: Emby/1 CFNetwork/1327.0.4 Darwin/21.2.0 # EMBY SERVER LOGS 2022-02-08 02:32:31.007 Info Server: http/1.1 Response 204 to 192.168.1.3. Time: 13ms. http://192.168.1.13:8096/emby/Sessions/Playing/Progress 2022-02-08 02:32:39.741 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 313277ms. http://emby.mydomain.duckdns.org/Sync/JobItems/9/File 2022-02-08 02:32:39.955 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 313501ms. http://emby.mydomain.duckdns.org/Sync/JobItems/5/File 2022-02-08 02:32:40.006 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 313193ms. http://emby.mydomain.duckdns.org/Sync/JobItems/25/File 2022-02-08 02:32:40.130 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 313313ms. http://emby.mydomain.duckdns.org/Sync/JobItems/24/File 2022-02-08 02:32:40.276 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 313809ms. http://emby.mydomain.duckdns.org/Sync/JobItems/16/File 2022-02-08 02:32:40.675 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 313840ms. http://emby.mydomain.duckdns.org/Sync/JobItems/38/File 2022-02-08 02:32:40.812 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 312229ms. http://emby.mydomain.duckdns.org/Sync/JobItems/57/File 2022-02-08 02:32:40.897 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 312303ms. http://emby.mydomain.duckdns.org/Sync/JobItems/59/File 2022-02-08 02:32:40.974 Info Server: http/1.1 Response 200 to 108.170.192.1. Time: 312381ms. http://emby.mydomain.duckdns.org/Sync/JobItems/67/File # NGINX ERROR LOGS 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/3/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/3/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/4/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/4/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/5/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/5/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/6/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/6/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/7/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/7/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/8/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/8/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/9/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/9/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/10/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/10/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/11/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/11/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/12/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/12/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/13/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/13/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/14/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/14/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/15/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/15/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET /Sync/JobItems/16/File?api_key=e387a9519d7f440ca1e089afc076f733 HTTP/2.0", upstream: "http://192.168.1.13:8096/Sync/JobItems/16/File?api_key=e387a9519d7f440ca1e089afc076f733", host: "emby.mydomain.duckdns.org:443" 2022/02/02 04:40:19 [error] 944#944: *10661 connect() failed (111: Connection refused) while connecting to upstream, client: 108.170.192.1, server: emby.mydomain.duckdns.org, request: "GET embyserver_redacted.txt embyserver-63779937295_redacted.txt nginx_error_redacted.txt
  15. I like listening to my music through my roku/emby setup. However, I don't need to know how the artist is while listening. I was wondering if there is some way to set up a virtualization like on windows media player? I can wait and my roku will go to it's screen saver, but I would like to make a choice. Or even display the lyrics on screen, all of my music files have the lyrics embedded.
  16. Pretty simple suggestion. I have multiple users for my Emby server. If I want to do continuous maintenance on the media, I have to tell everyone. some of them are harder to reach than others ( i.e. no Facebook or Skype chat etc. ) It would be great if say... on the admin panel, I could hit a check box that enables 'maintenance mode', where the server still runs does everything as normal, but instead of the login screen it displays a maintenance page saying the server is unavailable. Even better if I were able to directly put a reason in a text box that would then display on the login screen as well. Not really sure what others would think of this, but for me it would be quite helpful. mostly if I want to make sure no one is trying to access content I know won't work until I've done a full library scan again. Thanks for reading. -Kyle
  17. Hi, I need help. I am premium user and have the following issues. 1. My server is loaded on my iMac and I can watch shows on either the app or the web client on the iMac. 2. I can open and watch shows on my MacBook Pro 15" (older model) via either app or web client 3. (Problem 1) - I can open and watch shows on one my iPhone 12's but not my other (both the same age) 4. (Problem 2) - I can't load the server on my Apple TV - it just continues to give me the spinning cogwheel 5. (Problem 3) - I can't load the server on my MacBookPro 13" (current model) I have attached a log file for today but this is went screwy 3 days ago and I am going around the bend trying to figure it out. I have had to go back to using Plex which I dont like except for their subtitles. Any help would be greatly appreciated.
  18. Hello, I'm new to the Emby community, and looking to help my brother upgrade his Emby server that is now straining under the load of dozens of family and friends. Is there a thread, forum, or other site where I can go to learn about an optimal hardware upgrade path for his Windows system? Thanks in advance!
  19. stevedallas

    Subtitles - cannot get them

    I am a newby but I've searched these forums. I know I am making a newby mistake and would like help. I have created a user login in open subtitles and have provided my login name and password in emby. I have (I think) checked all of the correct boxes in each library's settings, but still no subtitles. There are no subtitle files in each recording's folder. I'm attaching a screen grab from my latest recording attempt. Please help! Thanks, Steve
  20. Hi everyone. My first post in this forum. I hope someone with some experience on emby API can help me figuring out how to call this endpoint. (https://app.swaggerhub.com/apis/vdts/jellyfin-server_api/1.0.0#/default/ResetTuner) The background is.. I use a 'virtual M3U tuner' on Jellyfin server that connects to a remote m3u file. This gets only updated if I do so on the admin panel at the EPG Data Refresh. By resetting the tuner, I suppose this would basically reload the remote m3u file but I don't know how to use it. I know it is a POST request, I've tried the payload using {'operationId':'RefreshItem','Id':'38d682202ec8345f5b7381f656f921e9c '} but I cant quite understand what does the Id refer to. That number there is what I can read on the browser address ..../livetvtuner.html?id=8d682202ec8345f5b7381f656f921e9c when getting into the tuner settings page. Any clue? Thanks in advance,
  21. Problem: Since the latest Emby Server Windows 10 update a few days ago, I have on all my Nvidia Shield devices no user selection screen anymore. The only options are "manual", "connect" or "server change". So every user have to do a manual login with password, altough the user account are set that no password is required on local network. My setup: Local network with a Windows 10 server running Emby Server (4.6.6.0). Four Nvidia Shields in the same network connected to this server, having the Emby Anroid TV app installed (2.0.48g registered). User setup and settings: Multiple users that in the local network are visible users (visible tiles on user selection screen) and no password is required to access the Emby server in the local network. Behaviour before the latest Server update: Started the Emby app on Shield and user selection screen showed up, the user selected his user tile and got immediate access to the libraries (no password required). What I have tried to fix:: - Deinstalled Emby Android TV app on each Shield, reinstalled, unfortunately issue remains - Checked if this error can be replicated by accessing the server by a browser. Here it does work as it should, it shows a user selection screen with tiles you click on one and you get immediate access. That means this issue could be App specific, however Android App hasn't been updated since weeks and the only update that happened the last few days has been the Server update which and the timing matches with the first appearance of my issue. Could you please have a look at it. Thanks.
  22. First, thanks for what looks to be an amazing piece of software. I've scanned in all my music and some albums have appeared correctly but others not. The common ground between all those which failed is that they are in one single parent folder (which has various artist / album folders below it). Emby seems to think that the parent folder is an album with hundreds of tracks, although Metadata Manager shows me that it has read the Album ID3 tags correctly on each individual track. Does Emby make Album objects in the library based on the tags or on the folders? My audio tracks are not quite strictly organised as artist/album/track, but the same folder structure has worked fine with many bits of software over the past ten years or so (eg. Kodi, Foobar, Logitech Media Server etc), and I would much rather not re-folder if I can avoid it. Many thanks in advance for any help. SC Platform details: HP Microserver > Ubuntu > Flac files with ID3 tags > Emby 3.0.5675.1 - let me know if you need to know anything else!
  23. TomasBrabec

    DSM 7

    Hello, please go somewhere to download Emby server on synology ds218 +. I have a DSM 7, I can't download anywhere that could be tried. thank you very much
  24. As seen in https://en.wikipedia.org/wiki/HTTP/2 and lot of other IT sites.... it is known that HTTP/2 is coming as upgrade to HTTP/1.1 and has tons of benefits over the 1999's deprecated 1.1 version. Some sites already implement it (Akamai, Cloudfare...) and benefits on speed are remarkable. Probably is too soon to implement it on Emby... but I'd like to suggest it to be something to be studied, because soon we will be hearing more about it.
  25. Trying to install the Server - latest release. I cannot get past the language selection. It is just a blank drop-down, and clicking "next" does nothing. Windows Vista. Firefox. Adblock turned off. Admuncher turned off. I checked the forums for similar problems. I noticed at least three (3) other people over the past several months posted the same issue. No certain solutions. Frustrated. This occurred at the end of a long line of problems installing the software in the first place (related to Windows blocking me - "protecting me" - from installing the setup.exe.) I got past that. But this one? I'm too burned out to trouble-shoot on my own. I really don't want to update every add-on like shockwave, flash, java, etc, in Windows to see if it "might" fix the problem. Any help would be appreciated. Better yet, a final solution for other people who'll eventually have the same problem in the future.
×
×
  • Create New...