Jump to content

Search the Community

Showing results for tags 'ip cam'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. I seem to be having a slight problem with the IPTV plugin. I don't believe it is the plugin's fault, but possibly the Emby Server side, transcoding, or even the web browser. Currently it is working under Emby Theater, Emby for Android and Emby for Kindle. When I go to the Emby web client under Google Chrome, it will not display video or audio, just a black screen. I have the IPTV plugin installed with RTSP streams coming from my Ubiquiti UniFi Video Cameras. Here is what a working log looks like from the clients I have currently working: (see down below after this log for the web client which doesn't work) http://192.168.1.113:8096/videos/d1bcb6de4124e31def037ec88f3ee35d/stream.mp4?DeviceId=f87efcc71d08a74180944a1ec1b9611c63b07af4&MediaSourceId=053122d1ec71cdbcffce1a2a7793f08e&VideoCodec=h264&AudioCodec=aac&VideoBitrate=1372000&AudioBitrate=128000&MaxAudioChannels=2&MaxWidth=1280&Level=41&ClientTime=635667906067009206&Profile=high&PlaySessionId=d2de185902184809b19e1f2b35368a7a&api_key=63f14aa82a9348cebb47dc47b37fd475 {"Protocol":"Rtmp","Id":"053122d1ec71cdbcffce1a2a7793f08e","Path":"rtsp://192.168.1.113:7447/67f22897-e419-3645-ab79-a1745ece7f02_1","Type":"Default","Name":"053122d1ec71cdbcffce1a2a7793f08e","ReadAtNativeFramerate":false,"SupportsTranscoding":true,"SupportsDirectStream":false,"SupportsDirectPlay":true,"RequiresOpening":false,"RequiresClosing":false,"MediaStreams":[],"PlayableStreamFileNames":[],"Formats":[],"RequiredHttpHeaders":{}} C:\Users\Administrator\AppData\Roaming\MediaBrowser-Server\ffmpeg\20150331\ffmpeg.exe -fflags +genpts -i "rtsp://192.168.1.113:7447/67f22897-e419-3645-ab79-a1745ece7f02_1" -sn -codec:v:0 libx264 -force_key_frames expr:gte(t,n_forced*5) -vf "scale=min(iw\,1280):trunc(ow/dar/2)*2" -pix_fmt yuv420p -preset superfast -crf 18 -maxrate 1372000 -bufsize 2744000 -vsync vfr -profile:v high -level 41 -map_metadata -1 -threads 0 -codec:a:0 aac -strict experimental -ac 2 -ab 128000 -af "aresample=async=1" -f mp4 -movflags frag_keyframe+empty_moov -y "P:\~MediaBrowser\transcoding-temp\d94c1f3d453ac60e5211825e9d636193.mp4" ffmpeg version N-71182-g5cba529 Copyright (c) 2000-2015 the FFmpeg developers built with gcc 4.9.2 (GCC) configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-lzma --enable-decklink --enable-zlib libavutil 54. 21.100 / 54. 21.100 libavcodec 56. 32.100 / 56. 32.100 libavformat 56. 27.100 / 56. 27.100 libavdevice 56. 4.100 / 56. 4.100 libavfilter 5. 13.101 / 5. 13.101 libswscale 3. 1.101 / 3. 1.101 libswresample 1. 1.100 / 1. 1.100 libpostproc 53. 3.100 / 53. 3.100 Input #0, rtsp, from 'rtsp://192.168.1.113:7447/67f22897-e419-3645-ab79-a1745ece7f02_1': Metadata: title : 0418D623CE8B_1 Duration: N/A, start: 0.113107, bitrate: N/A Stream #0:0: Audio: aac (LC), 11025 Hz, mono, fltp Stream #0:1: Video: h264 (Main), yuvj420p(pc, bt709), 720x400 [SAR 80:81 DAR 16:9], 15 fps, 15 tbr, 90k tbn, 30 tbc [swscaler @ 0000000002e5f200] deprecated pixel format used, make sure you did set range correctly [libx264 @ 00000000059d00a0] using SAR=404/405 [libx264 @ 00000000059d00a0] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX [libx264 @ 00000000059d00a0] profile High, level 4.1 [libx264 @ 00000000059d00a0] 264 - core 146 r2538 121396c - H.264/MPEG-4 AVC codec - Copyleft 2003-2015 - http://www.videolan.org/x264.html - options: cabac=1 ref=1 deblock=1:0:0 analyse=0x3:0x3 me=dia subme=1 psy=1 psy_rd=1.00:0.00 mixed_ref=0 me_range=16 chroma_me=1 trellis=0 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=0 threads=6 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=1 keyint=250 keyint_min=15 scenecut=40 intra_refresh=0 rc_lookahead=0 rc=crf mbtree=0 crf=18.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 vbv_maxrate=1372 vbv_bufsize=2744 crf_max=0.0 nal_hrd=none filler=0 ip_ratio=1.40 pb_ratio=1.30 aq=1:1.00 Output #0, mp4, to 'P:\~MediaBrowser\transcoding-temp\d94c1f3d453ac60e5211825e9d636193.mp4': Metadata: encoder : Lavf56.27.100 Stream #0:0: Video: h264 (libx264) ([33][0][0][0] / 0x0021), yuv420p, 720x404 [SAR 404:405 DAR 16:9], q=-1--1, max. 1372 kb/s, 15 fps, 15360 tbn, 15 tbc Metadata: encoder : Lavc56.32.100 libx264 Stream #0:1: Audio: aac ([64][0][0][0] / 0x0040), 11025 Hz, stereo, fltp, 128 kb/s Metadata: encoder : Lavc56.32.100 aac Stream mapping: Stream #0:1 -> #0:0 (h264 (native) -> h264 (libx264)) Stream #0:0 -> #0:1 (aac (native) -> aac (native)) Press [q] to stop, [?] for help Past duration 0.756660 too large Past duration 0.736656 too large Past duration 0.701653 too large Past duration 0.696663 too large Past duration 0.766655 too large Past duration 0.686653 too large Past duration 0.756660 too large Past duration 0.766655 too large Past duration 0.701653 too large Past duration 0.711662 too large Past duration 0.766655 too large Past duration 0.761665 too large Past duration 0.696663 too large Past duration 0.721657 too large Past duration 0.761665 too large Past duration 0.606667 too large Past duration 0.721657 too large Past duration 0.761665 too large Past duration 0.711662 too large Past duration 0.736656 too large [NULL @ 0000000002e73400] RTP: missed 5 packets Past duration 0.701653 too large Past duration 0.756660 too large [h264 @ 00000000095b3160] error while decoding MB 16 23, bytestream -32 [h264 @ 00000000095b3160] concealing 123 DC, 123 AC, 123 MV errors in I frame Past duration 0.766655 too large Past duration 0.731667 too large Past duration 0.711662 too large Past duration 0.766655 too large frame= 27 fps=0.0 q=15.0 size= 1kB time=00:00:02.22 bitrate= 4.5kbits/s dup=0 drop=5 Past duration 0.686653 too large Past duration 0.681664 too large Past duration 0.751656 too large Past duration 0.761665 too large Past duration 0.696663 too large Past duration 0.751656 too large Past duration 0.761665 too large Past duration 0.666664 too large frame= 35 fps= 33 q=14.0 size= 1kB time=00:00:02.78 bitrate= 3.6kbits/s dup=0 drop=5 Past duration 0.721657 too large [NULL @ 0000000002e73400] RTP: missed 5 packets Past duration 0.731667 too large Past duration 0.681664 too large [h264 @ 00000000095b3160] error while decoding MB 17 23, bytestream -10 [h264 @ 00000000095b3160] concealing 122 DC, 122 AC, 122 MV errors in I frame Past duration 0.736656 too large frame= 39 fps= 23 q=14.0 size= 1kB time=00:00:03.06 bitrate= 3.3kbits/s dup=0 drop=5 Past duration 0.761665 too large Past duration 0.711662 too large Past duration 0.706657 too large Past duration 0.731667 too large Past duration 0.741661 too large Past duration 0.766655 too large Past duration 0.716652 too large Past duration 0.756660 too large Past duration 0.766655 too large Past duration 0.716652 too large Past duration 0.666664 too large Past duration 0.766655 too large frame= 51 fps= 23 q=15.0 size= 1kB time=00:00:03.90 bitrate= 2.6kbits/s dup=0 drop=5 [NULL @ 0000000002e73400] RTP: missed 4 packets Past duration 0.761665 too large Past duration 0.711662 too large [h264 @ 00000000095b3160] error while decoding MB 20 23, bytestream -50 [h264 @ 00000000095b3160] concealing 119 DC, 119 AC, 119 MV errors in I frame Past duration 0.766655 too large Past duration 0.761665 too large Past duration 0.711662 too large Past duration 0.721657 too large Past duration 0.746666 too large Past duration 0.726662 too large Past duration 0.736656 too large frame= 60 fps= 22 q=16.0 size= 1kB time=00:00:04.45 bitrate= 2.2kbits/s dup=0 drop=5 Past duration 0.701653 too large Past duration 0.756660 too large Past duration 0.766655 too large Past duration 0.701653 too large Past duration 0.696663 too large Past duration 0.751656 too large [NULL @ 0000000002e73400] RTP: missed 4 packets Past duration 0.716652 too large Past duration 0.681664 too large [h264 @ 00000000095b3160] error while decoding MB 20 23, bytestream -38 [h264 @ 00000000095b3160] concealing 119 DC, 119 AC, 119 MV errors in I frame Past duration 0.766655 too large frame= 69 fps= 20 q=15.0 size= 1kB time=00:00:05.01 bitrate= 2.0kbits/s dup=0 drop=5 Past duration 0.761665 too large Past duration 0.711662 too large Past duration 0.766655 too large Past duration 0.761665 too large Past duration 0.711662 too large Past duration 0.736656 too large Past duration 0.746666 too large Past duration 0.696663 too large Past duration 0.736656 too large Past duration 0.746666 too large frame= 79 fps= 20 q=15.0 size= 1kB time=00:00:05.66 bitrate= 1.8kbits/s dup=0 drop=5 Past duration 0.711662 too large Past duration 0.721657 too large [NULL @ 0000000002e73400] RTP: missed 4 packets Past duration 0.701653 too large Past duration 0.741661 too large [h264 @ 00000000095b3160] error while decoding MB 22 23, bytestream -48 [h264 @ 00000000095b3160] concealing 117 DC, 117 AC, 117 MV errors in I frame Past duration 0.766655 too large Past duration 0.701653 too large Past duration 0.711662 too large frame= 86 fps= 19 q=21.0 size= 969kB time=00:00:06.22 bitrate=1275.8kbits/s dup=0 drop=5 Past duration 0.766655 too large Past duration 0.701653 too large Past duration 0.696663 too large Past duration 0.766655 too large Past duration 0.746666 too large Past duration 0.711662 too large Past duration 0.766655 too large Past duration 0.761665 too large frame= 94 fps= 19 q=15.0 size= 969kB time=00:00:06.68 bitrate=1187.2kbits/s dup=0 drop=5 Past duration 0.651665 too large Past duration 0.721657 too large [NULL @ 0000000002e73400] RTP: missed 4 packets Past duration 0.746666 too large Past duration 0.741661 too large [h264 @ 00000000095b3160] error while decoding MB 25 23, bytestream -68 [h264 @ 00000000095b3160] concealing 114 DC, 114 AC, 114 MV errors in I frame Past duration 0.721657 too large frame= 99 fps= 16 q=18.0 size= 969kB time=00:00:07.15 bitrate=1110.1kbits/s dup=0 drop=5 Past duration 0.701653 too large Past duration 0.711662 too large Past duration 0.766655 too large Past duration 0.701653 too large Past duration 0.756660 too large Past duration 0.766655 too large Past duration 0.701653 too large Past duration 0.696663 too large [NULL @ 0000000002e73400] RTP: missed 8 packets Past duration 0.766655 too large [h264 @ 0000000009605500] error while decoding MB 23 21, bytestream -12 [h264 @ 0000000009605500] concealing 206 DC, 206 AC, 206 MV errors in P frame Past duration 0.761665 too large Past duration 0.621666 too large [NULL @ 0000000002e73400] RTP: missed 4 packets Past duration 0.766655 too large Past duration 0.761665 too large [h264 @ 00000000096b5b40] error while decoding MB 23 23, bytestream -46 [h264 @ 00000000096b5b40] concealing 116 DC, 116 AC, 116 MV errors in I frame frame= 119 fps= 18 q=16.0 size= 969kB time=00:00:08.35 bitrate= 949.7kbits/s dup=0 drop=5 [NULL @ 0000000002e73400] RTP: missed 4 packets frame= 126 fps= 18 q=15.0 size= 969kB time=00:00:08.91 bitrate= 890.4kbits/s dup=0 drop=5 [h264 @ 00000000096b5b40] error while decoding MB 23 23, bytestream -56 [h264 @ 00000000096b5b40] concealing 116 DC, 116 AC, 116 MV errors in I frame frame= 128 fps= 17 q=16.0 size= 969kB time=00:00:09.00 bitrate= 881.2kbits/s dup=0 drop=5 [NULL @ 0000000002e73400] RTP: missed 4 packets frame= 142 fps= 17 q=14.0 size= 969kB time=00:00:09.93 bitrate= 798.8kbits/s dup=0 drop=5 [h264 @ 00000000096b5b40] error while decoding MB 23 23, bytestream -39 [h264 @ 00000000096b5b40] concealing 116 DC, 116 AC, 116 MV errors in I frame frame= 150 fps= 17 q=14.0 size= 969kB time=00:00:10.49 bitrate= 756.4kbits/s dup=0 drop=5 [NULL @ 0000000002e73400] RTP: missed 4 packets [h264 @ 00000000096b5b40] error while decoding MB 25 23, bytestream -10 [h264 @ 00000000096b5b40] concealing 114 DC, 114 AC, 114 MV errors in I frame frame= 158 fps= 16 q=25.0 size= 969kB time=00:00:11.05 bitrate= 718.3kbits/s dup=0 drop=5 [NULL @ 0000000002e73400] RTP: missed 4 packets [h264 @ 00000000096b5b40] error while decoding MB 24 23, bytestream -12 [h264 @ 00000000096b5b40] concealing 115 DC, 115 AC, 115 MV errors in I frame frame= 174 fps= 17 q=18.0 size= 1874kB time=00:00:12.07 bitrate=1271.7kbits/s dup=0 drop=5 frame= 181 fps= 17 q=14.0 size= 1874kB time=00:00:12.63 bitrate=1215.6kbits/s dup=0 drop=5 frame= 183 fps= 17 q=-1.0 Lsize= 2240kB time=00:00:12.81 bitrate=1431.4kbits/s dup=0 drop=5 video:2123kB audio:113kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.189996% [libx264 @ 00000000059d00a0] frame I:3 Avg QP:15.47 size: 71706 [libx264 @ 00000000059d00a0] frame P:47 Avg QP:16.12 size: 20772 [libx264 @ 00000000059d00a0] frame B:133 Avg QP:16.67 size: 7378 [libx264 @ 00000000059d00a0] consecutive B-frames: 2.7% 1.1% 0.0% 96.2% [libx264 @ 00000000059d00a0] mb I I16..4: 1.3% 4.4% 94.2% [libx264 @ 00000000059d00a0] mb P I16..4: 0.1% 0.1% 0.0% P16..4: 91.8% 0.0% 0.0% 0.0% 0.0% skip: 8.0% [libx264 @ 00000000059d00a0] mb B I16..4: 0.0% 0.0% 0.0% B16..8: 25.0% 0.0% 0.0% direct:39.8% skip:35.2% L0:34.1% L1:61.0% BI: 4.9% [libx264 @ 00000000059d00a0] 8x8 transform intra:5.5% inter:30.1% [libx264 @ 00000000059d00a0] coded y,uvDC,uvAC intra: 96.6% 94.0% 79.3% inter: 42.2% 25.0% 1.5% [libx264 @ 00000000059d00a0] i16 v,h,dc,p: 9% 82% 6% 2% [libx264 @ 00000000059d00a0] i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 13% 46% 13% 3% 4% 3% 6% 1% 11% [libx264 @ 00000000059d00a0] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 20% 35% 7% 5% 7% 5% 8% 4% 9% [libx264 @ 00000000059d00a0] i8c dc,h,v,p: 31% 30% 28% 11% [libx264 @ 00000000059d00a0] Weighted P-Frames: Y:0.0% UV:0.0% [libx264 @ 00000000059d00a0] kb/s:1424.74 Here's the transcode log for when I try to play it from the web client: (server log also attached) http://192.168.1.113:8096/videos/d1bcb6de4124e31def037ec88f3ee35d/stream.webm?DeviceId=01697e56dc9e645cb2543b150ec7cacc29d06393&MediaSourceId=053122d1ec71cdbcffce1a2a7793f08e&VideoCodec=vpx&AudioCodec=vorbis&VideoBitrate=29872000&AudioBitrate=128000&MaxWidth=1920&ClientTime=635667900292354754&PlaySessionId=2d0cae29e6f043938b69a73784bcf870&api_key=1f071737179c4c0bb2db382c247f3495 {"Protocol":"Rtmp","Id":"053122d1ec71cdbcffce1a2a7793f08e","Path":"rtsp://192.168.1.113:7447/67f22897-e419-3645-ab79-a1745ece7f02_1","Type":"Default","Name":"053122d1ec71cdbcffce1a2a7793f08e","ReadAtNativeFramerate":false,"SupportsTranscoding":true,"SupportsDirectStream":false,"SupportsDirectPlay":true,"RequiresOpening":false,"RequiresClosing":false,"MediaStreams":[],"PlayableStreamFileNames":[],"Formats":[],"RequiredHttpHeaders":{}} C:\Users\Administrator\AppData\Roaming\MediaBrowser-Server\ffmpeg\20150331\ffmpeg.exe -fflags +genpts -i "rtsp://192.168.1.113:7447/67f22897-e419-3645-ab79-a1745ece7f02_1" -sn -codec:v:0 libvpx -force_key_frames expr:gte(t,n_forced*5) -vf "scale=min(iw\,1920):trunc(ow/dar/2)*2" -pix_fmt yuv420p -speed 16 -quality good -profile:v 0 -slices 8 -crf 4 -qmin 0 -qmax 50 -maxrate:v 29872000 -bufsize:v (29872000*2) -b:v 29872000 -vsync vfr -map_metadata -1 -threads 3 -codec:a:0 libvorbis -ab 128000 -af "aresample=async=1" -y "P:\~MediaBrowser\transcoding-temp\d42b9db41cefafff1be64543af891cc2.webm" ffmpeg version N-71182-g5cba529 Copyright (c) 2000-2015 the FFmpeg developers built with gcc 4.9.2 (GCC) configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libdcadec --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-lzma --enable-decklink --enable-zlib libavutil 54. 21.100 / 54. 21.100 libavcodec 56. 32.100 / 56. 32.100 libavformat 56. 27.100 / 56. 27.100 libavdevice 56. 4.100 / 56. 4.100 libavfilter 5. 13.101 / 5. 13.101 libswscale 3. 1.101 / 3. 1.101 libswresample 1. 1.100 / 1. 1.100 libpostproc 53. 3.100 / 53. 3.100 [h264 @ 0000000002c83340] RTP: missed 8 packets [h264 @ 0000000002c83340] error while decoding MB 15 22, bytestream -56 [h264 @ 0000000002c83340] concealing 169 DC, 169 AC, 169 MV errors in I frame Input #0, rtsp, from 'rtsp://192.168.1.113:7447/67f22897-e419-3645-ab79-a1745ece7f02_1': Metadata: title : 0418D623CE8B_1 Duration: N/A, start: 0.000000, bitrate: N/A Stream #0:0: Audio: aac (LC), 11025 Hz, mono, fltp Stream #0:1: Video: h264 (Main), yuvj420p(pc, bt709), 720x400 [SAR 80:81 DAR 16:9], 15 fps, 15 tbr, 90k tbn, 30 tbc [swscaler @ 0000000002c77fe0] deprecated pixel format used, make sure you did set range correctly [libvpx @ 0000000002ce3ea0] v1.3.0 [libvorbis @ 0000000002ce4ee0] encoder setup failed Output #0, webm, to 'P:\~MediaBrowser\transcoding-temp\d42b9db41cefafff1be64543af891cc2.webm': Stream #0:0: Video: vp8 (libvpx), yuv420p, 720x404 [SAR 404:405 DAR 16:9], q=0-50, 29872 kb/s, 15 fps, 15 tbn, 15 tbc Metadata: encoder : Lavc56.32.100 libvpx Stream #0:1: Audio: vorbis, 0 channels, 128 kb/s Metadata: encoder : Lavc56.32.100 libvorbis Stream mapping: Stream #0:1 -> #0:0 (h264 (native) -> vp8 (libvpx)) Stream #0:0 -> #0:1 (aac (native) -> vorbis (libvorbis)) Error while opening encoder for output stream #0:1 - maybe incorrect parameters such as bit_rate, rate, width or height Log.txt
×
×
  • Create New...