Jump to content

Search the Community

Showing results for tags 'encoding'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 15 results

  1. Hi emby Team, I testet as lot and want to describe a problem in detail that really keeps me away from using the emby app of my LG65OLED C7D. I already know that the emby app encodes all audio tracks that are not the first/default audiotrack of a mkv. But... emby also encodes the first/default audiotrack if this is Dolby TrueHD/Atmos. Why? and that leads to the/my problem: everytime the emby app starts a ffmpeg process to transcode a audio track (for the none default audio track or and thats a much bigger problem... for Dolby TrueHD Tracks) the video begins to stutter... plays for a few seconds than stocks for a few seconds and so on - til the end of the movie :-( ) because many of the 4K remuxes have a Dolby TrueHD/Atmos default track, they are unwatchable via the emby app. 1. the problem is reproducable everytime 2. the problem only exists with 4K material (UHD Remuxes) 3. it's not a problem of hardware limitation of the emby server (CPU is 70% idle, gigabit LAN, HDD...) 4. it doesn't matter what kind of audio is being encoded (Atmos, DTS, DD5.1, DTSMA, DTSHD...) 5. emby dlna plays fine those files because it's playing the files without encoding the audio summarized: audio encoding on 4k remuxes in any way leads to video stuttering! possible solutions: - stop encoding audio tracks other than the default (like DLNA does) or - make TrueHD tracks playable without transcoding (direct play/passthrough) or - fix the problem that causes the video stuttering when transcoding audio in 4K movies any questions? don't hesitate to contact me ;-)
  2. I've been waiting for this feature for a while now. I'm hopeful that it will improve video quality. and a setting for audio encoding preference would be very nice as well
  3. doffactory

    Hardware Encoding Issues (j4125)

    So I happen to have the new Asustor Lockerstor 4 NAS, with Intel Celeron j4125. Before I used to have a much weaker AS3202T though also with Intel processor. On both I usually use transcoding. However, since the hardware update, I am unable to use the hardware encoding on the j4125 CPU. Decoding works, however, encoding does not. Under the Transcoding I have enabled the following: Enable hardware acceleration when available: Advanced Preferred Hardware Decoders - [x] MPEG-2: VAAPI UHD Graphics 605 - MPEG-2 - [x] H.264 (AVC): VAAPI UHD Graphics 605 - H.264 (AVC) - [x] VC-1: VAAPI UHD Graphics 605 - VC-1 - [x] VP8: VAAPI UHD Graphics 605 - VP8 - [x] H.265 (HEVC): VAAPI UHD Graphics 605 - H.265 (HEVC) - [x] VP9: VAAPI UHD Graphics 605 - VP9 Preferred Hardware Encoders - [ ] H.264 (AVC): VAAPI UHD Graphics 605 - H.264 (AVC) - [ ] H.265 (HEVC): VAAPI UHD Graphics 605 - H.265 (HEVC) Transcoding thread count: Auto Transcoding temporary path: /tmp Enable throttling [x] Audio boost when downmixing: 2 H.264 encoding preset: medium H.264 encoding CRF: 22 Allow subtitle extraction on the fly: [x] As you can see, I am forced do disable the hardware encoders, as the video becomes extremely choppy, if played at all. As soon as I disable the hardware encoding, the video plays, but the encoding part of the transcoding happens with the CPU instead of the GPU. I tried to switch the settings from CPU decoding and GPU encoding, but no luck. I also tried to disable the subtitle extraction, no difference. Is there some known problem with the j4125, or is it just so "new" that it is not supported by emby or its ffmpeg? Any help is more than welcome!
  4. it is the latest beta, fresh install, not sure what to do. i intended to use my shield to convert my media to HEVC to save space using its supported hevc encoder. 14:43:13.366 embymc init function called 14:43:13.366 [hevc_mediacodecndk @ 0x29a8924d00] NdkEnc: is_rtk: 0 pix_fmt: 0 pixelFormat: 19 14:43:13.367 [hevc_mediacodecndk @ 0x29a8924d00] NdkEnc: Mime: video/hevc Size: 720x500 rc_mode: 1 rc_max_rate: 1180000 rc_buffer_size: 2360000 bit_rate: 200000 14:43:13.367 [hevc_mediacodecndk @ 0x29a8924d00] NdkEnc: Framerate: 24000 / 1001 14:43:13.367 [hevc_mediacodecndk @ 0x29a8924d00] NdkEnc: Profile: 8 Level: 512 14:43:13.367 [hevc_mediacodecndk @ 0x29a8924d00] NdkEnc: aspect: 1295 / 1296 14:43:13.367 [hevc_mediacodecndk @ 0x29a8924d00] NdkEnc: mediacodec_name: OMX.Nvidia.h265.encoder 14:43:13.388 [hevc_mediacodecndk @ 0x29a8924d00] NdkEnc: Failed to configure encoder; check parameters 14:43:13.389 Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height 14:43:13.397 Conversion failed!
  5. Hi, i bought a new LG TV (LG TV OLED65C7D). This TV is able to play as good as everything (h264,x265,wmv,divx,xvid) without the need of encoding anything. I managed to adjust the DLNA Profile LG SMART TV so that all content is now played without encoding. BUT... playing the same files via Emby LG Smart TV App the files are still being encoded altough thats not necessary :-/ Is there a config file analog to ...\config\dlna\user\LG Smart TV.xml that tells the app whether a file has to be encoded or not? Thx & greetz
  6. Hey Guys, I just bought emby lifetime and am building a new budget machine for it. I'm building it under the assumption that my GPU is the piece that needs to be the most powerful as it will handle my video en/decodes and the proc/mobo/mem need to be sufficient enough to run windows and emby. Specs: ASRock B450 Gaming-ITX-ac AMD Ryzen 3 2200G Quad Core Radeon RX570 12GB DDR4-2666 (4GB) + 8GB 120GB M.2 boot drive (same performance different size) 1TB,3TB, 3TB 7200 RPM Media Drives Media Background: While a significant portion of my media is 480p encoded with H264 and AAC audio future forward I will only be purchasing blurays to add to my digital collection and will be ripping them with a web optimized H.264 30FPS 8bit color, AAC audio (avcodec) setting with light NLMeans denoise filter. Questions: My Goal is 10 streams at 1080p or lower. Should I return the RX570 for: an RX580/590 - I figure extra the extra oomph and more ram from a stronger card will help me handle more simultaneous streams. It's only 10 bucks more. a 1660 - 10 series and 16 series seems to be recommended with this driver patch that allows unlimited simultaneous streams With Specs Like these, how many concurrent streams can I expect to handle and what could I do to improve it? @ @@Sammy @@lightsout
  7. maeffjus

    Raspberry Pi4 & NAS for Server

    Hi Guys, actually I'm running my Emby on a Windows-Server 2012 R2 with a Core-i7 which is from the 3 or 4-Series. But since this costs a ton of electricity, I'd like to change this to a more energy-efficient alternative. While the new Raspberry Pi 4 seems to be very powerful, could I use this as an alternative for transcoding? (If I'm abroad, I sometimes transcode FHD-content to my mobile devices, but I often use FHD to FHD) Can anyone tell me if the RPi4 has enough power? If not, what energy-efficient alternative do you recommend? Regards, Matthias
  8. McBoothertonEsq

    Choosing NVENC encode GPU

    I'm currently looking into making a 2 in 1 gaming + NAS system to power my downstairs TV, I plan to use an Nvidia GTX 690 in it for a while as the card has been sitting in my attic for about a year ever since I upgraded, but will at one point get a higher end GPU like a 1070, maybe Ti, or Vega 56 (unless the 11 series drops soon enough) for gaming as the 690s 2gb per GPU frame buffer is a choking point for almost any modern game. Then I could have the 690 in there as an encode/Physx card. If I go for the Vega 56 and select NVENC encoding I assume I won't have issues as Emby should just use the 690 for that. Thing is, if I get the 1070/Ti over the Vega 56 and choose NVENC for encoding, will I be able to specify which graphics card I want the encoder to use? I'd prefer for the 1070/Ti to be reserved for gaming and general display out while the 690 encodes whenever needed. I don't see any options in settings for selecting a different GPU, I imagine there's a config text file option for it but idk where to find it or how to change which GPU it'll use. Second, does the encoding GPU need to be connected to a display? Or can it just be used as an accelerator with no video out? Any help would be greatly appreciated. This seems like a promising alternative to Plex, especially as it's free to use features like hw encode (for the record I plan to donate if this becomes my permanent media server, had to sink $2500 into my truck recently so it won't be for a while).
  9. I encode all of my media before it goes onto the server so I'm wondering if there are any recommended settings for smooth playback on Emby both inside and out of network? Currently I'm using the settings below. Please excuse the format it's copied and pasted from my (plist) file. <?xml version="1.0" encoding="utf-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist> <array> <dict> <key>AudioList</key> <array> <dict> <key>AudioBitrate</key> <string>320</string> <key>AudioEncoder</key> <string>MP3</string> <key>AudioMixdown</key> <string>Stereo</string> <key>AudioSamplerate</key> <string>Auto</string> <key>AudioTrack</key> <integer>1</integer> <key>AudioTrackDRCSlider</key> <real>0</real> <key>AudioTrackDescription</key> <string>Unknown</string> <key>AudioTrackGainSlider</key> <real>0</real> </dict> </array> <key>AudioAllowAACPass</key> <true /> <key>AudioAllowAC3Pass</key> <true /> <key>AudioAllowDTSHDPass</key> <true /> <key>AudioAllowDTSPass</key> <true /> <key>AudioAllowMP3Pass</key> <true /> <key>AudioEncoderFallback</key> <string>AC3</string> <key>ChapterMarkers</key> <true /> <key>Default</key> <integer>0</integer> <key>FileFormat</key> <string>MKV file</string> <key>Folder</key> <false /> <key>Mp4HttpOptimize</key> <integer>0</integer> <key>Mp4iPodCompatible</key> <integer>0</integer> <key>PictureAutoCrop</key> <integer>1</integer> <key>PictureDeblock</key> <integer>0</integer> <key>PictureDecombDeinterlace</key> <false /> <key>PictureDecombCustom</key> <string /> <key>PictureDecomb</key> <integer>0</integer> <key>PictureDeinterlaceCustom</key> <string /> <key>PictureDeinterlace</key> <integer>0</integer> <key>PictureDenoiseFilter</key> <string>off</string> <key>PictureDenoiseCustom</key> <string /> <key>PictureDenoisePreset</key> <string>ultralight</string> <key>PictureDetelecine</key> <integer>0</integer> <key>PictureDetelecineCustom</key> <string /> <key>PictureHeight</key> <integer>804</integer> <key>PictureKeepRatio</key> <integer>0</integer> <key>PictureModulus</key> <integer>2</integer> <key>PicturePAR</key> <integer>2</integer> <key>PictureLeftCrop</key> <integer>0</integer> <key>PictureRightCrop</key> <integer>0</integer> <key>PictureTopCrop</key> <integer>0</integer> <key>PictureBottomCrop</key> <integer>0</integer> <key>PictureWidth</key> <integer>1920</integer> <key>PresetBuildNumber</key> <string>2016021100</string> <key>PresetDescription</key> <string>No Description</string> <key>PresetName</key> <string>Movies Dual</string> <key>Type</key> <integer>1</integer> <key>UsesMaxPictureSettings</key> <integer>1</integer> <key>UsesPictureFilters</key> <integer>1</integer> <key>UsesPictureSettings</key> <integer>1</integer> <key>VideoAvgBitrate</key> <string /> <key>VideoEncoder</key> <string>H.264 (x264)</string> <key>VideoFramerate</key> <string>Same as source</string> <key>VideoFramerateMode</key> <string>vfr</string> <key>VideoGrayScale</key> <false /> <key>VideoQualitySlider</key> <real>20</real> <key>h264Level</key> <string>Auto</string> <key>x264OptionExtra</key> <string>rc-lookahead=30:ref=4</string> <key>x264Preset</key> <string>medium</string> <key>h264Profile</key> <string>none</string> <key>x264Tune</key> <string>none</string> <key>x264UseAdvancedOptions</key> <integer>1</integer> <key>h265Profile</key> <string>none</string> <key>x265Preset</key> <string>veryfast</string> <key>x265Tune</key> <string>none</string> <key>VideoQualityType</key> <integer>2</integer> <key>VideoTargetSize</key> <string /> <key>VideoTurboTwoPass</key> <integer>0</integer> <key>VideoTwoPass</key> <integer>0</integer> <key>x264Option</key> <string>rc-lookahead=30:ref=4</string> </dict> </array> </plist> Thanks.
  10. So this feature is really nice. It helps playback start immediately. I am going to setup my mother and aunt on this for live TV but it poses one issue which keeps me from having them buy the lifetime. CPU power. Is there any change to integrate a feature for selecting quality on convert on the fly to a lower resolution so ffmpeg does not eat so much CPU power. Or is this a setting that can be changed in a file somewhere?
  11. Hi guys... I was wondering if there's any plans to make users on a server have the ability to set per library permissions. For example on my Music folder I might want some users to be able to stream/listen to the library, but not be able to download them. Others I might want the other way around. But at the same time. I may want them to not be able to encode/stream video to their devices but instead download the full file and play it locally. (Guests for example who are not in my network.) Where as another user I might prefer that they have the ability to stream or download video but have no download access to a single library. Basically I would like to see/have per library permissions for each user if possible. (Maybe adding group permissions might make more sense if you have to go down this road?) Hope that makes sense? If it needs further clarification or a flow chart or something let me know. Thanks! -Phantom
  12. https://github.com/MediaBrowser/Wiki/wiki/Transcoding
  13. Concept211

    Tweak or Add Encoding Options?

    Is it possible to add or change existing encoding/transcoding parameters when streaming a video via the web UI? I would like to try and tweak the lowest 720p option with a lower bitrate so that it can stream a little bit more reliably on my ISP's 1mb upload cap. I looked in the server config files and can't find anywhere to change it.
  14. It would be helpful if you could add the following streaming option to the Web UI inside the file: /%appdata%/MediaBrowser-Server/System/dashboard-uiI/scripts/mediaplayer-video.js options.push({ name: '720p - 1.0Mbps', maxWidth: 1280, bitrate: 1000000 });
  15. buddyweiser

    DVDFab 9 Converter problems

    I'm wondering if anyone has this problem or can offer any advice. I'm using DVDFab to encode foreign-only subtitles onto MP4 video files for movies such as The Wolverine, Elysium, and Captain Phillips. Here is the problem: DVDFab supports CUDA GPU to encode/decode video, however when I select the option and start a task, the "Encoding fps" drops to 8, then less than 1fps. On Software encoding, it never goes over 30fps and takes sometimes 5 hours per movie. Could this be an issue with my GPU? I have searched multiple forums and cannot find a solution to this issue so I thought I would bring it here where my questions are pretty much always answered Here is a shot of the settings screen.
×
×
  • Create New...