Jump to content

Search the Community

Showing results for tags 'direct play'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hello, First of all, I would to apologize if I posted this topic at the wrong community, but as of right now the LG webOS app is the only place I can reproduce this type of files. Also English is not my first language, so I'll try my best to explain the situation. I have an old Windows laptop working as a NAS connected via ethernet to a router, to which my LG B9 is connected also using ethernet cable. I'm using the lastest Emby app on the TV and the server is up-to-date. I am having problems watching 4K HDR remux files stutter free. I tried tonight and it started fine but after a f
  2. So, i want to buy the premium subsricption but first of course i test the Emby Theatre on my Xbox One X. And it is working execpt one function. There is no 4k HEVC direct play and of course because of that there is no HDR. I don't know what's wrong but my server Transcoding any 4K HEVC file because : The Video resolution is not supported. But why? Can anyone help me please? I attached my log files. Thanks. LOG1.txt LOG2.txt LOG3.txt LOG4.txt
  3. I'm running emby on Synology NAS (DSM 6.xx). I'm using iOS 14 Phone / iPad and iMac (Catalina) to play music. I would like to ask wether the lossless audio files are transcoded to be played or not. As far as I understand (see https://support.emby.media/support/solutions/articles/44001161688-ios) emby can direct play Flac only. ALAC / m4a is not listed. As far as I understand there might be a second bottleneck to overcome: the iOS device "normally" transcodes to AAC before playing. So does the embay-ios app follow this procedure? Or do I listen to hi-res lossless audio? (if my file is loss
  4. Hi, I would like to direct play a movie to my Chromecast Ultra but i can't.... I can't understand why because here https://github.com/MediaBrowser/Wiki/wiki/Chromecast, it says that MKV is supported by Chromecast, but when I try to play it it says "The media is compatible with the device regarding resolution and media type (H.264, AC3, etc.), but is in an incompatible file container (.mkv, .avi, .wmv, etc.). The video will be re-packaged on the fly before streaming it to the device."... Do you know why ? log.txt embyserver.txt
  5. Hey guys Recently moved to Emby from Plex. You guys did a really great job with that, I really love it and prefer to Plex which is not stable enough in my opinion... Though I'm missing one important feature that Plex has : Favorising direct play / direct stream while you can also select "auto" setting. This means that if Direct Play / Direct Stream is not possible for a user connected to the server (due to slow internet connection, or invalid format etc...) then the Player will automatically select the best quality available for this user. BUT it will always favorise Direct Play
  6. I have a .STRM file and have disabled transcoding for the user. In the dashboard the content shows up as direct played but it is evident this is not happening because there is massive stutter. I looked in the log files and Emby is still using FFmpeg to transcode it even though it should be direct play. I am using Emby Web Client on Chrome.
  7. I have the Emby app installed on my Shield which plays my local files easily, including my 4K files with HD audio as I direct stream. I have installed a remote server using my cloud provider to stream my media. Because it is a new server, whenever I choose it, the "trial" warning comes up so I would have to unlock / purchase. My question simply is this: Using the app as it is (trial), when I play a 4K file, it automatically transcodes (stats for nerds shows this as well as saying maximum bitrate has been exceeded). If I unlock this app, will it then direct play as with my local file
  8. mwe21975

    Playback Reporting

    I check my server dashboard often. Most times I check it, it shows my users (friends) watching content via Direct Play which is great. Once in a while it will be Direct Stream and very seldom transcode. I have my library set up in a way to direct play ( smaller file sizes etc) However when I check this Playback Reporting, it looks like most everything is Direct Streaming? Unless I am reading it wrong. Im just wondering why when I check my dashboard it says everything Direct Plays but this Playback Reporting looks like everything Direct Streams? Screen Shot attached. Thanks
  9. Hi, I'm an Emby Premiere customer, currently experiencing an issue with playback on Apple TV. Playback of Direct Streaming media (no transcoding) on Apple TV (4th gen) is not working correctly. Video pauses for ~10ms every ~10 seconds. Audio is unaffected. This is happening on 4.1.0.23 in an iocage running on FreeNAS 11.2-U3. It was also happening on 4.0.0.2. I updated to 4.1.0.23 yesterday, but the problem persists. This appears to be happening due to repeated 'HTTP Response 204 messages in the logs. I should mention that this server has been running flawlessly f
  10. I've found an unusual issue. I typically name my H.264 files as .M4V. Using that extension, with a stock multi-track movie (2 chan HE-AAC as the first track and AC3 5.1 as the second), it will default to the stereo track, and only Direct Stream the 5.1 track. If I rename the file to a .MP4 extension, it does DirectPlay without issue and auto-selects the 5.1 track without issue. The info indicates it is doing Direct Stream with M4V due to the container. I've used M4V on many many servers, with this audio setup and none had an issue with the container/codec setup. I'm not sure if this is by
  11. Recently tried to play some Music vids i have. Using my local home wifi network. The app tries to play the vid and does so, but it starts/stops every sec, stutters continuously, and the audio is also start/stop. They are mp4 or mkv files H264 with AAC audio. Direct Play. (when i switch Quality to a lower setting than the files bitrate, to force transcode, it plays fine.) The vids that have the issues are noted as "AVC1". (Though, strangely, a couple other vids I have that are labeled the same codec tag play fine) App version 2.9.92 All vids play fine with older app
  12. Hey All, I've got a ChromeCast that has jerky playback because my server (SynologyNAS) can't handle transcoding, but Direct Play works perfectly! I read some threads that say the Folder Sync plugin can transcode in the background and produce a version suitable for the ChromeCast and this will be selected automatically when I go to play it... but it doesn't am I missing a step? Folder Sync is setup, with a ChromeCast profile pointed to a general folder '\\Media-ChromeCast' I've selected the media in the WebApp, gone to sync, selected the new profile = General and quality = High The
  13. richwphillips@yahoo.com

    Audio Codecs For Direct Play

    I'm curious as to the best audio codecs to use for my video files to have Emby direct play them on my Roku Ultra. At the present time, my Roku is connected to my TV via HDMI. I hope to add a home theater setup later that will be able to handle surround sound. For now, my videos are h264 or HEVC and mostly in mkv containers. Many have AC-3 5.1 though a growing number have AAC 5.1 for audio. I've noticed on my Emby dashboard that when I'm playing these files, the files that have AAC 5.1 show "Direct Playing" on Emby while the ones with AC-3 5.1 always show transcoding. I've tried converting just
  14. It would be great if the Chromecast Ultra profile would be updated to allow direct playing of VP9, Opus, and mkv/webm containers. They all definitely work, as I can direct play them with all transcoding turned off. The reference VP9 encoder (libvpx in ffmpeg) pushed out an update in October that allows for much faster encoding than before, making VP9 a useable codec for me (and others). All of those codecs and containers are open and freely licensed as well, which is a great thing to support. Also, VP9 + Opus + webm is directly playable in Chrome, Firefox, and Opera (as well as Edge if an expe
  15. SkippyJohn

    Direct Play of Live TV stops

    Direct play of Live TV consistently stops at around the 35 minute mark and drops back to the guide. This has persisted over the last few Emby Theater (UWP) and server releases. Latest test done on UWP 1.1.158 and Windows Server 3.2.32. If I set the quality at 10Mbps and force transcoding, streaming of live TV seems to work fine (longest test run to 58 minutes).
  16. Hi ! I have a screen attached to a Chromecast v2. I have a Raspberry Pi 2, with Emby server with DLNA support. From my iPad, with the Emby official application, I can stream all my movies. But, for each video, there is transcoding, my CPU is > 99% even for videos that don't require transcoding because the Chromecast v2 support it. If I use a simple iPad application to play a DLNA video to my Chromecast (without any transcoding), I can play the same video with less than 5% of CPU usage. So, I suppose this could be fixed if I create a ChromeCast profile to skip some suppo
  17. Hi all, Redshirt explained something about the different video play methods in another thread, which explained a lot the me: Transcoding will occur on all the mobile clients if they don't support the codec/container of the source video, or they can't access the media directly. Transcoding is a necessary evil. Streamcopy is a form of transcoding, it means the device supports the stream, but not the container. It's just not as cpu intensive as a full transcode. Direct play and direct stream are two different things. Direct play means that the client can access the f
  18. [uPDATE] -> It works if i browse the DLNA server and play content from mede8er! Now testing with 8player client.... [uPDATE2] -> I created another custom profile for 8player client and it did work like a charm! [sOLVED] Hi Guys, I created a custom profile for my mede8er player but so far could NOT get the direct play functionality working, it keeps converting my flacs to mp3 and then stream to mede8er. Is there any way to change default behavior from streaming to direct play for all files? I edited default.xml, added flac into direct play sections, but every time i restart
  19. Roku app is severely dated, its transcoding even when the setting of the server says not to do so. Mp3 @ 320kbps are transcoded down to 128kbps which isn't needed as Roku can play@ 320kbps without issue. Trancoding to and from and format has serious delays and dropout when streaming over the internet (lag time in the transcoder I believe). Natively supported codecs are being transcoded and do not need to be in Roku app, actually causes degradation of video and audio when its not needed. Video — H.264/AVC (.MKV, .MP4, .MOV), on Roku 4 only: H.265/HEVC (.MKV, .MP4, .MOV); VP9 (.MKV) Aud
  20. grizlyadams

    Question about direct play

    Hi, If i'm on the same LAN and have access to the same folders that Emby has, why do my files not direct play when I watch them via the browser Also, how do i check that Emby for WMC is playing direct play? Emby server is running in a docker on unRaid. thanks Griz
  21. Hey all, so for some reason Emby (Kodi) isn't direct playing/streaming my blu-ray folders and is transcoding them instead. I've also tried the Windows Emby Theater app, which won't play blu-ray's at all (it just hangs at the spinner after selecting to play for 1 minute), but will play all of my other files. I've attached the ffmpeg log and a section of the server log, however before I attach the full server/kodi logs, is there anything I need to censor? I'm seeing api keys for the websocket, my remote address, etc... 2016-12-01 13:13:23.2336 Info Main: Emby Command line: /usr/lib/emby-s
  22. neonko-sensei

    direct play unable to connect to smb

    I'm encountering difficulty getting the Kodi add-on to direct play files from an smb share. configuration: RPi3, Kodi 16.1, Emby add-on 2.2.32 recent related threads: 1, 2, 3 Here's the relevant log excerpt: 01:48:18 18909.144531 T:1206289392 NOTICE: EMBY.playbackutils -> Play called. 01:48:18 18909.164062 T:1206289392 NOTICE: EMBY.playutils -> Verifying path: smb://server/public/movies/5 Centimeters per Second/5_Centimeters_Per_Second.mp4 01:48:18 18909.181641 T:1206289392 NOTICE: EMBY.playutils -> Failed to find file. 01:48:18 18909.181641 T:1206289392 NOTICE: EMBY.playuti
  23. Now that Channel mapping is supported in the internal live TV implementation, I made the switch today from NextPVR. I use QAM for cable so NextPVR was my only option prior to the most recent update. NextPVR always transcoded when I used it, so I always ended up putting the direct stream address from the HDhomerun prime into my player software (MPC-HC) to avoid transcoding. Not the most glamorous solution but my streams remained direct. To my surprise, Emby's internal implementation is also transcoding live TV streams. Bandwidth is not an issue. Is there a setting somewhere where I can
  24. Hi, My android tv just recently updated and now all my movie files that encoded x265 are now all being transcoded during playback whereas before they were all direct play. Any ideas why this is happening? Log attached. log.txt
  25. When playing a movie in some browsers (mainly Chrome) if res/bitrate menu is pulled up and the account is set to absolutely no transcoding the movie will stall or crash if the bitrate/resolution is changed. Initially it will show "Direct Play" but once change "Direct Play option disappears. The next picture will show that "Direct Play" disappears once it has initially changed to anothe Bitrate/Res. Granted sometime depending on browser you are able select a bitrate/res higher then the file and it will go back to "Direct Play" but lots of times it will just crash until transcoding is t
×
×
  • Create New...