Jump to content

Search the Community

Showing results for tags 'bind'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support


  • Emby Blog


There are no results to display.

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...

Found 3 results

  1. My server has 3 NICs. By directly editing "/var/lib/emby-server/config/system.xml" to look like this: <LocalNetworkAddresses> <string></string> <string></string> </LocalNetworkAddresses> I am able to access the server on my main network at and on my guest network at And as I hoped, I am not able to access the server from the 3rd network at This almost does exactly what I want it to. Except the Easy Pin Codes only work on the 172 network. On the main network (172): I am able to log into all accounts using the full password OR the Easy Pin Code.On the guest network (10): Again, I am able to log into all accounts using the full password. But I cannot log into any of the accounts using the Easy Pin Code. It doesn't seem to matter which order I have the networks listed in the system.xml file. I get the exact same results. This behavior is also true when logging into account directly on the server or when accessing the server from another machine. Am I missing a setting that allows accounts to login using the Easy Pin Codes on all networks the server is binded to? After reading the "Enable in-network sign in with my easy pin code" check-box description; is it possible the server thinks the 10 guest network is outside my home 172 main network and this is why the Easy Pin Codes do not work? Server: Emby Version Linux Mint 17.3 Main Network: Guest Network: 3rd Network: Accounts: Terrel.User - Pin and Full Password Guest.User - Pin and Full Password Hieroglyph.Admin - No Pin Setup. Full Password server-63652070097.txt
  2. There is wrong local network address in the Dashboard, the local address is the the same as the public ip-address. I've attached a screenshot. I would like to have an option to explicitly specify network interfaces to whom Emby should bind. As well as ability to completely disable binding to unnecessary interfaces.
  3. Hello Again. When trying to use the BIND TO IP feature I'm having trouble connecting to it via external networks. - Internal connections seem fine. - If I disable the bind, both internal ad external work fine. The message that appears in browser is only: "Bad Request (Invalid host)" Nothing shows up in logs.. even with debugging mode ON. Funny fact: My laptop (used only as client) has in it's HOST files an entry telling my local emby server IP when looking for the external address. I do that to avoid NAT loopback here at home. "What's so fun?" - When I use the local IP in browser and https port... it lets me connect (with just a ssl warning). If I write the external domin name (that should do the same result), it throws me that error, too. It's almost as if when Emby has IP BIND, it won't like being connected via domain name UPDATE: Using http port with domain name also throws that error. Really not related to HTTP/HTTPS, but instead connecting via domain name.
  • Create New...