Jump to content

Search the Community

Showing results for tags 'XML'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 29 results

  1. hi, using emby 4.0.2 and using the xtream-editor service to sort my M3U + XML (EPG) from them. But emby is not able to get the XML correct, Error Log: 2019-01-19 09:21:02.886 Info App: xmltv path: https://xtream-editor.com/en/get/epg/ID 2019-01-19 09:21:02.886 Info App: Downloading xmltv listings from https://xtream-editor.com/en/get/epg/ID 2019-01-19 09:21:02.886 Info HttpClient: GetTempFileResponse url: https://xtream-editor.com/en/get/epg/ID 2019-01-19 09:21:04.067 Error App: Error adding metadata *** Error Report *** Version: 4.0.0.2 Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3 Operating system: Unix 4.4.59.0 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 2 Program data path: /config Application directory: /system System.Xml.XmlException: System.Xml.XmlException: Root element is missing. at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.ParseDocumentContent() at System.Xml.XmlTextReaderImpl.Read() at System.Xml.XmlReader.ReadToDescendant(String name) at Emby.XmlTv.Classes.XmlTvReader.GetChannels() at Emby.LiveTV.Listings.XmlTv.XmlTvProvider.GetChannels(ListingsProviderInfo info, CancellationToken cancellationToken) at Emby.LiveTV.EmbyTV.GetEpgChannels(IListingsProvider provider, ListingsProviderInfo info, Boolean enableCache, CancellationToken cancellationToken) at Emby.LiveTV.EmbyTV.AddMetadata(IListingsProvider provider, ListingsProviderInfo info, List`1 tunerChannels, Boolean enableCache, CancellationToken cancellationToken) at Emby.LiveTV.EmbyTV.GetChannelsAsync(Boolean enableCache, CancellationToken cancellationToken) Source: System.Private.Xml TargetSite: Void Throw(System.Exception) at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.ParseDocumentContent() at System.Xml.XmlTextReaderImpl.Read() at System.Xml.XmlReader.ReadToDescendant(String name) at Emby.XmlTv.Classes.XmlTvReader.GetChannels() at Emby.LiveTV.Listings.XmlTv.XmlTvProvider.GetChannels(ListingsProviderInfo info, CancellationToken cancellationToken) at Emby.LiveTV.EmbyTV.GetEpgChannels(IListingsProvider provider, ListingsProviderInfo info, Boolean enableCache, CancellationToken cancellationToken) at Emby.LiveTV.EmbyTV.AddMetadata(IListingsProvider provider, ListingsProviderInfo info, List`1 tunerChannels, Boolean enableCache, CancellationToken cancellationToken) at Emby.LiveTV.EmbyTV.GetChannelsAsync(Boolean enableCache, CancellationToken cancellationToken)
  2. Hi everyone. I use TinyMediaManager to do all of my metadata. I happen to move my files around a lot based on my own organizational madness, lol. This would KILL Emby's collections method. I switched over from Plex a few days ago and this was maddening because I was used to using tags. So I wrote an export template for TinyMediaManager that exports a list of movies in xml form. I wrote my template to conform to Emby's collection.xml scheme and placed the xml in a "CollectionName [boxset]" folder in the Collections folder. I was pleasantly surprised to find that it worked. So, I can rearrange my files at will, use whatever folder and naming scheme that I wish, replace files with better quality rips, re-tag or rename, or pretty much do whatever i want. I just thought that I'd share my methods for people in the same situation. I have several MoviesFolders though, including a folder containing all the movies that I haven't watched yet. There's also a folder of movies that I consider temporary residents on my hard drive. TinyMediaManager keeps it's export templates in a folder named "templates" in the main program folder. In this folder, I had to create a folder named "EmbyCollectionXML". In that folder, I need 2 files. I need a "template.conf" file and a "list.jmte" file. TinyMediaManagerFolder\templates\EmbyCollectionXML\ In the conf file I needed the following: name =EXCEL list type=movie list=list.jmte extension=xml description=This template exports a valid Emby collections.xml file In the list.jmte I needed the following: <?xml version="1.0" encoding="UTF-8"?> <Item> <LockData> true </LockData> <LocalTitle>Collection Title</LocalTitle> <DisplayOrder>PremiereDate</DisplayOrder> <CollectionItems> ${foreach movies movie} <CollectionItem> ${foreach movie.mediaFiles mediaFile} ${if first_mediaFile}<Path>${mediaFile.path}\\${mediaFile.filename}</Path>${end} ${end} </CollectionItem> ${end} </CollectionItems> </Item> This template exports an xml that writes the path for every one of your movies inside a CollectionItem. In TinyMediaManager, I simply filter the list by tags or by "datasource" or by whatever I want, then I export the list using my template. Open that xml and change "Collection Title" to whatever the name of my Collection will be. Rename the xml to "Collection Title.xml" Create a folder inside your Emby Collections folder: \Emby-Server\programdata\data\collections\Collection Title [boxset]\ Place your xml in that folder. I put a folder.jpg in there too for my collection. I refreshed my Collections in Emby and BOOM: There it was. I don't know if this will be helpful for anyone else, but that's how I do it for my custom collections that plugins might not pick up and to deal with me moving stuff around occasionally. It's best for big collections or random custom collections. Oh, and the reason I can't just filter by tags on the movies screen is because I'm using the Tizen version of Emby client on a Samsung Smart TV. That means if I filter and there aren't enough movies, I can't get back to that "Filters" button. It's been discussed in another thread.
  3. Hey all! I am new to EMBY (from Plex) and have been using it for the past few days totally fine! I have an IPTV M3U setup which is my main tv source now, and I tied in their XML to get all the channel data. It worked great for a few days and now the guide is completely empty. I spoke to a friend who told me I had to fetch/get the new data. I went to their site and downloaded the XML file to my computer and pointed Emby to this xml file on my machine. I refreshed the Guide Data and just nothing appears! I have the full channel list, but no actual show information in the timeline guide. I thought that if I tied in the XML feed url in emby, it would just always pull in the recent show information if I 'refreshed guide data'. But it no longer works? Can anyone help? Sorry this is coming from a general noob and I need any help I can get!
  4. kanipek

    EPG123 - Now provides XMLTV data

    It's in beta testing at the moment. If you are frustrated with somewhat complicated setup of the various XLMTV programs out there or perhaps you would like a GUI? I highly recommend EPG123: http://epg123.garyan2.net/ The beta is discussed here: http://www.thegreenbutton.tv/forums/viewtopic.php?f=99&t=11525 The primary focus for EPG123 has been getting reliable, accurate data into WMC and it does this very well and very easy. He has also built some channel management stuff for WMC in this beta for those that are still using it. Take a look and see what you think, if you like it buy the guy a beer, coffee or chocolate.
  5. Hi, I use XML files (xmltv.xml) generated using the zap2epg python script to map my channels. It works great for all channels except I'm running into an issue with ABC EPG data. It seemed to be working fine, but it appears that something in the XML file for ABC, maybe it's a special character that is causing a problem with SQ lite and the library.db file, I don't know. I have attached the xmltv.xml and embyserver.txt files. I pulled out just what I believe should be needed. When looking at the guide through the Emby client, doesn't matter if I'm using the Fire Stick TV, my phone app, or doing it on the server, for ABC it shows guide data properly all the way up to and including Jimmy Kimmel Live that starts at 11:35PM on 11/1/18 and ends at 12:37AM on 11/2/18, but then it shows nothing after that. It just shows <No Program Data Available> or blank depending on the client being used. All my other channels, and I have 45 Channels from HDHomerun Premium, and 30 OTA channels, guide data works fine. The EPG data after Jimmy Kimmel Live clearly exists in the xmltv.xml file, and I can't figure out what's wrong with it. The only thing I can think of is that there is something in it that SQ lite does not like, so when it imports that data into the library.db file, it messes up the EPG feed for ABC, and once it happens it is broke for good for that channel. I thought I could just shutdown the Emby server and rename the library.db file, and that would fix it, but I tried that once and it didn't, so I ended up completely uninstalling/reinstalling the Ember server to fix it... but at that time I had no data at all showing up for ABC, so I didn't really have any information to go on for root cause. I just did the uninstall/reinstall last night, and it looked like it fixed the problem because EPG data for ABC was showing up just fine, or so I thought. I realized earlier today that it was only showing guide data up to and including Jimmy Kimmel Live tonight, and that was it... the problem has returned after that. I appreciate you looking at this data below, and log file, and any insight you can provide to the root cause and permanent fix. Thanks in advanced. Brady embyserver.txt Sample_xmltv.xml
  6. Aussiedroid

    Actors Metadata not Refreshing

    Hi All, I'm not sure if this may be a bug or not (happy to provide logs if needed), but my actors metadata is not refreshing/displaying after running the Refresh People scheduled task. Images seem to be working fine, but not the metadata. I understand that these are now stored in the database from reading another post & no longer in the metadata folder, but I have mine as xml in the People folder along with the images. I have the Emby XML plugin installed to support (I assume this is needed?), but the only way I can seem to get these to display is doing a search from within Emby Theater to find missing metadata on an actor by actor basis. I assume 'finding missing metadata' is reading the xml & not scraping new data, but I cannot be sure without some further testing. Is there any way I can refresh these so they all display without having to do a manual refresh on each individual actor? or is legacy xml support just not viable anymore for actors? If it is not, is there a way to refresh all in the new method/format? Would really love not to loose the large number of actors metadata I have already sourced! As always, thank you, AD
  7. Hi, I have a music video folder in my library, this contains folders for the artists with the video files in it. No I have enabled the nfo and the xml reader for this folder: So far I've created a folder.xml file for the artist metadata (with LocalTitle, SortTitle and Description in it), but as I'm trying to move to nfo files, I enabled also the nfo saver for music videos: While this works without problems for the video files, there is no nfo created for the artist folder, even if I edit and save the metadata. So this is, what a folder might look like: As you can see, no nfo for the folder, only the old xml file. But when I enter the metada editor in the emby web client, I can edit and save the data, but still no nfo file is created. Also, in the wiki there's nothing about the file names for (artist) folders nfo files, at least I couldn't find something. So what would be the right name for an artist folder nfo file? Also, does anybody know a tool for creating the metadata (nfo files) for music video files, as emby is really bad at automatically creating these (tried with one folder, artist Army of Lovers, video file Crucified (1991).mkv it created metadata for a comletely different artist and song (something with crucified in it's name) from 2003. It could be much easier, if the artist could be read from the tags in the video file (just as it is already done with title, genre and year)... Ciao, Alfred
  8. Hi, I'm creating all metadata by myself, I used to use MetaBrowser but now switched to EMM. So now, I've changed from using movie.xml files to movie.nfo files. For 3D movies, I have a tag <format3d> in the xml file (HSBS, HTAB, etc) that ws auto created by MetaBrowser, which works with xml files. But if I insert the same tag into the nfo file, it seems to be ignored, the server doesn't show that the file is 3D, the Format3D field in the information is empty and I have to edit the information in emby manually. Is this a bug or is there a different 3D tag for nfo files? Thanks & Ciao, Alfred
  9. Hi everyone, Currently using Version 3.2.26.0 (had to revert back from Beta's that were doing weird stuff with rendering the dashboard) Not sure if anyone else has had this by Emby seem to no longer be interested in reading my MetaBrowser .xml files that are in my Movie and TV directories, I reckon one of the last Beta's may have had a funny turn but I have some content that was all fine before but now no longer have any details and because they are not on IMDB etc... there's no online content to pick up. Is Emby no longer reading xml's by design? Do I need to switch to .nfo's or do I need to take some drastic action with the database? Any help muchly appreciated. Andy.
  10. Emby no longer reads metadata from a xml file? Only nfo files can be used now? This has changed sometime in the last month I think. If you go to Server Manager > Library > Metadata and locate Metadata Savers option, only nfo is available now? This is no good, where did the xml option go? The main reason I choose to go with xml is Media Center Master creates the metadata in xml. I like that because I can manipulate the synopsis for example: "Former cop Brian O'Conner is called upon to bust a dangerous criminal and he recruits the help of a former Miami street racer who has a chance to redeem himself. Parental Rating Summary: MPAA Rating: PG-13 Sex & Nudity: 12 Violence & Gore: 25 Profanity: 1 mouthed and 1 muffled F-word, 2 obscene hand gestures, 3 sexual terms, 38 scatological terms, 24 anatomical terms, 30 mild obscenities, 1 religious profanity, 1 religious exclamation Alcohol/Drugs/Smoking: 1 Frightening/Intense Scenes: 2" as opposed to the overlong: "Florida street racer Tej (Ludacris) is looking for a driver and calls Brian O'Conner (Paul Walker) to a race. Brian is an ex-cop who has the hottest car now. He races against Suki (Devon Aoki), Orange Julius (Amaury Nolasco) and Slap Jack (Michael Ealy) and wins. The police arrive and give chase, capturing Brian. Agent Markham (James Remar) and... ON AND ON AND ON FILLING UP MY SCREEN" Can this be fixed or put back the way it used to be please? Please allow xml metadata files to be read or allow us to choose the type of synopsis is displayed.
  11. thespot84

    no guide info

    I have an HDHR T1 that required WMC and serverWMC to get running in Emby. I can currently browse the channels directly and watch them via chromecast on my tv, which is awesome, however I cannot get either Schedules Direct or zap2xml to populate my guide, it shows all my channels, but there's no program data, and the channel mapping list is blank. I succesfully downloaded xml data from tvguide.com, so I know the data is there, but even pointing emby to that file on my server doesn't fix anything. Any help is very much appreciated. Log.txt
  12. JoshFink

    XML Saver Plugin

    Hello, I know I'm probably missing something extremely simple here but where is the XML Saver plugin? I remember it was there but I don't see it anymore. Thanks Josh
  13. I remember I could edit a movie's last played date to anything i like, but I can't seem to find that option anymore. Has it been removed? Or is it because I use .xml instead of .nfo for my metadata?
  14. CBers

    Change from XML to NFO

    As it seems that XML support is dying out in Emby, what is the best way to change over to NFO support ?? Do I change the METADATA settings to use NFO, stop EMBY, delete all XML files, start EMBY and run a LIBRARY scan ?? Thanks.
  15. So, I was looking around the Plug-in page on my server just to see what was new and I saw the Xml Metadata plug-in. A while back, I decided to use NFO when I could - but not completely sure why and I am open to changing. So, I am curious about this plug-in. Specifically 2 questions: 1. How is this different than picking "Emby Xml" as a metadata saver and prioritizing it over my NFOs? Specifically, what does the plug-in do that Emby doesn't do already? 2. I had to have chosen NFO for a reason. Maybe because it would integrate with other tools/platforms? Regardless, my question is why would I pick one format over the other?
  16. Happy2Play

    Taglines issue

    Emby is not reading taglines written by MCM and doing a none or local refresh removes taglines from xml. And doing a refresh isn't populating them. Can't get Identify to populate it either. If I manually enter Tagline in Metadata Manager they stay in metadata. Example of tag from MCM <Tagline>Ted is Coming.</Tagline> <Taglines> <Tagline>Ted is Coming.</Tagline> </Taglines> Example written by Emby <Taglines> <Tagline>Ted is Coming.</Tagline> </Taglines> Started looking at this around 17:30.
  17. I'm running into an issue scanning my library. I typically scrap my data with Media Center Master...with the following formats checked. I'm attaching file examples. hmm odd that i can't upload NFO files. server-63580784722.txt 03X05 - The Usurper.xml 03X05 - The Usurper.zip
  18. I've run into a problem with the metadata that is stored in the individual TV Series files - every single one of them is just a blank XML. Checking timestamps, all of the files were last modified on June 12th (about 3 weeks ago), but I cannot confirm that the files had any content at that time. The last time I actually looked them was 2 months ago when I last tried to organize my newly recorded TV episodes. They were definitely not blank at that time. I don't remember specifically changing anything at that time that would have forced a refresh of the metadata. The individual episode XML files are fine, as are the xml files for my movies. It is just the TV Series that are affected. This has not affected the functionality of MBC, Theater, the Roku app, or the Android app. All have shown the appropriate metadata for every TV Series, however, my script that helps me sort and organize the metadata relies on that file to identify the series id's, so I'm wondering if there is a simply way to fix it for every TV. I did manage to find a workaround to force it to update by deleting the empty Series.xml and manually refreshing the metadata from the Metadata Manager (this doesn't work if I don't delete the existing empty series.xml first), but I'm hoping there is a better fix. Is there a setting or it there something else. Given the fact that the metadata is cached somewhere (since all of the Apps & the metadata manager still showed the correct metadata), is relying on the individual XML files a mistake?
  19. Hi, can some one help me? - Is there a way to media browser to import the metadata from a ".xml", if so, how would it be? (I need this becouse I had organized my movie files to Media Browser 2.0 a long time (in 2011) ago and I'm from Brazil, so I need information in Portuguese, and I made all the work back then , to do all again will be a pain. - Another question, supose my movies are on the "C:\Movies\" Folder, but some time from now i cange it to "D:\Movies" or under an server, how can I mantain the same metadata's? I don't want to loose all the work. Thank you very much
  20. Smitty018210

    Movie.xml & Auto Boxsets

    Just a quick questions...I decided to use this plug-in and moved away from the old box sets folder structure. So far only a few have showed up, and from what I found from searching the forum is that probably because of the old Movie.xml files. Some of the ones I have are from a number of years ago. Do need to manually refresh each movie, or is a better option for this to work faster? Thanks guys.
  21. MB-3.0.5434.27057 MCM-2.12 can media browser amend movie.xml files created by MCM generally? it seems that mb is unable to add TmdbCollectionName and TMDbCollectionId to movie.xml created originally by MCM steps to reproduce. 1. fetch movie with MCM (folder and files renamed to standard, movie.xml created) 2. copy movie into MB collection/rescan library. 3. MB is not aware that film is member of tmdb collection, no tmdb collection info in webclient or movie.xml alternatively a. delete xml from movie and rescan b. xml with tmdbcollectionid now present. anyone know of an alternative program that is good at identifying movie folder names/movie content, subtitles etc and renaming (whilst deleting non movie content and not creating a movie.xml that can trip up mb)?
  22. I want to scorch the earth with all XBMC media knowledge and import the info from Media Browser. I only use XBMC for Pseudo tv in the living room. I use Media Browser everywhere else, but I can't for the life of me figure out how to get my xml/nfo data exported from Media Browser and import it into XBMC. I can find the opposite instructions, but even when I remove my movies from XBMC and clean the library, every time I add the movies folder back and set the scraper to scan locally it always re imports my old XBMC metadata. I have options set in the Media Browser web ui to save metadata as an xml and nfo, but it doesn't appear to have a manual back up mode, and I can not locate any nfo files (hidden files shown) from either XBMC, or Media Browser within the movie folders themselves. In a nut shell I want to erase my XBMC metadata from my movie collection and replace it with the metadata from Media Browser and continue to use Media Browser to look up and save the metadata in the future in XBMC. I apologize if this has been explained multiple times. Asking Google the right question on this has been difficult. And thank you for any and all help!
  23. jhs39

    ANSWERED XML vs XBMC

    There is now a choice between two different meta-data formats--is there an advantage to switching from XML to XBMC?
  24. MB3 currently doesn't support the following folder structure... [\org{0, n}] [\artist\{0,1}] [\org {0,n}] \album where org=organisational subfolder {0,n}= zero to many instances []=optional Could such support be added, or alternatively could an xml tag/file be recognised by mb3 to treat organisational folders as organisational and NOT as artists/albumartists. eg M:\Music\Soundtracks\Blade Runner\Tracks.mp3 M:\Music\Soundtracks\Top Gun\Tracks.mp3 M:\Music\Soundtracks\Jungle Book\Tracks.mp3 Soundtracks is detected (shown in dashboard) as an albumartist and artist.xml is placed on filesystem thanks for considering.
  25. RedStripe

    Music Videos missing movie.xml

    1 issue and 1 question. Server Version 3.0.5267.16902 Music Videos file structure: Music Videos\ Artist\ Video1\ track.mp4 Video2\ track.mp4 1) ****movie.xml is not being created for Music Videos. This results in red warning icon being displayed. I have refreshed the Music Videos collection...no joy. I have rescanned the Library...no joy I have refreshed the Music Video...no joy. 2) Is there supposed to be a "artist.xml" in the artist folder? (none are being created...just wondering)
×
×
  • Create New...