Jump to content

Search the Community

Showing results for tags 'Random'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 8 results

  1. lloydcodrington

    TV series are playing in random order

    Hi Emby Team, I am not sure when it really started happening, but guess it was since the 3.3.x.x.x update. When I select a TV series and decide to play from the beginning, a complete or partial season or a few episode of a current season through to the end it ends up playing in a random order. When I check the Kodi playlist it displays the remaining shows in a random order. When I play direct from the Kodi menu system it plays in the correct order. So let's say that I've not watched the last three more more episodes of a particular series I would normally go to the next episode to be viewed and press play. With 'Auto play next episode' activated it use to continue in proper order but now it randomises the order playing each, once. So it's just the order of play that is wrong. Has this issue been raised before and are there any ideas on how to overcome this issue? Lloyd
  2. foghorntom

    DVR random stops N minutes into recording

    fglog.txtMy DVR works well most of the time, but frequently will fall out of record mode, just a dead stop. One from last night log is attached. I got 2 minutes of Family Guy. Far as I know there was no disruption of the "server", and I use that term loosely, I am running a W-10 PC that's not far north of the minimum requirements. 8G of RAM, AMD X2 255 3.1 GHz 2 core which I suspect might be the weakness. Any advice on how to upgrade the "server" would be welcomed. Thanks
  3. arrbee99

    Improving Shuffle for music

    As per Luke's suggestion, turning this into a feature request - It would be nice if Shuffle didn't get killed if I pick another song to play while its already in shuffle mode, or in other words I want to skip the song its decided to play but still shuffle and move on to the next song. In relation to this, when I click Shuffle, the Shuffle button doesn't visually change to show its been selected, This would also be useful to click again to Unshuffle. If this can't be done, a Skip This Track button would be nice. Hope this isn't too confusing - it confuses me when I read through it....
  4. Arelion

    Emby Server randomly stops working

    Hi guys, I'm worthless at Linux overall but trying to learn more and more so bear with me in this case and I barely know how to read the log file either so ...... >.> My issue is that my Emby-server randomly just stops working on my Ubuntu 17.04. I try to run "sudo service emby-server start" when it stops working but that doesn't help so I have to restart my whole server. ​I have my shares mapped via fstab if that helps anything but I guess this isn't the issue as the same shares have been used by Plex earlier and worked like a charm. My Emby server is like 2 weeks old and I have had it updated 2 times I think but no update solved it. I have attached a Log-file that I took right after I restarted my server. Any help I can get is much appreciated! Log.txt
  5. Hi guys, Tonight while playing a TV show using Emby addon, with direct streaming over HTTPS from Emby server, the playback stopped several times and went back to the episode selection. This happened to me at least 4-5 times in a 1hr episode. Waiting a few seconds and pressing <enter> on the episode, will resume playback most of the times but sometimes it will just restart playback from the beggining and I had to FF to the point when playback stopped. Emby server version: 3.0.5713.2 (latest beta) Emby Kodi addon version: 1.0.35 In the Kodi log I keep getting: ERROR: /storage/.kodi/addons/script.module.requests/lib/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning And everytime that playback stops: ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28) NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 1 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28) NOTICE: CCurlFile::FillBuffer - Reconnect, (re)try 2 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28) ERROR: CCurlFile::FillBuffer - Reconnect failed! I already checked on the server and transcoding is not in use at all but some errors are logged every time I start playback again. 2015-08-25 23:54:08.5992 Error - HttpServer: Error in ProcessAccept *** Error Report *** Version: 3.0.5713.2 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 3.10.0.229 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/lib/emby-server Mono: 4.0.1 (tarball Thu Jun 25 23:12:03 UTC 2015) Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe The authentication or decryption has failed. System.IO.IOException at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 InnerException: System.IO.IOException Error while sending TLS Alert (Fatal:InternalError): System.IO.IOException: EndWrite failure ---> System.Net.Sockets.SocketException: The socket has been shut down at System.Net.Sockets.Socket.EndSend (IAsyncResult result) [0x00000] in <filename unknown>:0 at System.Net.Sockets.NetworkStream.EndWrite (IAsyncResult ar) [0x00000] in <filename unknown>:0 --- End of inner exception stack trace --- at System.Net.Sockets.NetworkStream.EndWrite (IAsyncResult ar) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.EndSendRecord (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.InternalSendRecordCallback (IAsyncResult ar) [0x00000] in <filename unknown>:0 InnerException: System.IO.IOException EndWrite failure at System.Net.Sockets.NetworkStream.EndWrite (IAsyncResult ar) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.EndSendRecord (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.InternalSendRecordCallback (IAsyncResult ar) [0x00000] in <filename unknown>:0 InnerException: System.Net.Sockets.SocketException The socket has been shut down at System.Net.Sockets.Socket.EndSend (IAsyncResult result) [0x00000] in <filename unknown>:0 at System.Net.Sockets.NetworkStream.EndWrite (IAsyncResult ar) [0x00000] in <filename unknown>:0 2015-08-25 23:54:08.6162 Error - HttpServer: Error in ProcessAccept *** Error Report *** Version: 3.0.5713.2 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 3.10.0.229 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/lib/emby-server Mono: 4.0.1 (tarball Thu Jun 25 23:12:03 UTC 2015) Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe The authentication or decryption has failed. System.IO.IOException at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 InnerException: System.IO.IOException Error while sending TLS Alert (Fatal:HandshakeFailiure): Mono.Security.Protocol.Tls.TlsException: The client stopped the handshake. at Mono.Security.Protocol.Tls.SslServerStream.EndNegotiateHandshake (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 InnerException: Mono.Security.Protocol.Tls.TlsException The client stopped the handshake. at Mono.Security.Protocol.Tls.SslServerStream.EndNegotiateHandshake (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 2015-08-25 23:54:18.8848 Error - NotFoundHttpHandler: 192.168.7.31:8920 Request not found: /Videos/405d54115b8702070151cc5aba2093a5/405d54115b8702070151cc5aba2093a5/Subtitles/2/Stream.srt 2015-08-25 23:57:02.4431 Error - HttpServer: Error in ProcessAccept *** Error Report *** Version: 3.0.5713.2 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 3.10.0.229 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/lib/emby-server Mono: 4.0.1 (tarball Thu Jun 25 23:12:03 UTC 2015) Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe The authentication or decryption has failed. System.IO.IOException at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 InnerException: System.IO.IOException Error while sending TLS Alert (Fatal:InternalError): System.IO.IOException: EndWrite failure ---> System.Net.Sockets.SocketException: The socket has been shut down at System.Net.Sockets.Socket.EndSend (IAsyncResult result) [0x00000] in <filename unknown>:0 at System.Net.Sockets.NetworkStream.EndWrite (IAsyncResult ar) [0x00000] in <filename unknown>:0 --- End of inner exception stack trace --- at System.Net.Sockets.NetworkStream.EndWrite (IAsyncResult ar) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.EndSendRecord (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.InternalSendRecordCallback (IAsyncResult ar) [0x00000] in <filename unknown>:0 InnerException: System.IO.IOException EndWrite failure at System.Net.Sockets.NetworkStream.EndWrite (IAsyncResult ar) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.EndSendRecord (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.RecordProtocol.InternalSendRecordCallback (IAsyncResult ar) [0x00000] in <filename unknown>:0 InnerException: System.Net.Sockets.SocketException The socket has been shut down at System.Net.Sockets.Socket.EndSend (IAsyncResult result) [0x00000] in <filename unknown>:0 at System.Net.Sockets.NetworkStream.EndWrite (IAsyncResult ar) [0x00000] in <filename unknown>:0 2015-08-25 23:57:02.4630 Error - HttpServer: Error in ProcessAccept *** Error Report *** Version: 3.0.5713.2 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 3.10.0.229 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/lib/emby-server Mono: 4.0.1 (tarball Thu Jun 25 23:12:03 UTC 2015) Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe The authentication or decryption has failed. System.IO.IOException at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 InnerException: System.IO.IOException Error while sending TLS Alert (Fatal:HandshakeFailiure): Mono.Security.Protocol.Tls.TlsException: The client stopped the handshake. at Mono.Security.Protocol.Tls.SslServerStream.EndNegotiateHandshake (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 InnerException: Mono.Security.Protocol.Tls.TlsException The client stopped the handshake. at Mono.Security.Protocol.Tls.SslServerStream.EndNegotiateHandshake (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0 2015-08-25 23:57:16.8627 Error - NotFoundHttpHandler: 192.168.7.31:8920 Request not found: /Videos/405d54115b8702070151cc5aba2093a5/405d54115b8702070151cc5aba2093a5/Subtitles/2/Stream.srt Please note the subtitle stream error, but subs are working just fine. The network is solid too, I'm using a wired connection. Plus I never have this kinds of problem before without using the Emby addon (direct NFS play), or using it with Emby addon direct play/local paths (using NFS too). I don't have time to check direct stream over HTTP tonight but I will do it tomorrow to verify if the problem is in any way related to the protocol in use. One last note: in the addon setting I had defined the IP address of the server to connect to, not the name, but the server certificate CN value holds the server fqdn instead. Maybe the HTTPS warning in Kodi logs but also on server logs is related to that? Thanks in advance for your help. kodi.log.gz
  6. If you are running an Ubuntu or Debian server and mono version 3.10 or older or 4.0 or newer and are experiencing random crashing of Emby with no errors in your logs, you might be experiencing an issue related to a bug in the kernel. Finally one of the Sonarr devs popped in and helped us figure out a possible solution to the problem. (that quote is from http://emby.media/community/index.php?/topic/19955-emby-crashing-ubuntu-server/page-5&do=findComment&comment=207271) Once users started upgrading their kernels to as new as 4.0, they reported that the stability of Emby has greatly improved. Here are some instructions on how to upgrade your kernel without having to do a distro upgrade: http://askubuntu.com/questions/119080/how-to-update-kernel-to-the-latest-mainline-version-without-any-distro-upgrade Also, a few users reported that they were still experiencing crashed even though they weren't running Emby in a VM. Many of them also reported that a kernel upgrade actually fixed their problem. If you are still having issues with Emby crashing after a kernel upgrade and you don't know why, please let us know.
  7. I know MBT doesn't have random play natively, but I can send random play from the MBS remote. However, it only works if I send a TV series with a limited number of episodes. For example, If I send a random play for It's Always Sunny in Philadelphia, it works. This series has about 100 episodes. Instead, if I send a random play for South Park, which has over 200 episodes, nothing happens. I'm not sure if this is an MBS issue or an MBT issue, but if I try to do the same thing with MBC, it works fine. Therefore, I think there is some sort of limit that MBT is imposing. Is there any way to fix this?
  8. bobafett_h

    Music feature requests

    I understand that there is still a lot of work to be done with regards to music in MB3, but I wanted to submit some of the requests I have been looking for, but never found all at the same time in a media player. Hopefully all of these can be implemented at some point in the future as it would definitely satisfy all of my needs with regards to music playback. Crossfader Media Browser definitely needs a crossfader with options for amount of time to crossfade and whether to fade out when stopping playback or not. Also the option to cross fade only tracks within the same albums or artist might be useful too. Playback options Play modes - Alphabetical (plays tracks in order of track name) Numerical (plays tracks in order of track number) Random (plays tracks in a random order) Repeat (plays tracks again after finishing) Play from - All Genre Album Artist Artist Album Year Playlist If currently browsing a specific Genre/Artist/Album/etc., the play mode should only play music from that Genre/Artist/Album/etc. Otherwise, MB should request for the source to be chosen. Mutiple Genres/Artists/Albums/etc. should be able to be selected from a simple folder tree view of the entire library. When using Random, tracks should be played only from the chosen Genre/Artist/Album/etc. and can play from multiple Genres/Artists/Albums/etc. if they are also selected. The Repeat mode should be able to be combined with other play modes. Should also be able to use Repeat when only playing single tracks. Party Mode There should be an option to prevent people from exiting Media Browser, the Music library or the Music Now Playing screen without using some kind of remote/keyboard shortcut with a PIN/Password to unlock it. This could allow for other people to add songs from the library to the playlist themselves, or stop anyone from messing with it at all during a party or something like that. Now Playing Visualisations It would be great to have a variety of visualisation options for the Now Playing screen built-in, with the ability to add more via plug-ins (WinAmp style). Options should include whether the Album Art is displayed, what size it is displayed at, the screen position it is displayed and whether it is always displayed or only during the beginning/middle/end of the song or not at all. The same would go for other track details such as Artist, Album, Track number, Track title, Year, Genre, Rating or other comments if applicable. Things like the font, font size and font colour should also be customisable, even when a Theme is being used. There should be various background options such as something like the Album Art waterfall in Windows Media Center. It should be possible to tell it how fast to flow, whether to flow up/down/left/right, the size of the images, and whether or not it uses album art images from the entire library, or the current Genre/Artist/Year/Playlist/etc. ReplayGain Support Support for ReplayGain tags definitely needs to be included for both track and album gain. Using track gain values over album gain values can result in more consistent volume levels when playing random tracks from different albums. On the other hand album gain values are more recommended for listening to whole albums straight through. An option to use either track or album gain for different playback modes would be great.
×
×
  • Create New...