Jump to content

Search the Community

Showing results for tags 'Permissions'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hello Community, I was hoping someone else is having a similar problem and perhaps know the reason why after the second to last update of Emby, my collections vanished (both user created, and those generated by the box set plugin). At first I thought it had to be ownership/permissions had become muddled, but all other writes are allowed (updates to metadata, metadata refreshes on intervals, favourites) Here is a breakdown of my formerly working setup: Emby running on Docker - app folder in home directory to utilize the SSD benefit. OS: Fedora 33 - kept up to date d
  2. Hello! I recently moved emby to a dedicated server. I installed Kubuntu and added cifs-commons (sudo apt install cifs-commons). My media is on a Synology Diskstation DS918. The config of the library is set to store nfo files and pics alongside the movie in the corresponding movie-folder. In my understanding (after reading a lot of similar problems from other people) that emby is using the user "emby" for file-access. As mentioned from @Lukein different threads, in ubuntu the access to a smb-shares should be done via mounting the share and accessing the mount-point (because
  3. I've read through countless threads on this topic with similar situations and I cant find the solution. I have all my media on an external HD. When I'm setting up the server, I go to add a folder for the media, the file path doesn't show up. And when I manually type in the path I get; "The path could not be found. Please ensure the path is valid and try again.". How can I specifically grant emby:emby permissions to access my external? When I use; ls -l /path/to/media Every file is permissioned my username and my group. How can I change this? Thanks!
  4. binerf

    Sync to any device

    Hi all, I'm using Emby to share library to family but I was surprised when I discovered that a user can sync any file from its authorized libraries to any device previosuly connected to Emby even if this user has never logged this device (even if this device belongs to another guy). How is it possible to limit devices to user's devices only that Emby admin has no knowledge of ?
  5. al92780

    Permissions after editing photo

    Photos load correctly from library, external SSD and are viewable. When an edit is performed, they no longer load. Permission has been changed from (Pi:Pi -all,all,all to pi:pi - only owner, only owner, nobody. I can manually change back to all,all,all. Is there a configuration setting that would not require manual intervention. am logged in as pi@raspberrypi. thanks al
  6. Hi, I’m trying to setup Emby on my Intel NUC. I’m new to OpenSUSE Tumbleweed (though not to Linux) and I’m struggling to get this sorted out. I’ve had Emby running on Mint for sometime now. Goal: to setup & use Emby (Emby software apps is already installed and running) Hurdle: give Emby access to the media files (stored on external HDDs) I have external hard drives formatted as exFAT and NTFS (I’m working on switching them all over to exFAT but not there yet). I currently have my primary username set as the owner of the drives and the group is set to “users” (of whic
  7. Hello, I am now running Emby on windows 10 and wondering what user account does Emby use ? I know for linux its Emby user and Ebmy group. I am needing to mount my SMB share drive to windows for Emby to use. What credentials do I need to make available to Emby? Can I run Emby server as a service and specify my own user account / password for the service to run under?
  8. Miljol Dedy

    Bug Report: Group Permissions

    I think I have found a bug in Emby 4.3.1.0 on Synology. On my NAS I have groups instead of direct permissions. So ONLY the group has direct permissions. When I added the Emby user to the group of the folder for the library, I was not able to choose the folder. When selecting it just disappeared (just like when you have no permission). So, when giving the user direct permission it worked like a charm. I guest this is not as it supposed to be...
  9. xsteacy

    Windows sofware raid on linux

    Hi, I need emby to access a Windows formatted raid in linux. I mounted the raid with the ldmtool but I cannot access the files with emby. I gave emby access to the drive with chown but with no luck. I saw lots of posts in Google and here about that but for normal drive... I use Elementary OS 5.1(bases on Ubuntu 18.04) Thank you for any help, all is welcome.
  10. Hi All, Firstly, thank you for any help you are able to provide. I've been trying to get this working for 4 days and it's driving me crazy. I'm new to Linux so please bear with me. I have a AWS instance running Ubuntu 18 and a virtual Google Drive mounted to /gdrive using rclone which works fine. I can navigate through the files in the /gdrive folder using the Linux terminal as expected, great. The issue I'm facing is when I navigate to http://localhost:8096 and chose the "Add media library" option, it cannot see the folder /gdrive. If I then un-mount my google drive from the gdriv
  11. riothamus

    Fixed my NFS issue

    Background: I hate CIFS/Samba (just kidding, I loathe that technology) so my setup consists of a CentOS server that also acts as an NFS server containing all of my media. Emby runs on a separate Debian server, and it mounts the NFS shares via autofs. I have been wondering why my metadata was not getting saved back to the media directories on my NFS exports. So I got off my lazy arse and actually started to do some real troubleshooting. Initially, my /etc/exports consisted of shares configured like so: /srv/nfs/media 192.168.100.0/24(rw,async,no_root_squash) And on my Debian serve
  12. kmed27

    Help needed with permissions

    Hi I am trying to get Emby to add my cameras videos automatically but seem to be struggling with permissions. I have created a folder on my nas for my cctv camera and it creates the mp4 files in it via NFS. I have ended up giving full permission to everything and everyone in the synology folder but I keep getting xxxxxx.mp4: Permission denied I have given Embysvr custom permissions with everything ticked take ownership, change permissions etc. I have tried setting the NFS to map users to admin and then tried map to guest. It appears that ffmpeg/ffprobe still don't have permis
  13. rubenmf92

    Emby permissions problem

    Hi @@mastrmind11, @@Q-Droid, I think a have a permissions problem with emby. I´m trying to see two different external hard drives, but I only manage to see one of them. The permissions and owner of the one I can properly see is: drw------- 4 root root 4096 sep 19 19:29 mnt drwxr-xr-x 3 root root 4096 jun 30 11:30 mntSubfolder1 drwxr-sr-x 4 root root 4096 sep 17 20:07 mntSubfolder2 drwxr-sr-x 4 userftp sftponly 4096 ago 25 19:50 Movies As you can see, I'm able to see the files even when emby does not belong to the group or owner. On the contrary, I´m not able to
  14. Hello all. I apologize in advance if this is long and sound nuts. I have just about lost my mind as I have spent last 5 days on Google and these forums trying desperately to get Emby to work. (by the way I have seen the software work on a friend at work and was blown away so I immediately signed up for premiere account. So I know it is possible and will be great once I get it going. Only difference is I want to use Linux and not windows like my friend. Major Kudos to the developer for this awesome software.) To my problem, as stated in title, I'm running Emby on a (at first) headless U
  15. I am unable to run 4.2.1.0 on NixOS. Last known running version is 4.0.1.0. I am getting the following error: Aug 14 18:42:31 nixos systemd[1]: Started Emby Media Server. Aug 14 18:42:31 nixos emby[13309]: Unhandled Exception: System.IO.IOException: Read-only file system Aug 14 18:42:31 nixos emby[13309]: at System.IO.FileSystem.CreateDirectory(String fullPath) Aug 14 18:42:31 nixos emby[13309]: at System.IO.Directory.CreateDirectory(String path) Aug 14 18:42:31 nixos emby[13309]: at EmbyServer.Support.ApplicationPathProvider.GetProgramDataPath(String applicationPath, IEnvironme
  16. Ok.. I have been able to compile and install a custom ffmpeg with OMX (hardware encoding enabled) https://emby.media/community/index.php?/topic/36227-h264-omx-instead-of-x264/page-2 But when enabled in the Emby server.. it silently fails.. HOWEVER... When I copy/paste the command (for example): ffmpeg -i file:"/media/usb0/TV Shows/SpongeBob SquarePants (1999-2015) [480p] [720p] [HEVC] [x265]/Season 01/[pseudo] S01E02 Reef Blower [480p] [h.265].mkv" -map_metadata -1 -map_chapters -1 -threads 0 -map 0:0 -map 0:1 -map -0:s -codec:v:0 h264_omx -b:v 2211644 -maxrate 2211644 -bufs
  17. (I searched for the permissions problem but didn't see it. Sorry if I'm repeating other posts here...) I set up the Emby Theater app on Windows for my mother and was careful to not let her do any admin-type stuff, but she is able to cancel my recordings (any recording - movie, show episode or series)! I double-checked the permissions and double-checked them again. As it stands, she doesn't have permission to make her own recordings, or to delete shows or movies, but she can cancel my recordings. I've asked her to be careful not to do that. Also, if you use the large-format icons
  18. I have a couple of directories that are hidden trash folders, as in the output below: 2018-07-30 16:05:29.895 Error LibraryMonitor: Error in Directory watcher for: /misc/movies3 *** Error Report *** Version: 3.5.1.0 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-rpm_{version}_x86_64.rpm Operating system: Unix 4.17.9.200 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 4 Program data path: /var/lib/emby A
  19. vl1969

    a few quick questions on Emby use.

    Hi everyone. I have a home server running Proxmox VE 4.5 on ZFS the server has several ZFS pools where I store my data. i.e. custom user pools not connected to Proxmox except that the main machine hosts the disks. I want to create a VM container (LXC) where I will run Emby and other apps. Proxmox have a number of templates from TurnKey that I can use to create my container(s). I have tried the turnkey Mediaserver which is a TurnKey fileserver plus Emby. it works for the most part and works nicely but as I tried to setup additional things on it I broke the config and it has issues n
  20. I can get Emby Server to install ok on Raspbian. I can load it up and everything works, except that it can't read my storage device. Raspbian file explorer sees the storage and I can view the movies, but when I type that path to add to my library, it says it's not valid. I have zero experience here. I'm just googling what I can, but a lot of it is over my head. Can someone please help me out with a ELI5? Thank you!
  21. Emby WebUI - Please create a general device that represents all web browsers At present, its impossible to restrict users to only the WebUI without granting permissions to all devices. It would be good to have a device in devices, that represents the webUI or all web browsers in general. This way permission can be granted to users without granting permission to all devices. This would serve as a solution to allow only downloading (no streaming, no transcoding, no direct play, etc) Only browse library and file download.
  22. It would be really nice if there were more granular permissions per user. Right now you can only give a user broad delete permissions. I don't want users deleting anything except for TV Recordings (and ideally only ones that they owned or recorded unless the user had admin delete permissions or something). Right now I have only an admin account that is used to delete media and have to periodically go through and clean out recorded TV because users can't delete themselves.
  23. bric

    File permissions again

    Failure setting up Emby (my first time) I have a hard drive in my 'server' that contains all my media. It is formatted as NTFS. I have it mounted from the fstab. listing of files/directories show as ... -rwxr-xr-x 1 bric bric 110914782 Jun 16 21:11 Finding Dory-trailer.mov drwxr-xr-x 1 bric bric 4096 Jul 30 15:09 Home Video I added emby to the group owning the files on that drive. So the groups command returns: emby: emby bric When I try to add the media library (in the web interface) either with /path/to/mounted/drive/Movies or //192.168.0.10/Movies or //MyServer
  24. Long-ish question, *hopefully* easy answer: I recently upgraded from several external hard drives to a QNAP NAS. After testing the QNAP Emby app server performance, I preferred the old Windows-based server overall and thus the new QNAP is purely operating as the NAS, not the server (hence this forum). That being said... Similar to a question I had awhile back here, after changing my library media folders to the new NAS folders, I am again having difficulty saving metadata into local media folders (rather than in a generic "metadata" folder in the server files). When I add new content, the
  25. .17 I have permissions turned off for most of my users for any type of Live TV functionality. Users that don't have permissions are still seeing the ON NOW section on home screen of the app and regardless of their permissions they can access and play any live tv feed featured in ON NOW.
×
×
  • Create New...