Jump to content

Search the Community

Showing results for tags 'MPC-HC'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

  • Community Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 25 results

  1. Emby External Player Launcher (E2PL) Emby External Player Launcher is a simple and pretty basic .NET application that connects an external video player to an Emby server as a playback device. MPC-HC is currently supported, MPC-BE should work as well and more players may be coming in the future. E2PL lets you play videos from your Emby library straight to MPC-HC, provides remote control support for essential commands and will automatically sync viewing progress to your library. I wrote E2PL for my own personal use, I wanted to watch videos using MPC-HC on my Windows desktop while also keeping everything nicely synchronized with my Emby library, which I access from multiple devices. I simply leave E2PL running in the background, use the Emby web interface to select it as a playback device and play videos. I decided to also release it since it may be useful to other people as well. General features: Play videos from your Emby library in MPC-HC Automatic viewing progress synchronization Resuming in-progress videos Remote control: E2PL will translate essential remote control commands from the Emby web interface to MPC-HC (stop, pause/unpause, seek and volume control are supported) Easy to run: no special install required, simply run the program Doesn't get in the way: E2PL only appears as a tray icon and works in the background once configured Free and open source: anyone can contribute or have a look at the source (GPLv3 licensed) E2PL uses direct playback in order to launch MPC-HC, the videos have to be stored on your PC or on a network share that can be accessed. The Emby server itself isn't involved in the playback process, which also means that transcoding isn't supported. Where to get it: On GitHub. There is more detailed information available in the ReadMe as well as the source code and pre-built binary versions you can simply download from the Releases section. If you just want to download it, click here and get the latest release. Make sure to read the ReadMe for some instructions. Support: If you're using E2PL and are experiencing issues, let me know and I'll try to help. As for further development, I will very likely keep E2PL working with new versions of Emby if compatibility breaks since I'm using it myself. I may also look into adding support for mpv and Mono/Linux in the future, but I have no specific plans at this point. Using E2PL and have a suggestion or some feedback? Let me know.
  2. Would like to be able to resume playback using external player such as MPC-HC with Emby Theater. This was possible with Emby on WMC,activated through the "web interface" in MPC-HC somehow. Just switched my HTPC to Win 10 and did not realize it was not a feature with ET. Thanks, CFC
  3. Hi there, I recently updated to emby premire in my new WIN10 configuration, until now I was using MPC-HC as an external player in the MB3 version. Now I can't configure MPC-HC as the external player. It seems to be so easy but I can't make i works: C:\Program Files\MPC-HC\mpc-hc64.exe in the player path area {path} in the command line arguments area There are no more options, but it doesn't work, always the same error when trying to reproduce any movie... Error launching process: Type error: Cannot read property 'toString' of undefined. Emby works fine with the internal player, there are no problems with the archives which can be opened without problem with the MPC-HC when tried directly. What can I do? Many thanks in advance.
  4. Hi, no idea what changed but suddenly nothing will play using MPC-HC as an external player. I've removed it from the Emby for WMC Configurator, removed and reinstalled MPC-HC, Added it again in the configurator but to no avail. If I use the internal player everything plays fine. If I could turn subtitles on or off on the fly then I would leave the internal player set. Anyone any idea? It's probably something really simple I am missing! Oh, I've reinstalled Server and Emby WMC apps too. Kind regards, Cog.
  5. RIP, you were a pal for a long time! https://mpc-hc.org/2017/07/16/1.7.13-released-and-farewell/ I've been using the native player for about a year now, but MPC served me well in the early days. Sorry to see it go!
  6. I wonder if anyone can assist! I have 2 PC's with same setup: Windows Media Center with Emby Server & Mediabrowser Classic. I have installed MPC-HC on both with exactly the same settings which I have checked thoroughly about 7 times now before wasting anyone's time here. The issue is that when I start Media Center and go to play a file, MPC-HC is playing behind Mediabrowser Classic. I can exit Mediabrowser Classic and MPC-HC will still be playing but I lose functionality of forward or backwards. I would have to exit this too. I have attached screenshots of the PC which is the issue and showing my configuration for Mediabrowser Classic and the other is showing it working correctly. Same settings remember though. I have uninstalled Mediabrowser Classic and even went to the folder where the settings are held in User Roaming etc and deleted. Did the same in ProgrammeData but the settings came back after I installed it again. Am I missing something here?
  7. Hello, I hope it this is the right place to put this because my problem is about to the legacy version of Emby Theater. I want to use MPC-HC as an external player out of MBT but the file always starts from the beginning. At the dashboard it shows me which file is playing (until I close the player) but not the position of the play progress. As I understood, I have to activate the web interface by using the "listen to port" checkmark in MPC-HC. My command line arguments in the external player settings in MBT are: {PATH} /start {ms} /fullscreen /play /close any help would be greatly appreciated
  8. zebo51

    Emby Not playing full 5.1

    I have always used chrome in the past to access my media and played content via the browser. Just noticed today that I'm not getting surround sound. I spent a lot of time updating drivers, messing with settings etc. It works fine when watching movies from my cable provider. Finally narrowed it down to chrome and firefox. Using IE I can hear sound on my surround speakers. I have an AMD Radeon HD 5500 video card with HDMI out to my AVR, so it handles audio. Running Win 8.1. If I go into my windows sounds configuration it is set to 5.1 and the test sounds each speaker. Also if I play using an external player like MPC-HC, sounds work in all speakers. So not sure what is going on now. Any ideas? Is there a better way/experience to view movies on my main media PC? Several years ago I used to use media browser theater I think it was, but switched to a browser which was easier to use for navigating etc with a wireless KB/Mouse. Thanks
  9. Hi all, I'm using: Emby Server Version 3.0.5785.0 MB Theatre 3.0.5848.25554 I use TMT6 as an external player for BD and DVD playback. I use MPC-HC as an external player for all other media content. The "Continue watching" (resume) feature works fine for any content played back using MPC-HC but not for content played back via TMT6. My 'Resume' settings in Emby Server are as follows: Min resume %: 5 Max resume %: 95 Min resume duration: 300 I think these are the default settings. I've had this problems since I first installed MB (as was) and MBT a couple of years back. How can I troubleshoot this further? Let me know if you need me to upload logs. Many thanks
  10. Scenario: Using EMC (Media Browser Classic in WMC). Loading External Players. Issues: 1. When loading MPC-HC with MadVR from EMC it sometimes starts to play audio only but sometimes plays fine. I either need to right click a mouse (not very reasonable as this is supposed to be all controlled with a remote) to get the file to play or I need to try repeatedly by stopping the playback and starting over from one to three times to get video playback. 2. ISO mounting. I have the configurator set to load TMT5 set for playback for ISO only and I have Elaborate Bytes Virtual Clone Drive set as the ISO mounter in the ISO and Extender tab. I have Mikhano's ISO mounter for WMC also installed. The iso's are not mounting nor playing back, unless I mount them prior to loading EMC which is not good as EMC loads when WMC loads when I Select HTPC on my Harmony Remote. Any assistance would be appreciated.. My logs from yesterday and previously when this occurred will not open correctly and I get the following from ServiceStack: Response Status Error CodeOutOfMemoryExceptionMessageException of type 'System.OutOfMemoryException' was thrown.Stack Trace[GetLogFile: 1/4/2016 8:54:42 PM]: [REQUEST: {Name:server-63587389501.txt}] System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown. at System.Text.StringBuilder.ToString() at System.IO.StreamReader.<ReadToEndAsyncInternal>d__19.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task) at MediaBrowser.Server.Implementations.HttpServer.HttpResultFactory.<GetStaticResult>d__7.MoveNext() I will try to grab a log immediately next time this occurs but stopping to do something like that lowers WAF tremendously! Thanks.
  11. Hi all, I'm continuing this from another thread that was veering a bit off-topic and I hope I'm in the right forum. Basically the problem is this: I need to get the MB-C interface working 100% without keyboard and mouse. I had it about 90% there but there was one huge problem: Subtitles. I have a number of foreign-language films that I prefer to watch in the native language with English subs. Windows Media Center really has no way to handle this, so it was suggested that I try MPC-HC. While MPC-HC is more feature rich, I'm having some extreme problems that are making it impossible to use. Mouse pointer is always on the screen When I press STOP the player stops but doesn't go back to MB-Classic (just sits there with a black screen and the word STOPPED in the corner). Subtitles in .ISO files are not being recognized (i.e. the option for subtitles is greyed out). Subtitles in MPC-HC do work with .MKV, but not .ISO. Since my wife and I need to invoke this feature often, having subtitles accessible by remote is mission critical for us. And while I can invoke them with the keyboard, I prefer to keep both it and the mouse locked up unless I'm doing config or maintenance on the system--and even then, I prefer to do that via remote from another PC. I know a lot of people are using the MPC-HC/WB-C combination so I'm sure this is old-hat to some on here. I've got a full day of tinkering into this already and every change I make seems to be a dead end. Can all three of these problems be solved? Thanks to all. And if this is the wrong forum or Website, if anybody can point me to the right place I'd also be mightly greatful. Please and Thanks!
  12. I have Emby for Kodi installed and the server configured with Cinema Mode enabled to play 2 trailers then my intro video. I use MPC-HC as an external player and configured in playcorefactory.xml as follows: <rules action="prepend"> <rule filetypes="mkv|mp4|m4v|mov|m2v|avi|divx|ts|mpeg|mpg|ogm|iso|wmv|flv" player="MPC-HC"> <rule name="streams" protocols="daap|m2ts|rtv|rtsp|rtmp|rtmpe|http|https|rtsp|mms|rtp|pvr" player="DVDPlayer"/> </rule> </rules> (Intro video is in .m2ts format) In previous versions of the add-on, it would play the 2 trailers and intro video in DVDPlayer then switch to MPC-HC to play the movie (mkv file). Now when I select a movie, it plays the 2 trailers and intro video in DVDPlayer, then plays the movie in DVDPlayer as well. It never switches to MPC-HC. I did notice that previously, when it was playing the trailers and intro video, the Kodi status bar (that shows when you move the mouse) would show the name of the trailer (or intro video) and would allow me to skip the trailer/video and go right to the movie with the ->| button. Now, it only shows the name of the movie, (even though the trailer/intro is currently playing) and doesn't allow me to skip them, e.g. nothing happens when I click that button. I remember reading somewhere that Cinema Mode creates a playlist for Kodi, (which would explain how I could skip the trailers/intro), but now it seems like it doesn't do that anymore. Now it appears to concatenate them all together into one. I'm using direct play (SMB path is reachable from Kodi machine), but not direct stream, (play from HTTP isn't enabled) or local paths for the movie. I'd like to get back to the way it was, as I'd like to continue to use MPC-HC. I've attached the log file. Thanks, Dave kodi.log
  13. Pirlo1966

    ANSWERED File not found

    Hi I replaced paths on Emby server: volume1/Media/Film/Movies by \\NAS1815\Media\Film\Movies Whenever I try to play a movie form Emby Theater with MPC-HC as an external player, MPC-HC opens but indicates it cannot find a file?? What am I missing? Should I do something extra besides replacing paths? Playing the same media directly for MPC-HC works well. The ET-log when launching a movie: 2015-08-08 23:27:14.4124 Info - App: C:\Program Files (x86)\MPC-HC\mpc-hc.exe "\\\NAS1815\Media\Film\Movies\3 10 to Yuma (2007)\3 10 to Yuma (2007).mkv" /play /close /fullscreen 2015-08-08 23:27:14.4244 Debug - ApiClient: ReportPlaybackStart: Item 15948721cd70ceadb367a80c00452f49 2015-08-08 23:27:14.4244 Debug - ScreensaverManager: Calling SetThreadExecutionState to prevent system idle 2015-08-08 23:27:14.4244 Debug - ApiClient: POST http://192.168.1.100:8096/mediabrowser/Sessions/Playing?format=json 2015-08-08 23:27:14.5125 Info - ApiClient: Received web socket message: PlaybackStart 2015-08-08 23:27:14.5255 Debug - ApiClient: Received 204 status code after 102,0964 ms from POST: http://192.168.1.100:8096/mediabrowser/Sessions/Playing?format=json 2015-08-08 23:27:15.0390 Info - ApiClient: Received web socket message: UserDataChanged 2015-08-08 23:27:21.8207 Debug - ScreensaverManager: Calling SetThreadExecutionState to allow system idle 2015-08-08 23:27:21.8207 Debug - ApiClient: POST http://192.168.1.100:8096/mediabrowser/Sessions/Playing/Stopped?format=json 2015-08-08 23:27:21.8337 Info - ApiClient: Received web socket message: PlaybackStopped 2015-08-08 23:27:21.8337 Debug - ApiClient: Received 204 status code after 15,0137 ms from POST: http://192.168.1.100:8096/mediabrowser/Sessions/Playing/Stopped?format=json 2015-08-08 23:27:22.3792 Info - ApiClient: Received web socket message: UserDataChanged
  14. Pirlo1966

    ANSWERED External player no launching?

    I Istalled emby server on my synology NAS DS1815+. Library (>1500 HD movies, >1.200 HD episodes and >20.000 MP3's) took ages to build. All seems fine now. However, I use Emby for WMC with MPC-HC as external player. That worked fine with emby server installed on the same client. With emby server installed on my NAS MPC-HC is no longer launched. The internal mediacenter player is used with the emby custom layer. Playback is very choppy. I have the impression that media is transcoded instead of streamed to my client for decoding. How do I make sure that there is no transcoding done on my NAS and how to make sure MPC-HC is launched instead of the internal player? thanks!
  15. I've setup MPC-HC as an external player (to get audio bitstreaming) and everything is working perfectly except that about every 15 minutes MPC-HC stop/closes and returns me to the Emby WMC/Classic interface. I checked the screensaver settings on Emby WMC thinking that maybe this was causing it but it is set to kick in at 5 minutes. The PC itself has screensaver disabled. Not sure why I keep getting dumped out of MPC-HC. If anyone has anything thoughts that would be great. I'm not familiar with MPC-HC as this is my first time setting it up and using it. I pretty much kept vanilla settings except for changing output to use madvr and changing subtitle render engine. Thanks for any assistance.
  16. Is it even possible to use an external player with Kodi + Emby addon? I tried various players and means, but can't get it to work. If YOU have managed to get Kobi and Emby to work with an external player (MPC-HC / MPC-BE / DS Player), could you let me know how? Thanks heaps for the help...
  17. 'Force close player on stop button' is not working with MPC-HC as external player. When I press the stop button, playback does into 'stop' and stays in that state. Yes, I'm aware it works with VLC, so please don't post a reply saying this. VLC is causing other issues so I am not using it. I'm using MPC-HC version 1.7.7 which is the current stable build.
  18. Have had a search for an answer to this but either I've missed it or am doing something wrong! I recall when adding MPC-HC as an external player through MBC configurator (on previous installs) that there was an option to have the settings for MPC-HC automagically configured for you by clicking a 'configure my player' link (or did it just pop up?). On the last two installs I've tried on two separate machines (WIndows 7 Home Premium 64bit and Windows 8.1 Pro 64bit) I can't see that option when adding MPC-HC (and no pop up has presented itself). Could there be something blocking it or has that feature been removed from either MBC or MPC-HC? if this isn't a simple one please let me know if I can provide more info to diagnose. ....and before anyone wastes any time on this I've answered my own question - found that its been removed by reading the release notes! Sorry all :S
  19. PeteWhite67

    MB3 & MPC-HC Playlists

    Hi, how do I get MBC3 to recognise a MPC-HC playlist (*.mpcpl) as a valid file? Thanks in advance, Pete
  20. When I hit the play button nothing happens anymore after the last server update. Using MPC-HC as external player. When I remove the external player the play button works again but with the internal player. Do I need to configure something new? Edit: Internal player also does not play the content. Rolled back the Server "System.old" folder and all working fine again.
  21. im trying to get stable ISO playback. VLC was working, but has begun crashing -badly, so that i need to hard reset. so, i installed MPC... looks nice, only, i cannot navigate the DVD menus with keyboard or mouse... any ideas (i checked the MPC config, and im using the correct keys)
  22. I am still having problems in Server version Version 3.0.5264.17006 and Theater 3.05243.22734 playing back .wtv recorded TV programs with MPC-HC 1.7.5 set as the external player for .wtv files Specifically, subtitles do not display and are greyed out I cannot jump past commercials using the harmony remote. Skip forward is not working. And stop does not return me to Theater. I am getting a lengthy filter list in MPC-HC: iTV MPEG-2 Section and Tables madVR Default Direct Sound Device PBDA DT Filter LAV Video Decoder (internal) Audio Switcher PBDA DT Filter LAV Audio Decoder (internal) Stream Buffer Source However, the recorded TV show will play and 720 is upscaled to 1080 so the video quality is improved.
  23. AdrianW

    MPC-HC Time display

    With the WMC player when pausing playback, the progress bar appears so you know how far you are through a video. I've been trying to setup MPC-HC with MadVR and I can't find a way to display a video's progress on screen using a remote (it can be done my moving a mouse pointer to the base of the screen, but a mouse isn't always handy in the TV room). Does anyone know how to do this or if it's even possible. It's kind of important as my wife watches a lot of Asian dramas with subs, and often the subs have typos, so she likes to record the time and then she gets me to fix the subs for her later. I'm not going to be popular if she can't easily discover the time point where she is in a video.
  24. Hi folks, I've noticed something odd, that has repeated a few times, but I'm not sure I can completely reproduce it. I've used MPC-HC (currently the latest release, 1.70 something...) quite a bit, and I've got it freshly installed on my new Win7x64 system. One of the things I like to do with it is go frame by frame through movie action sequences and the like and see neat stuff in each still that you can't see properly when the movie is playing. Anyway, I recently added MPC-HC as an official external player in MBC. I assigned it in the configurator and let it do some configurations (which messed up my key assignments, but that's another minor story). About a day after doing the setup in MPC-configurator, I noticed that anytime I frame stepped a sequence, it wasn't smooth. It looked like it was doing short seeks instead of one frame after another. Kinda messed up. I've got a defined key that I assigned to do frame stepping (right arrow, and I've made sure nothing else is defined as right arrow that would interfere). I reinstalled MPC-HC and the problem went away. I re-configured MPC-HC through the configurator, and eventually the problem came back. I just noticed it now. I think it didn't come back until the next time I started MBC, or maybe did an upgrade (tonight). I never had this problem before running the MBC Configurator... what exactly is it doing, and how might it be interfering with frame step to make it not do nice even frame by frame steps but instead jerky seeks? Thanks for any light that can be shed on this. Marc
  25. Continuing this issue at the new forum cause it is not solved yet. When I have watched an episode of any serie (mostly mkv files) I delete the episode once I have watched it. This has always worked well in MB2 and also in the beginning of MB3 and MBC. Since the last few updates and that is for a few weeks now I’m having issues with deleting those episodes. Most of the time it takes way to long before MBC says the item has been deleted from the server etc. The spinning icon stays in the screen for over 30 seconds mostley before I can continue watching something else. But sometimes it just deletes an episode immediately like it did before. ebr mentioned that this could be theme related but after testing with several themes like NEO, default theme and since the last week or two ROC theme there is no differents between these themes. With all of them the delete behaviour is the same. Because it does delete normally sometimes there must be something causing this. It’s also not pc related because I have tested on multiple pc’s and my wife has complained about this to and asked me when this will be solved? I just watched a few episodes of Under the dome and after watching episode 6 the delete went fast like it should but after watching episode 7 it was really slow again. Maybe the log explains more about why this is. Earlier ebr mentioned that my log shows different times about how long the delete takes but I can assure you that the time the spining icon stays in my screen till MBC tells me the item has been deleted from the server is at least 30 seconds if not more. Also I told ebr about the delete sound that sometimes is hearable twice in row and mosly when that happens the delete will be fast. I hope this can be solved once and for all even if it seems that I’m the only one having this issue. Windows 7 x64 (Dutch) the delete sound is called recycle.wav and is in the folder C:\Windows\Media Todays log right after watching the latest episodes from Under the dome. MBC Log
×
×
  • Create New...